1 2 Previous Next 17 Replies Latest reply on Oct 13, 2016 8:18 AM by jesc

    Windows ( 8.1 )updates keeps breaking my RAID 5.

    Anius

      First the question if anyone can answer that would be great.

       

      1)     What is the difference ( in Windows 8.1 ) between clicking on the power icon ==> selecting shutdown VS power icon ==> select shift + restart ==> select shutdown ( from the next screen).?

      2)     Can I somehow manually setup the System Volume flag in RST?

       

      Background:

       

      I installed a RAID 5 setup on my computers ( actually I tried it on another computer before with the same result) .  Initial install was with a HP recovery DVD with Windows 8.1. Initial install went fine. after a couple of days and lots of updates, my computer would only start after a long delay and a couple of restarts.

      When it did restart I noticed, when I shutdown the computer the HDD light would stay on for a long time about 20 seconds. and then the computer would power off. My guess is its writing something and windows actually shuts it down before it has a chance to finish.  In the meanwhile, the RAID volume has also become unmarked as a system volume.

      The only way I can do a clean shutdown which I somehow happened upon accidentally , is to select shift+restart and from the options shutdown in which case it shuts down normally within three seconds.

       

      More background:

                I tried setting up RAID on a different computer before too but ran into problems after running updates. I now believe its something within the Windows 8.1 cumulative update. ( Microsoft released a cumulative update for windows 8.1  patch all the windows 8.1 updates  ).  On my previous setup ( z87 and 3X OCZ SSDs + clean Windows 8.1 Enterprise install ), I was having a similar issue ( i,e it all started off fine, but after a few days after Windows updates, the Volume would loose the "system disk" flag in  RST and then it wouldn't start properly.

                Actually this is my THIRD setup,  I also tried installing Windows 8, upgrading to Windows 8.1 ( up-to that point  all was fine. ) but then after a couple of days after more updates the result.

       

       

      If anyone needs any other info other than listed below feel free to ask.

       

      I realize some people might say , its a Microsoft issue ( which I agree with), Unfortunately Microsoft has officially stated in several spots that RAID 5 as a Boot drive is not possible ( which I don't agree with), How  ever that means I can ask Microsoft for assistance on this.

       

       

       

      Specs of the present setup:

      z75 chipset HP motherboard

      4X OCZ SSDz

      i7 cpu

       

      present software specs:

       

      RST :13.1.0.1058

      chipset drivers: 12.8.2.1000

        • 1. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
          sylvia_intel

          Hello Anius, I’m sorry for the inconvenience that you have faced with your motherboard.

          Regarding your questions:

          1. I suggest you to contact Microsoft since this information will be handling by them.

          2. About your 2nd question, I would need to to be a little more specific on this request. What do you mean by “System Volume flag in RST?


          I recommend you installing the previous version of Intel® Rapid Storage Technology 12.9 and check if you are still getting the same behavior.  Intel® Download Center    


          Please verify the status of the RAID on Ctrl + I. if the RAID is healthy and all hard drivers appears as members  of the array, then issue could be relate to the system volume and not the RAID array.


          • It would be necessary to set up the RAID manually from scratch on the Ctrl + I. Then, run the recovery DVD from HP.
          • If for any chance this DVD includes and RST version, please uninstall it.
          • Once you updated all drivers if there are not issues, you can run all required Windows updates.
          • Finally try installing the Intel® Rapid Storage Technology.
          • 2. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
            Anius

            I was able to find a workaround and understand the first issue actually by disabling the fast-boot option. When using the option of the troubleshooting, I guess the the computer doesn't use fast-boot. So it wasn't having a problem.  So while It doesn't start in 3 seconds But 6 seconds is fast enough for me and whenever the incompatibility is figured out by either microsoft or intel we'll see at that time.

             

            For the seconds issue please see the screenshot below of the intel Rapid Storage Technology application. The drive shows normal and bootable in the ctrl+I firmware application.  Also I must point out , I have seen the same issue arise on several installs as pointed out in the first post. Where after a few days of updates it changes from "System Volume : Yes to No.

             

            2014-07-28_16-34-20.gif

             

            I have tried different versions of iRST ( 12.8, 12.9 and of-course the current version with no resolution ) .

            • 3. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
              sylvia_intel

              Anius, base on the information provided and since you already tried different versions of the Intel® Rapid Storage Technology; this seems to be a hardware situation more than a software issue.

               

              According to the information of the picture on your previous post, the Operating System is not included on the RAID array; therefore it is not a bootable volume.

              Would you pleas confirm to me if the OS is or not included on the array?

               

              Did this behavior started after a Windows 8.1 updated?

              • 4. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                Anius

                The RAID is definitely Bootable.

                 

                To clarify, I have 4 drives in a RAID5 configuration on the system. There are no other disks attached ( to boot from ). The initial Intel boot firmware shows up fine ( RAID disks present and Volume is marked as bootable ). once in Windows , when running the Rapid Storage Technology, this is what shows.

                 

                To explain more,, This is NOT the case when initial windows setup is done. initially for a few days and thru several sets of updates this shows up correctly as it should ( as a boot volume ).

                 

                I have seen the same thing happen on different physical computers, and using different methods of install.

                1) Using OEM HP Windows 8 restore and then updating to 8.1

                2) Using Microsoft Windows 8.1 enterprise image followed by updates.

                3) Using HP OEM Windows 8.1 restore and then doing updates.

                 

                One computer had the Z87 chip-set and the current one has Z75.

                 

                Every time Windows remains OK for a couple of days and then this happens.  I *think* I did notice that this seemed to occur after the Windows 8.1 cumulative update was applied. ( Not Windows 8.1 service pack  rather Microsoft released a cumulative pack of about 800M or so to patch all windows 8.1 computers ).

                I believe its a software issue because Aside from the fact that i saw it on two different computers, for all intents and purposes ( other than the two Ive mentioned, the system behaves normally as far as I can tell )..

                 

                2014-07-29_13-07-02.gif

                • 5. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                  sylvia_intel

                  Anius, can you try to update the BIOS on the boards is order to update the option ROM?

                  If the behavior continues, this could be a problem with the RAID chipset and it will be necessary to replace the motherboard.

                  • 6. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                    Anius

                    On the computer with the Z87 chip-set I experienced the issue across two different BIOS versions ( albeit neither BIOS versions had a Intel storage firmware update ).  For the current one ( with the Z75 motherboard ) , it on the current release version.

                    • 7. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                      Anius

                      I believe I have correctly diagnosed the situation with the help of the thread linked below.

                      System Volume Wrong

                       

                      The issue is a *bug* in the Intel RST software  whereas it marks whatever volume the system uses to host the page file.  Looking at the aforementioned thread I noticed that in the screenshot provided the software was marking the drive with the page file as the system volume. In my case i was not using a page file at all.  So to test it I enabled a page file and the result is shown below after a restart.

                       

                      page file.gif

                      Up-to this point the only difference in the system is that the page file enabled again.

                      Since I do not need a page file I'll disable the page file again and post the result shortly.

                      • 8. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                        Anius

                        Same computer 3 minutes after with the page file disabled.

                         

                        Pagefile disabled.gif

                         

                         

                        Just an FYI I believe this needs to be escalated for verification and rectification.

                        • 9. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                          sylvia_intel

                          Thanks for your findings on this issue Anius. I’m going to report this right away to the corresponding team.

                          • 10. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                            Anius

                            There have been a couple of updates of the iRST and the issue is still there.  I am wondering if this just didn't make the cut in time for release , or it couldn't be verified to be an issue( something else entirely )?

                            (* issue still persists with ver.  13.2.4.1000).

                            • 11. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                              sylvia_intel

                              Let me check on this.

                              • 12. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                                sylvia_intel

                                I'm still waiting for an updated Anius. I apologize

                                • 13. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                                  sylvia_intel

                                  Anius, I just request an update regarding this software.  Are you still using version 13.1? Could you try using version 12.9?

                                  • 14. Re: Windows ( 8.1 )updates keeps breaking my RAID 5.
                                    Anius

                                    yes I  Just tried the 12.9 again and its still doeskin work ( altho I don't understand why it would when I have said that it doesn't work ). I also tried 13.5 and that as expected doesn't work either.

                                     

                                    If you were given feedback to try 12.9 I think the developers are being lazy and just didn't want to try it.  I presume they just said to try 12.9 because the thread refers to the z75chipset and they wanted to wash their hands off this by saying that the newer RST doesn't support  the 7series chip-set, however  In my first post i explained that the issue also exists in my z87 chip-set setup.

                                     

                                    If  Intel doesn't want to fix this as it requires a deepdive( and it doesn't look like anyone is working on it ), its no sweat off my back.

                                    1 2 Previous Next