5 Replies Latest reply on Jul 30, 2014 3:50 PM by Wurst

    Can't find boot device on 2820fykh NUC

    emakaay

      After 2 weeks of use (intel nuc 2820FYKH), the unit gives me the following error message "a bootable device has not been detected"

       

      I didn't change anything to the system (hardware it was like before). Bios wise it was like before. The only thing that could be different is Ubuntu (14.04) which updates automatically.

      I was using bios version 0.34 (Uefi/ACHI). I tried resolving the problem by updating the bios to version 0.38. But this didn't fix anything.

       

      I removed the SSD (kingston 16GB) and noticed that the uefi boot entries  were removed (as expected.

      After that I reinstalled the SSD, and the uefi boot entries were back again. So the SSD is detected correctly.

       

      I even reinstalled ubuntu 14.04 again. That went perfectly. The SSD was detected by NUC and Ubuntu installer.

      But afterwards the NUC would still not boot.

       

      Any Ideas how to resolve this problem ?

        • 1. Re: Can't find boot device on 2820fykh NUC
          joe_intel

          Hi emakaay, perhaps you may want to check if there is a firmware update for the SSD.

          • 2. Re: Can't find boot device on 2820fykh NUC
            Tex_Mex

            Did you check the support for Linux? There is some support doco on what the correct settings are that Intel released. I followed it for Windows 8.Documents & Guides for the Intel® NUC Kit DN2820FYKH

            • 3. Re: Can't find boot device on 2820fykh NUC
              Wurst

              Ha, you went into the same trap as me

               

              But there is help!

               

              It has nothing to do with SSD firmwares or anything else the (sorry!) rather clueless people here suggest.

               

              When the GRUB bootloader is updated (a few days ago this was the case via an Ubuntu system update, I'm sure your problem arose after that update), the boot files in the hidden EFI partition are changed in a way so that the UEFI of the NUC is not able to boot anymore.

               

              This unfortunately happens each time such a GRUB update is installed.

               

              Fortunately there is a workaround which is a bit hard to find:

               

              Re: D34010WYK No UEFI Boot Devices

               

              This also works perfectly on the DN2820FYKH. Now Ubuntu can always update GRUB like it wants to, it doesn't affect bootability.

               

              Only drawback is that the NUC needs a bit longer for booting. (Can be sped up by reducing the preconfigured time-outs.) Otherwise, Ubuntu runs just fine on the device, no problems so far.aps

               

              P.S.: Since there obviously are quite a number of Linux users here, could this workaround somehow be pinned or get into a FAQ of some sorts?

              • 4. Re: Can't find boot device on 2820fykh NUC
                emakaay

                Thanks everybody,

                 

                especially Wurst because now I know what caused the problem.

                That bothered me the most. Not knowing what was the reason for not booting. I was working perfectly before.

                 

                I resolved the problem by doing the following (not in front of NUC, so these are the steps I remember)

                - Disable legacy boot

                - Enable secure boot

                - Remove all uefi entries (there is some option to do this, can;t remember how it is called).

                - Reinstall my NUC using ubuntu server 14.04 on USB stick.

                - bootloader was installed perfectly

                 

                I hope Ubuntu will fix this problem

                • 5. Re: Can't find boot device on 2820fykh NUC
                  Wurst
                  As I said: The next time Ubuntu does a GRUB update you will have the same problem. It's not very likely that it will be fixed by Ubuntu,  so the workaround posted by me is the only true solution. Why don't you simply apply it? You won't have any disadvantages...