5 Replies Latest reply on Jul 30, 2014 2:47 PM by BillyBarty

    Problems with USB Shell Example: Linux_USBShell.ino

    BillyBarty

      Hello everyone,

       

           I tried the example "Linux_USBShell.ino" which is in package that I downloaded from here.  The upload (to Galileo on COM5) using the Arduino IDE completed without error.  I then proceeded according to the directions presented in the comments of the sketch:

       

      ... "use your favourite terminal emulator (we used puTTY) to connect to your Galileo's

      COM port (it's the same one you use to connect Galileo to the Arduino IDE).

      Baud rate is 115200."

       

      I used PuTTY (COM5) with baud rate set to 115200 as instructed:

      SNAG-0045.jpgSNAG-0048.jpgSNAG-0047.jpg

      However, I do not successfully connect.  The session just hangs:

      SNAG-0046.jpg

      More information:

      *I am using Windows 7

      *I am working with a fresh install of firmware version 1.0.2

      *Arduino IDE version is 1.5.3

      *I have no SD card installed

      *Here is the "about" screen for the PuTTY I am using:

      SNAG-0050.jpg

      Is there something wrong with my PuTTY settings?

      Are then any other prerequisites needed for this example to work?

       

      Any help would be greatly appreciated.

       

      Thanks,

      Bill

        • 1. Re: Problems with USB Shell Example: Linux_USBShell.ino
          JPMontero_Intel

          Hi BillyBarty

           

          I've tried to replicate your issue. I uploaded the example sketch to my Galileo and followed the same steps you did, but it worked for me. It starts a blank session in the Putty but as soon as I hit Enter it displays the clanton login request. I’m using Putty 0.63, I set on Serial line COM4 (USB cable connected to USB client of the Galileo) and the baud speed to 115200. I hope you find this useful.

           

          Regards,
          JPMontero_Intel

          1 of 1 people found this helpful
          • 2. Re: Problems with USB Shell Example: Linux_USBShell.ino
            BillyBarty

            Hi JPMontero_Intel,

             

                 Thanks for looking at my post and trying to duplicate the issue.  I tried again using PuTTY 0.63.  I got further than before in that I get the login prompt, can then log in as root, and then see a terminal prompt.  However, as soon as I enter a command (like "ls" in the below screenshot), the terminal hangs up on me.  I then have to killy the PuTTY session, reboot the board, and re-upload the sketch (since I am not booting from an SD card) in order to try again.  Are you changing any of the default PuTTY settings for Serial other than the port and the baud rate?

            SNAG-0051.jpg

            Thanks,

            BB

            • 3. Re: Problems with USB Shell Example: Linux_USBShell.ino
              JPMontero_Intel

              I used the default Putty settings the only thing I changed is the port and the baud speed. What is different in my configuration to yours is the Flow control from the Serial settings, I have it on XON/OFF.

              Regards,

              JPMontero_Intel

              • 4. Re: Problems with USB Shell Example: Linux_USBShell.ino
                BillyBarty

                Now I have tried booting off the SD card and am getting further along.  Now I can at least enter a command without it hanging up, but whether the command works or not is intermittent.  I try starting bash and the command is accepted (prompt comes back at least without error), but then any command after that causes the session to hang.  At that point, I have to reboot (but at least I don't have to re-download the sketch since I am now booting from an SD card) before I can successfully connect again.  Here is a representative screenshot depicting all of the above described phenomena (notice how "pwd" doesn't work, then works, and then stops working; and then I enter "bash", and then enter "pwd" and the screen hangs up):

                SNAG-0052.jpg

                Thanks,

                BB

                • 5. Re: Problems with USB Shell Example: Linux_USBShell.ino
                  BillyBarty

                  Just to put this one to rest in case anyone else has similar problems, here is the summary of what works best for me regarding the "Linux_USBShell.ino" example:

                   

                  1) Had to boot from the SD card (no luck if booted from the SPI flash)

                  2) I sporadically get "command not found" error due to the fact that, for whatever reason, the first character of the command is (sporadically) not received by the board.

                  3) I have to hit enter a few times (or maybe do a <Ctrl-C> or two) before the command that was yeileding the "command not found" error starts to work.

                   

                  This is sufficient for my limited needs, so I am satisfied with this.