6 Replies Latest reply on Sep 5, 2015 10:03 AM by devillegas3

    i5-4590 Machine Check Exception

    Comar

      Hello,

       

      I am the owner of Intel Core i5-4590 on G1.Sniper B5 motherboard and the two sticks of Kingston RAM (2x4GB DDR3 HyperX Genesis model KHX1600C9D3/4GX).


      The problem is that when you try to run installers of popular operating systems like Linux Ubuntu (ex. 14.04), Elementary OS, Fedora OS, etc. computer hangs (freezes) when loading the desktop environment. Only when you boot a kernel with nolapic parameter (for use only one CPU core) such problem does not occur.

       

      If I manage to boot an distro, then in the occasion of hardware rendering in the browser such as Chrome, on Steam, etc. also the problem exists My PC is not responding to any type of key combinations CTRL + ALT + DEL, CTRL + ALT + F1 etc.

       

      First I thought it might be a problem with the graphics driver or the graphics card itself. While I have two graphics cards:


      • integrated Intel HD Graphics card a / processor
      • and Sapphire Radeon HD 6790 1GB DDR5

       

      By default, I used the latter, namely the Radeon HD 6790, but it turned out that regardless of what drivers I use, whether it is the open-source or proprietary driver supplied by the manufacturer (AMD) stable and BETA as well - the problem still occurs. Therefore, I have totally disconnected and took the card from my computer, using only Intel GPU - the problem also occurs.


      I was able to read the content of the error messages from kernel:


      mce: [Hardware Error]: CPU 0: Machine Check Exception: 5 Bank 4: ba00000052000402

      mce: [Hardware Error]: RIP !INEXACT! 10:<ffffffff811ae6c4> {__mem_cgroup_count_vm_event+0x54/0x60}

      mce: [Hardware Error]: TSC 40679099be

      mce: [Hardware Error]: PROCESSOR 0:306c3 TIME 1406020749 SOCKET 0 APIC 0 microcode 17

      mce: [Hardware Error]: Run the above through 'mcelog --ascii'

      mce: [Hardware Error]: Some CPUs didn't answer in synchronization

      mce: [Hardware Error]: Machine check: Invalid

      Kernel panic - not syncing: Fatal machine check on current CPU

      Shutting down cpus with NMI

      drm_kms_helper: panic occurred, switching back to text console

      Rebooting in 30 seconds..

       

      To diagnose the problem I made the following:


      • I've tested the computer work both on the integrated and additional Sapphire Radeon HD 6790.
      • I tested the RAM. Full Memtest86 does not show any errors.
      • I traded places the sticks of RAM, and was putting them in different slots on the motherboard (the sticks of the 1 and 2 slot put into the slot 3 and 4).
      • I compiled the latest version of the kernel from kernel.org version 3.15.6.
      • I took from the motherboard not only the graphics card, but also all other extensions, such as a memory card reader or the front panel (AC97 audio), optical drive, etc.
      • Finally, I decided to update the BIOS to version F8 (the stable at the present day), as previously used the version F6, but it also did not help.

       

      I realize that this may also be a problem with the motherboard, not necessarily with a processor, but I decided to write here to you because I hope that based on the error message you could give me some tips or some important information about the problem and its nature.

       

      Best regards,

      Comar

        • 1. Re: i5-4590 Machine Check Exception
          sylvia_intel

          Hello Comar, thanks for contacting us through the Intel Communities.

           

          First of all it is important to tell you that we validated our products and provide drivers for Windows Operating system.

          However, in order to find out if you have a defective processor you can try running the following tool in Linux.  It is called Intel® Processor Diagnostic Tool but this is the Linux* bootable version. Processors — What is the Intel® Processor Diagnostic Tool?    

           

          At the end, this tool will let you know if your processor failed or passed the test.

           

           

           

          • 2. Re: i5-4590 Machine Check Exception
            Comar

            Hello Sylvia, thank you for your reply.

             

            Of course, I realize that Windows is the main supported system, but Intel supports Linux in many ways and even provides software and drivers for this system, so I believe that the fact that I use Linux does not discriminate against me among the users, and I can count on your help.

             

            As far as I know Machine Check Exception error isn't software related, and when it comes to diagnosis you cannot trust such diagnostic tools unconditionally.

             

            I was hoping that thanks to the error message that I attached I can get some information from you about possible reasons. It's quite unique error, so I think it must be understandable for your engineers. Without such information, I am helpless and left alone, with no chance of getting a solution.

             

            Comar

            • 3. Re: i5-4590 Machine Check Exception
              devillegas3

              Hello Comar

              I have an Intel i5 4590 with a GA-H97-D3H motherboard and presented a very similar error. I updated the BIOS to version F5 is the most current for this motherboard but the error is still there.

              I'm using GNU/Linux for the last year and although we often have headaches with hardware support at the end we did dominate although this problem has escaped my hands. Like you, not if it's a problem with the motherboard or CPU is a problem.

              He problem occurs both with integrated video and with the NVIDIA 650 TI. I contacted Gigabyte who says I have not had similar reports and install the appropriate drivers from their website.

              I have identified the error when trying to view any video in html5 on GNU/Linux and so the same in Windows 8.1 with all the official drivers from then motherboard but only happens to see any video in Google Chrome.

              I tried different settings with RAM memory, disabling the C-States (C1/E, C6/C7), TurboBost, VT among other parameters in the BIOS but the problem is still there.

              I wonder if you could achieve solve the problem because not to do, not what is

              the defective component, if the motherboard or CPU?

              Sorry for my English

              Thank You

              Daniel

               

              Machine:

              CPU: Intel Core i5 4590 (BX80646I54590)

              Motherboard: GA-H97-D3H (1.0)

              BIOS Ver: F5

              Video: Nvidia GeForce GTX 650 Ti

              Memory: Kingston 8GB - KHX16C9B1BK2/8X

              Power Supply: EVGA 500w (P/N: 100-W1-0500-KR)

              Operation System: GNU/Linux Ubuntu 14.04 LTS – GNU/Linux Opensuse 13.2

               

              IMG_20150105_152123.jpg

              • 4. Re: i5-4590 Machine Check Exception
                zrx8

                Hi,

                 

                I ran into the same "kernel panic - not syncing" with several live linux distros.

                The config is similar to the aboves:

                i5 4460 + Gigabyte GA GA-H97-D3H (rev. 1.0) + 2x4 Gb Kingston@1600MHz


                Is there any progress in this issue ? Please reply, it would be very urgent.


                Thanks in advance,

                p


                 

                • 5. Re: i5-4590 Machine Check Exception
                  hansb_intel

                  Hello zrx8,

                  I would suggest to run the diagnostic tool posted by Sylvia to see if there is a problem with the processor and also wait for other users to share their feedback.

                  • 6. Re: i5-4590 Machine Check Exception
                    devillegas3

                    Hello zrx8
                    My i5 4590 processor was tested on another computer for over a month with a friend without receiving any crash. Back home I retested with a BIOS update (F6) of the Gigabyte GA-H97-D3H (rev. 1.0) and the error remains.
                    Testing calmly loading the defaults the problem persists with the videos in html5.
                    I've noticed something curious is that by looking at the frequency of CPU, turbo boost operates erroneously to climb 3 cores to 3700MHz when the i5 4590 processor can only adjust the frequencies of single 2 core and 3.
                    The Machine Check error occurs when 3 of the 4 cores reach 3700MHZ.
                    There are some bugs between the motherboard GA-H97-D3H that the cpu overclocker more than support.
                    To me it has worked so far 2 things:
                    1. Disable the Turbo Boost leaving all other defaults.
                    2. Manually adjust the frequency of Turbo Boost in the BIOS, 100MHz reducing each core.
                    I dismissed the problem of CPU to another computer with Z87 chipset, and possibly test recommended Sylvia satisfactory as me.
                    Test and please share.
                    Thank you and sorry for my English