1 Reply Latest reply on Jul 23, 2014 3:15 PM by joe_intel

    SSDSA2BW16G3H, 8MB "bug", and impossibility to SET_MAX_ADDRESS

    prm

      Hi everyone,

       

      this SSD has been struck by the 8MB "bug"/behaviour, I'm desperately looking for a way to recover as much data as possible

      (therefore, I guess that the security erase procedure is not the best fit for the problem).

       

      It is currently at firmware level 4PC10362 that - iirc - is the latest available from the Intel site for this family (and the update tool says it's already updated).

       

      I tried to run hdparm -N /dev/sda (that actually queries the SSD for the current and max possible address) and I get a reasonable response: 16384/nnnnnnnnn (that is: currently set to 16Kblocks, that is, 8MBs, and the maximum value matches the maximum capacity).

       

      unfortunately, if I try to run hdparm -N nnnnnnnnnn /dev/sda (temporary setting) or hdparm -N pnnnnnnnnnn /dev/sda (permanent setting), even with lower block counts,

      hdparm says that SET_MAX_ADDRESS is failing for "input/output error"

       

      I tried to also run the unofficial HDAT2 bootable iso but it appears that it cannot remount itself and make the commands actually available "or something", I guess that anyway it cannot do any magic itself and would resort to SET_MAX_ADDRESS or the like.

       

      any suggestions?

       

      thanks a lot!