2 Replies Latest reply on Aug 29, 2014 7:04 PM by puckmad

    Intel NUC 34010WYKH CIR issue

    puckmad

      First off - please excuse my linux ignorance. I followed the nuci3hometheatresolution guide V2 from the Intel website to set up Linux Mint and XBMC but I messed up the lircd part by choosing "custom" as my remote type. I thought it may be as simple as removing and reinstalling lirc but I can no longer get to the lirc menu where you choose the remote type. Below is a copy of my terminal commands and results. Any help would be appreciated.

       

      mike@HTPC ~ $ sudo apt-get install lirc
      Reading package lists... Done
      Building dependency tree      
      Reading state information... Done
      Suggested packages:
        lirc-x
      The following NEW packages will be installed:
        lirc
      0 upgraded, 1 newly installed, 0 to remove and 302 not upgraded.
      Need to get 0 B/378 kB of archives.
      After this operation, 2,371 kB of additional disk space will be used.
      Preconfiguring packages ...
      Selecting previously unselected package lirc.
      (Reading database ... 150130 files and directories currently installed.)
      Preparing to unpack .../lirc_0.9.0-0ubuntu5_amd64.deb ...
      Unpacking lirc (0.9.0-0ubuntu5) ...
      Processing triggers for ureadahead (0.100.0-16) ...
      ureadahead will be reprofiled on next reboot
      Processing triggers for man-db (2.6.7.1-1) ...
      Processing triggers for doc-base (0.10.5) ...
      Processing 1 added doc-base file...
      Registering documents with scrollkeeper...
      Setting up lirc (0.9.0-0ubuntu5) ...
      * Loading LIRC modules                                                                                                                                                                                                                [ OK ]
      find: `/sys/class/rc/*/': No such file or directory
      * Starting remote control daemon(s) :

        • 1. Re: Intel NUC 34010WYKH CIR issue
          TON

          Your problem is related to the fact that removing lirc still leaves its configuration files in place for the case you need them later. In order to remove the package completely together with the config files you need to run 'apt-get purge <packet name>'. The better alternative for you should be just re-running the package reconfiguration. So try to run 'apt-get reconfigure lirc'.

           

          Hope this helps.

          • 2. Re: Intel NUC 34010WYKH CIR issue
            puckmad

            I have been away so haven't tried this till now. Purge solved my issue. Thankyou very much for your help.