5 Replies Latest reply on Jul 29, 2014 7:20 AM by allan_intel

    Laptop with Mobile Intel 945 Express Chipset boots to blank/black screen

    jd.hupp

      I have a Lenovo 3000 C200 laptop with Intel T2080 CPU, 1 GB RAM, running Vista Business 32-bit.  The OEM 1024x768 screen was broken, and I took the opportunity to upgrade to a 1400x1050 panel, which the Mobile Intel 945 Express Chipset specs say should be supported.  But after displaying the Lenovo BIOS splash and the Windows pre-login progress bar, the screen blanks and does nothing further.  But I hear the login prompt chime, and I can log in (blindly) and then hear the Windows startup chime.  If I boot with or hot-plug an external LCD monitor, that too has a blank screen.  I also tried a remote control session into the machine via Google Chrome Remote Desktop, and that also showed the blank screen.

       

      I can boot into Safe Mode OK.  And if I disable the Intel 945 device driver, then I can also boot into Normal Mode with a low-res default display driver.

       

      The replacement panel is an AU Optronics B150PG01.

       

      I tried several drivers for the Intel 945: Mobile Intel 945 Express Chipset Family provided by Intel Corp, 10/22/2008, ver 7.15.10.1587 (this was the Lenovo download).  I have also tried the slightly older version that is the latest one available directly from Intel.  I have also tried the one available from Windows Updates.  All fail the same way.

       

      This laptop is dual-booting with Lubuntu 14.04, and that display driver works fine, which confirms that the Intel 945 hardware supports 1400x1050, and also confirms that the BIOS is not restricting the supported display modes.

       

      I have another Lenovo 3000 C200 here configured much the same way, but it does not have the blank screen problem.  Its configuration differs slightly in that it has 2GB RAM instead of the 1GB on the problem machine (though I have now also tested it with 2GB, which made no difference), and it has the original 1024x768 display instead of 1400x1050 as on the problem machine.

       

      Also worth noting: The machine that works OK only has one Intel 945 display adapter device.  The problem machine has two, though I understand that this is actually the expected behavior (see http://www.intel.com/support/graphics/intel945gm/sb/CS-022194.htm).  If on the problem machine I disable the display device for PCI bus 0, device 2, function 0, then the other device disappears, there are effectively 0 display adapters installed, Windows uses a default display device, and I can boot into normal mode and set the resolution to a max of 1280x1024.  It's a bit fuzzy at this non-native res, but at least it's in the ballpark of expected behavior.

       

      And yes, I did flash to the latest BIOS and update everything.

       

      Is there a way to get this running properly under Vista?