1 Reply Latest reply on Jul 24, 2014 12:28 PM by IT Center

    How to create AlarmClock instance with wsman client?

    alex-sh

      Hi,

      I'm just trying to create Alarm Clock with wsman utility, but I couldn't figure out how to do it, can somebody help me?
      Trying to execute this command:

      root$ wsman put -k ElementName"DefAlert" -k StartTime="2014-07-15T22:00:00Z"-k Interval="PT12M" -k DeleteOnCompletion="true" http://intel.com/wbem/wscim/1/ips-schema/1/IPS_AlarmClockOccurrence?InstanceID="DefAlert" --port 16992 -h 192.168.0.14 --username admin -p "Admin44$" -V -v

      I get such response:

      <?xml version="1.0" encoding="UTF-8"?>
      <a:Envelope xmlns:g="http://schemas.dmtf.org/wbem/wsman/1/cimbinding.xsd" xmlns:f="http://schemas.xmlsoap.org/ws/2004/08/eventing" xmlns:e="http://schemas.dmtf.org/wbem/wsman/1/wsman.xsd" xmlns:d="http://schemas.xmlsoap.org/ws/2004/09/transfer" xmlns:c="http://schemas.xmlsoap.org/ws/2004/09/enumeration" xmlns:b="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:a="http://www.w3.org/2003/05/soap-envelope" xmlns:h="http://schemas.xmlsoap.org/ws/2005/02/trust" xmlns:i="http://docs.oasis-open.org/wss/2004/01/oasis-200401-wss-wssecurity-secext-1.0.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

        <a:Header>
          <b:To>http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous</b:To>
          <b:RelatesTo>uuid:1e82a3fe-fe28-1e28-8002-e6b2e3bae690</b:RelatesTo>
          <b:Action a:mustUnderstand="true">http://schemas.xmlsoap.org/ws/2004/08/addressing/fault</b:Action>
          <b:MessageID>uuid:00000000-8086-8086-8086-00000000075B</b:MessageID>
        </a:Header>
        <a:Body>
          <a:Fault>
            <a:Code>
              <a:Value>a:Sender</a:Value>
              <a:Subcode>
                <a:Value>b:DestinationUnreachable</a:Value>
              </a:Subcode>
            </a:Code>
            <a:Reason>
              <a:Text xml:lang="en-US">No route can be determined to reach the destination role defined by the WSAddressing To.</a:Text>
            </a:Reason>
            <a:Detail>
              <e:FaultDetail>http://schemas.dmtf.org/wbem/wsman/1/wsman/faultDetail/InvalidResourceURI</e:FaultDetail>
            </a:Detail>
          </a:Fault>
        </a:Body>
      </a:Envelope>
      Connection failed. response code = 400

      What am I doing wrong?