6 Replies Latest reply on Jul 13, 2014 5:56 PM by Rushang.Karia

    Problem with my new Galileo board

    Smaro10

      Hi everyone,

       

      I'm a beginner in Galileo world. I've just received my Galileo, it's amazing. I tried different sketches and they work properly on the RAM.

      To go further with my board I've tried to set Linux on it with the official: LINUX_IMAGE_FOR_SD_Intel_Galileo_v1.0.2.

      To do so, I formatted my 2GB SDCard with the official SDFormatter from: https://www.sdcard.org/downloads/formatter_4/ and then I unzipped theLINUX_IMAGE archive on my SDCard then I switched on my board with the SDCard plugged into.

      I waited a little while as it's written in the official Galileo GettingStarted manual to be sure the cryptographic keys are generated.

      My problem has appeared when I tried to install a sketch over linux. It doesn't seem working. I uploaded the basic blink example and the LED doesn't blink at all even if I reboot the board.

       

      Did someone experience this problem? And is there any mistake in the here-above process?

       

      For information:

      Board Firmware Ver: 1.0.0

      IDE Version: 1.5.3

      Linux Version: 1.0.2

      OS: Mac OS X 10.9

       

      Thank in advance for helping me with any idea.

      Have a nice day.

       

      Smarco10

        • 1. Re: Problem with my new Galileo board
          Rushang.Karia

          Hi,

           

          Did the basic blink example get successfully uploaded??? { Did the message on the arduino IDE show "Transfer Complete" at the end ??}

          Do you have a serial cable to observe the boot process?? Or when you inserted it for the first time, does the LED near the SD-card show a lot of bliinking?

          Did you format the SD-Card as FAT/Ext3

           

          First, Try downloading the IDE and updating the firmware { Click below if you use 64-bit or download a 32-bit instead }

          http://downloadmirror.intel.com/24000/eng/Intel_Galileo_Arduino_SW_1.5.3_on_Linux64bit_v1.0.2.tgz

           

          Help on how to update the firmware can be found in the Getting Started Guide

          Intel® Galileo Getting Started

           

          Try again and let us know.

          • 2. Re: Problem with my new Galileo board
            Smaro10

            Thank for this quick answer,

             

            For the first question, yes the upload process succeed as it was without linux.

            And no I don't have any serial cable, I think I'll buy one by the end of the next week.

            The LED near the SDCard blinks when the board starts.

            The SDCard is formatted in FAT32 and I copied linux files on its root.

             

            I've already downloaded the last IDE and updated the board firmware, that was my first action as it's written in the Getting Started Guide.

             

            I don't understand what's happening, because sketches work well without linux. So the problem should come from linux or the SDCard. I'll try whith another SDCard to check if it solves my problem.

             

            I'll keep you up.

            • 3. Re: Problem with my new Galileo board
              Smaro10

              I've just tried with another SDCard, which is a 16GB SDHC, and it's doing exactly the same think like with the other SD.

              So the problem isn't the SDCard but should be the board, linux or a mistake in the process to install linux or upload the sketch (I hope the last one).

               

              When we use the serial port, can we see the boot sequence process of linux?

              • 4. Re: Problem with my new Galileo board
                Rushang.Karia

                The SDCard is not the problem

                 

                Please update your firmware again just to be sure. I have detailed the instructions above. The board firmware should be in the latest version which is 1.0.2. I have not tried it so I am not sure if the latest download contains it but ideally it should.

                 

                Yes you will be able to see the boot sequence when you have a serial cable.

                If you have an ethernet cable it might be possible to do telnet and observe the Linux shell. Steps to do this are well documented in the Intel Community.

                 

                Since the sketch without Linux works there is something wrong during the SD-card setup phase and not with the board, I think.

                 

                I would try updating the board firmware. If it is in the latest firmware version then when you try to upgrade it will give you a prompt saying "the board is already in the latest firmware..do you want to continue updating ?"

                To be sure make sure you download the latest arduino IDE that I mentioned in the link in my previous reply.

                 

                Do that and let us know.

                 

                The Linux image that you downloaded says that, that version of Linux is for BOARD FIRMWARE v1.0.2 and it is not the Linux version. Since you mentioned board firmware 1.0.0 I think you should try to do that.

                 

                Also, you mention that the "transfer complete" message is shown even when the sd card is inserted right?

                1 of 1 people found this helpful
                • 5. Re: Problem with my new Galileo board
                  Smaro10

                  You've got a point with the board firmware version number.

                  I didn't know that. I downloaded the IDE a month ago and the linux image, yesterday so versions were different.

                  I updated the board and reinstalled the sketch and now that work perfectly.

                   

                  Thank you so much for your help.

                  Have a nice day.

                   

                  Smarco10

                  • 6. Re: Problem with my new Galileo board
                    Rushang.Karia

                    Welcome.

                     

                    Post any further problems that you in the community. Everybody is ready to help.

                     

                    Best of luck playing with your board!!