4 Replies Latest reply on Jul 9, 2014 5:29 PM by Rushang.Karia

    Bitbake error

    AnonyMouse

      Hello everyone, I am new to embedded programming and also Linux.

      I am not sure if I am supposed to post this question here or in some other forums, but maybe someone here knows so I am asking it anyway.

      I encounter an error during the building of Linux Image for Intel Galileo Board (both $ bitbake image-spi and $ bitbake image-full).

      I already made a search and encountered someone saying to downgrade the tar version.

      I would really appreciate any insight !

      Thanks.

      Details Below:

      ran from Virtual host - Ubuntu 14.04 LTS [x86_64]

      My tar version 1.27.1 [Somebody mentioned to downgrade to 1.26, but I cant do that on ubuntu 14.04 ]

      Terminal Output:

      Pseudo is not present but is required, building this first before the main build
      WARNING: Host distribution "Ubuntu-14.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.
      Loading cache: 100% |#########################################################################| ETA:  00:00:00
      Loaded 1617 entries from dependency cache.
      
      Build Configuration:
      BB_VERSION        = "1.18.0"
      BUILD_SYS         = "x86_64-linux"
      NATIVELSBSTRING   = "Ubuntu-14.04"
      TARGET_SYS        = "i586-poky-linux-uclibc"
      MACHINE           = "clanton"
      DISTRO            = "clanton-tiny"
      DISTRO_VERSION    = "1.4.2"
      TUNE_FEATURES     = "m32 i586"
      TARGET_FPU        = ""
      meta              
      meta-yocto        
      meta-yocto-bsp    = "clanton:e6129f8b337a261e03984c0c0bf45228475e7a0f"
      meta-intel        = "clanton:048def7bae8e3e1a11c91f5071f99bdcf8e6dd16"
      meta-oe           = "clanton:13ae5105ee30410136beeae66ec41ee4a8a2e2b0"
      meta-clanton-distro 
      meta-clanton-bsp  = "<unknown>:<unknown>"
      
      NOTE: Resolving any missing task queue dependencies
      NOTE: Preparing runqueue
      NOTE: Executing SetScene Tasks
      NOTE: Executing RunQueue Tasks
      ERROR: Function failed: sysroot_stage_all (see /home/ubuntu/Downloads/Board_Support_Package_Sources_for_Intel_Quark_v1.0.1/meta-clanton_v1.0.1/yocto_build/tmp/work/x86_64-linux/quilt-native/0.60-r0/temp/log.do_populate_sysroot.12386 for further information)
      ERROR: Logfile of failure stored in: /home/ubuntu/Downloads/Board_Support_Package_Sources_for_Intel_Quark_v1.0.1/meta-clanton_v1.0.1/yocto_build/tmp/work/x86_64-linux/quilt-native/0.60-r0/temp/log.do_populate_sysroot.12386
      Log data follows:
      | DEBUG: Executing python function sstate_task_prefunc
      | DEBUG: Python function sstate_task_prefunc finished
      | DEBUG: Executing python function do_populate_sysroot
      | DEBUG: Executing shell function sysroot_stage_all
      | tar: --same-order option cannot be used with -c
      | Try 'tar --help' or 'tar --usage' for more information.
      | tar: This does not look like a tar archive
      | tar: Exiting with failure status due to previous errors
      | DEBUG: Python function do_populate_sysroot finished
      | ERROR: Function failed: sysroot_stage_all (see /home/ubuntu/Downloads/Board_Support_Package_Sources_for_Intel_Quark_v1.0.1/meta-clanton_v1.0.1/yocto_build/tmp/work/x86_64-linux/quilt-native/0.60-r0/temp/log.do_populate_sysroot.12386 for further information)
      ERROR: Task 10 (/home/ubuntu/Downloads/Board_Support_Package_Sources_for_Intel_Quark_v1.0.1/meta-clanton_v1.0.1/poky/meta/recipes-devtools/quilt/quilt-native_0.60.bb, do_populate_sysroot) failed with exit code '1'
      NOTE: Tasks Summary: Attempted 23 tasks of which 22 didn't need to be rerun and 1 failed.
      No currently running tasks (7 of 63)
      
      Summary: 1 task failed:
        /home/ubuntu/Downloads/Board_Support_Package_Sources_for_Intel_Quark_v1.0.1/meta-clanton_v1.0.1/poky/meta/recipes-devtools/quilt/quilt-native_0.60.bb, do_populate_sysroot
      Summary: There was 1 WARNING message shown.
      Summary: There was 1 ERROR message shown,
      
      
      returning a non-zero exit code.
      
        • 1. Re: Bitbake error
          JPMontero_Intel

          I’d recommend you to try it with Ubuntu 12.04 instead of the 14.04, this is because some users have reported some issues with this version. Also make sure you have enough space to build the image, and just to clarify you need to download the version 12.04 from the Ubuntu website and install again, you cannot downgrade.
          Regards
          JPMontero_Intel

          • 2. Re: Bitbake error
            AlexT_Intel

            That's what I'd suggest too + don't use "image-spi" and "image-full" targets, nowadays you'd want "image-spi-galileo" and "image-full-galileo" instead.

            • 3. Re: Bitbake error
              pivan

              If you want to stick (at your risk, I do not suggest you to go this way) to Ubuntu 14.04 have a look here: https://www.yoctoproject.org/download/buildtools-sdk

              However, I solved all of my compilation issues switching to a Debian 7 (7.5) machine.

               

              Ivan

              • 4. Re: Bitbake error
                Rushang.Karia

                I am not sure if tar is causing the problem.

                 

                Also I want to point out that you are using too long file names.

                Try moving and renaming Board_* to something very small like /home/ubuntu/BSP so that your tree looks like ~/BSP/meta-*/*

                Do not use long file names. They are known to cause problems.

                 

                Again if you want to downgrade tar you need to rebuild it from source. I am not aware of other methods.

                 

                Get tar from the GNU ftp sites. For example I will use 1.25

                 

                wget http://ftp.gnu.org/gnu/tar/tar-1.25.tar.gz

                tar -xf tar*.gz

                cd tar*

                ./configure --prefix=/usr --exec-prefix=      #Note:: This applies to ubuntu only. For other OS's you need to locate where tar files are.. exec-prefix is intentionally left blank for ubuntu

                make

                sudo make install

                 

                tar --version | grep "1.25"

                 

                This should downgrade tar to 1.25

                 

                Hope this helps