4 Replies Latest reply on Jul 8, 2014 12:29 PM by kevin_intel

    Computer crashing on startup with recent versions of HD 4600 driver

    a1ngie

      I'm using the integrated GPU in the i5-4570 (rest of the specs included at the end) through a VGA cable since last summer and it was working flawlessly for weeks with the drivers provided by Asrock (the motherboard) I think I had manually updated them once ever since then, through a direct download from Intel's own website at some point during last year. No problems at all.

       

      Now a few weeks back once again Windows update fails to update to a newer version of the the drivers. I don't pay a lot of attention to it and go on with life but suddenly I get frequent freezes on start-up that force me to manually shut down the computer and are generally solved by going into safe mode and recoveryto an earlier point, sometimes just rebooting it would work. I don't instantly correlate this to the drivers update so I end up formatting in hopes to get the issue solved. I also update the BIOS. Of course, no such luck. Long story short, after a lot of troubleshooting and plenty of installations of both Windows 7 and 8.1 (both 64 bit), and plugging an old nvidia graphic card (that as predicted, fixes the issue) and connecting trough a DVI to HDMI cable (that seems to fix the issue too but that's not an option for my screen) I finally isolate the problem, or so I believe:

      Everything works fine under every circumstance or OS possible until the point when the graphic drivers are installed, independently of where I downloaded them from (it happens with Asrock's latest update: that dates back to October from last year, or Intel's latest or other versions released earlier this year) I generally am able to reboot once after installing them before two things occur:

      1) Computer freezing on start up (sometimes leading to BSODs like Machine_Check_exception or System_thread_exception_not_handled)

      2) Computer is unable to connect through WiFi, puzzling me and leading me in the wrong direction.

       

      Time and time again, both problems are solved once I uninstall the drivers and reboot the computer.

      So when I was almost ready to give up on it, I found someone with a similar problem leading me to believe this problem wasn't present in the v9 of the drivers, but introduced at some point in 10.

      Lo and behold, I eventually am able to find a version of the driver (9.18.10.3214 to be precise) that is signed a year ago and fixes both problems. TADA!

       

      So I wasted a ridiculous amount of time with something that could have been easily fixed with just reverting to the previous version of the driver, amazing. Luckily enough I didn't go and buy a dedicated graphics card like I was about to, at least it works now even if it is with a year old drivers, which is far from ideal.

      Anyway, if there's any further information I could provide to help this get fixed in a newer version  of the driver, I'd try to help.

       

      Computer specs:

      Windows 7 / Windows 8.1

      CORSAIR DDR3 2x4GB 1600Mhz

      Samsung 840 SSD Series 120GB SATA3

      CPU Intel Core i5-4570

      Asrock H87M Pro4