1 Reply Latest reply on Jun 23, 2014 11:05 AM by allan_intel

    Intel NUC DN2820 Blank Screen

    JamesJ

      Hi,

       

      I just putchased an Intel NUC DN2820 and what a drama this has been.

       

      I have been trying to install Ubuntu on this which I read before purchase was possible with the latest bio update.. WRONG!

       

      When first plugging the NUC in (before bios update), I got no screen, it was blank. I thought it could be ram or something but it wasn't.

       

      I removed the jumper pin and loaded the latest bios onto a usb stick. Booted the NUC and with a blank screen I could see the power light flashing continuously which is a sign that it is updating the bios.

       

      After the bios update I still received a blank screen so I tried holding down the power for 3 beeps, and then I got something on the screen! Yay!

       

      I went into the bios and started playing with some of the settings and I noticed that when you set it to Windows 7 (rather than Windows 8.x) in the Boot Config, a normal boot will show me a screen (and not be blank).. WHY is this?

       

      With Windows 7 set, I can't disable Legacy Boot which is recommended by Intel when installing Ubuntu (http://www.intel.com/support/motherboards/desktop/sb/CS-033935.htm)

       

      I tried installing Ubuntu anyway.. No luck, the installs goes fine but upon reboot it doesn't boot the OS.

       

      I then set the bios back to Windows 8.x and disabled legacy boot, once again a normal boot will show a blank screen so I held down power for 3 beeps, selected the usb stick as the boot device and did the install. The install freezes at when it is configuring GRUB (which has something to do with the boot)

       

      So my problems in summary are:

       

      1. Why is my screen blank when booting normally and Windows 8.x is set in the bios?

      2. Why does Ubuntu fail when using all the recommended settings, the only difference is I am holding down the power for 3 beeps so I can get a screen

       

      Lastly, I tried downgrading to 0032 firmware, this time a blank screen on normal boot and a blank screen when holding down the power for 3 beeps.