6 Replies Latest reply on Jan 5, 2016 6:08 PM by Deeznuts

    Galileo board is not detected.

    Sukruth

      Hi,

           I have connected my Galileo board as mentioned in the Getting started guide and when i check in the device manager, I don't see the board being detected. Could you please let me what would be an issue?

       

      dev_driver.PNG

      image.jpeg

      What would be an issue/ I am not seeing "Gadget Serial V2.4" in Device Manager. How do i go forward?

       

      Regards,

      Sukruth H V

        • 1. Re: Galileo board is not detected.
          mhahn

          - Have you tried another cable?

          - could it be the "Unknown Device"? Maybe check the steps in following note from "Getting started guide"

          Note: You may find Gadget Serial 2.4 under Other devices in Device Manager. If
          this is the case, do the following:
          a. In Windows Explorer, go to C:\Windows\System32\drivers and look for
          usbser.sys. If it is present, you can skip these steps. If it is missing,
          copy usbser.sys from the archive location identified below:
          Windows 7:
          C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd6
          4_neutral_fbc4a14a6a13d0c8\usbser.sys (archive file)
          Windows 8:
          C:\Windows\System32\DriverStore\FileRepository\mdmcpq.inf_amd6
          4_d9e0b9c4fe044b4d\usbser.sys (archive file)
          b. In Windows Explorer, copy to: C:\Windows\System32\drivers
          You may need to provide Administrator Permission to complete the copy.
          c. Once usbser.sys is copied, continue with step 5 above.
          
          • 2. Re: Galileo board is not detected.
            Sukruth

            Hi,

                 Yes, I have tried these steps and still i am facing the same issue.

             

            I have used the different cable, also copied the usbser.sys file, But still, i don't see any additional devices under device manager.

             

            Please do let me know if i am missing any other steps here.

             

            Regards,

            Sukruth H V

            • 3. Re: Galileo board is not detected.
              JPMontero_Intel

              Hi

               

              I’d suggest you try entering the Linux console of your board, in order to know if the board is booting up correctly or not, in case you are not familiar with this, take a look at this post https://communities.intel.com/thread/46335.In there are indicated the different ways you can get into the Galileo Linux console.

               

              Regards,
              JPMontero_Intel

              • 4. Re: Galileo board is not detected.
                jjaken

                mhahn suggested going to the getting started guide, but I think you may have missed that. 

                 

                It's likely that it is the "Unknown Device" you see.  Right click on that and update the driver.  For more instructions, follow the Galileo Getting Started - Windows guide.  The guide uses an example in which the device is called "Gadget v2.4" in the device manager, however, I've never seen that in my experience and it always comes in as "Unknown Device."  I'll paste that section below.

                 

                Step 3 - Install Drivers

                 

                1. Windows 7— Install Drivers:
                  1. Select Start -> Control Panel->System and Security->Device Manager
                2. Locate the Gadget Serial v2.4 device, under the Other devices tree. Right-click that and select Update Driver Software
                  1. Untitled.png
                  2. NOTE: You might get an error regarding a problem installing drivers - you can ignore this error.
                3. On the first window that pops up, click Browse my computer for driver software. And on the next page select Browse… and navigate to the Arduino-1.5.3\hardware\arduino\x86\tools folder within your Arduino Galileo software installation. Then click OK.
                  1. 5_DriverUpdate_Brow#10EB4A.png
                4. Click Install on the next Windows Security window that pops up. And, after a number of loading-bar-scrolls, the installation should complete and you should be greeted with a Windows has successfully updated your driver software window.
                5. Once the driver is successfully installed, Device Manager will show a Galileo (COMx) device under Ports (COM & LPT). Note the COMx port number as it will be needed in the IDE later.
                  1. 7_DeviceManger_Galileo.png
                • 5. Re: Galileo board is not detected.
                  Deeznuts

                  Yup, i did this too and it still shows up as an unrecognized device. Im beginnign to believe this whole arduino method is far to complicated, being that theres a population of makers that cant even get past establishing a USB connection. Dont know why there is no native capability to use ethernet, the jacks just sitting there while we are held hostage to the complication of USB.

                  • 6. Re: Galileo board is not detected.
                    Deeznuts

                    I have arduino 1.6.5 and the file directory set up is completley different. For starters, its actually a sub-directory of the Intel folder, and within the arduino folder, there is no x86 sub-directory.