0 Replies Latest reply on Jun 17, 2014 2:57 PM by Emmet

    i340-T4 and iSCSI ROM

    Emmet

      Hello,

      Quite new to "the world of hardware" and all option they have, but pretty used to tryout different technologies and concepts. Anyway, I found a i340-T4 on ebay pretty cheap and figured "hey, why dont I iSCSI boot my server - that sounds cool". So I bought the card after verifying that the auction page specified it supported iSCSI boot. I got the card but for some reason I only saw a PXE boot prompt. I read up a bit on the documentation and realized that I would likly need to flash the ROM of the NIC.

      I downloaded the Intel Bootutil and tried to run it. It lists all the ports just fine, all 4 of them, when running the command without arguments. But when I run the command bootutilw32.exe -nic=2 -FE I get the error message:

      "ERROR: Unsupported feature". So I googled a bit and found that apparently the NIC might only support combo images an hence the "enable" feature wouldnt be applicable since it was always enabled. So I ran the command bootutilw32.exe -nic=2 -up=combo I get the error message "Option ROM area in the flash is not supported for this device on port 2".

      I googled some more and it turns out that maybe this might be an OEM card and hence would need the OEM vendors own tool. But how do I find out which the OEM vendor might be? Is there anything else I've missed when trying to get iSCSI working?

       

      This is a standalone card, PCI-E 4x.

       

      Please let me know if you have any suggestions... I have sent the ebay seller an email, but have not yet recieved a response. I have also tried with the HP tool I've found, but it still seems it is not working even tho the command ran without error messages when I used a config file as input.

      Link to the card I bought on ebay (same NIC from same seller): New HP 593722 B21 NC365T Intel I340 T4 4 Port PCIe Gigabit NIC | eBay

       

       

      Thanks in advance.