3 Replies Latest reply on Jun 18, 2014 11:36 PM by zentish

    D54250WYKH USB3 boot issues with VMWARE 5.5 u1

    zentish

      I just purchased enough gear to build a nice NUC rig with the intention of running VMWARE for my home office. The low power consumption and quiet appeals to me, especially after living with the noise (and electricity bill) from an HP DL360G5 for a few years.

       

      I used UNETBOOTIN to load a boot-able drive image of the VMWARE installer to an old Cruzer USB 2.0 flash drive - the intention being to install it onto the small USB 3.0 Mushkin flash drive and use the internal drive for guest OS's. This worked great and I was able to boot from the Cruzer and install VMWARE on the Mushkin Atom drive without issues.

       

      The issues started almost immediately afterwards when trying to boot from the Mushkin USB drive. Sometimes the NUC would boot from the flash drive and sometimes it wouldn't. Some symptoms:

      1. Always boots from the USB 2.0 Sandisk Cruzer drive containing the VMWARE installer written by UNETBOOTIN
      2. Upgraded to and running the latest visual BIOS: WY00026
      3. Sometimes boots from the MUSHKIN from a pwoer-off/power-on cold boot
      4. The USB port doesn't seem to matter, I've tried them all (all the external ones)
      5. An F9 (load BIOS defaults) followed by an F10 and a warm reboot sometimes fixes the boot issue for a short time
      6. I tried a different flash drive, loading VMWARE onto a 16GB SanDisk Cruzer Fit (USB 2/3) and I get the same inconsistent behavior
      7. It will boot from either of the USB3 drives in a completely random manner, sometimes it will boot 6 or 8 times in a row, and sometimes it won't boot for long stretches without resorting to #10
      8. It will always recognize and boot from the 4GB USB 2 SanDisk Cruzer created with UNETBOOTIN from the VMWARE installer ISO
      9. If I boot and hit F10 to get the boot menu it will sometimes see and sometimes not see the MUSHKIN drive
      10. If I place the USB2 SanDisk Cruzer in the NUC along with the MUSHKIN drive, power up and hit the F10 boot menu option the BIOS always sees both drives
      11. Enabling or disabling the UEFI boot option in the BIOS seems to have no effect

       

      I've scoured forums and have found some slightly similar issues but I've not been able to get anywhere fixing this. I've tried an alternate USB3 drive and get the same inconsistent behavior.

      It seems like a USB bus timing issue of some kind.

      Once booted, the device seems to run VMWARE just fine, but if I can't get it to consistently boot without all the fiddling then I can's leave the home office to others to run in case there's a power outage.

       

      Any advice or help would be appreciated!

       

      The kit:

      1. Intel NUC BOXD54250WYKH1
      2. HGST Travelstar 7K1000 HTS721010A9E630 1TB drive
      3. Crucial Ballistix Model BLS2K8G3N169ES4 (2 x 8G) 204-Pin DDR3 SO-DIMM DDR3 1600
      4. Mushkin Enhanced atom 16GB USB 3.0 flash stick
      5. SanDisk Cruzer Fit (16GB)
      6. SanDisk U3 Cruzer Micro 4.0 (boot installer image)

       

      THANKS!

        • 1. Re: D54250WYKH USB3 boot issues with VMWARE 5.5 u1
          yonkers12

          1. Suggest setting USB ports not needed for BIOS or boot to "No Detect" under Devices/USB/USB Ports to minimize number of devices the BIOS must enumerate.  Make sure you leave at least one port from 01 thru 04 enabled so you can still have keyboard support in the BIOS. 

           

          2. You could try attaching the USB3 drive via a cheap USB2 hub to force a USB2 connection.  USB2 is way more reliable than USB3 across the board.

           

          3. It could be an interoperability issue with your drives.  I'm using a Silicon Power 64GB (SP064GBUF3B30V1K) with Phison controller.  I haven't seen any issues, but I mostly boot from SATA.

           

          4. You could add an mSATA drive to boot from.  Better write endurance and more random iops than a USB stick.

          • 2. Re: D54250WYKH USB3 boot issues with VMWARE 5.5 u1
            zentish

            1) I tried a number of variations disabling the USB devices or setting them to "No Detect" and didn't see any improvement.

            2) Rather than attempt a HUB, I'm going to try to load up a USB2 micro drive - I grabbed a third brand "PNY Micro Metal 16 GB USB2" thumb drive.

            3) It is disappointing that I'd get such inconsistent results from the latest BIOS. I'm posting here in hopes that INTEL will try to reproduce and fix these issues.

            4) The NUC has a 1TB SATA drive, but I was hoping to provide different boot media to allow me to change the VMWARE install without disturbing the guest images on the drive.

            • 3. Re: D54250WYKH USB3 boot issues with VMWARE 5.5 u1
              zentish

              My initial searches didn't yield any better answers, but I recently found some references to boot issues from USB specifically with ESXi 5.5 and the NUC because ESXi 5.5 will create GPT partitions instead of MBR when performing a fresh install.

               

              The solution I'm now investigating is to use the boot option

              formatwithmbr

               

              when running the ESXi 5.5 installer

               

              Boot the installer

              Press CTRL+O to set installer boot options

              Add the string

              formatwithmbr

              to the runweasel options

              proceed as per normal

               

              Found in a few places:
              Re: D34010WYKH Only Boots from USB when Using F10 Option

              http://www.virt-infrastructure.com/?p=375