2 Replies Latest reply on Jul 22, 2015 2:03 PM by RzR

    DN2820FYKH - Cannot get into Bios Settings after update

    chrizfitz

      Hi,

       

      Setup my DN2820FYKH with a new HD and 4 gig of Ram and tried to install W7 through USB. No usb detected. Got into the Bios settings and saw no settings that would stop my usb key booting. quick google says I need to update the Bios. Go to this page:

      Download Center

      and download latest FY0034.BIO threw it on mu usb key and installed through F2.

       

      Bios installs successfully and reboots. I now see the windows files starts to load then Blue Screen - system is not fully ACPI compliant.

       

      Ok lets hit the Bios settings and have a look see. Now the real issues start, F2 to enter Bios settings just hangs on "Entering Setup....."

       

      I have since tried FY0015.BIO 21 and 32. All the same issue.

       

      Bios recovery will not boot.

       

      Any help is appreciated.

       

      Update: removed jumper and recovered to 34. graphics are askew on intel NUC logo. Blank screen when F2 for Bios.

       

      Chris