1 2 Previous Next 16 Replies Latest reply on Jun 14, 2014 5:08 PM by billbruen

    Calling Lois H NUC Bios Entry Problem

    billbruen

      Just built up a new D54250WYKH and have been having a problem getting sound out to Creative Gigaworks T20 speakers.

       

      As part of my work to fix this problem, I thought I would update to latest BIOS.

       

      However, F2 during Boot does nothing. I had been using Logitech K330 wireless keyboard: have also tried wired USB keyboard without success.

       

      Any ideas?

        • 1. Re: Calling Lois H NUC Bios Entry Problem
          billbruen

          OK don't panic people.....

          Just updated to the latest Bios 0026?, and F2 now works again.

           

          Can anyone tell me what should happen when you plug, say, a headset into the front panel jack? Should it disable HDMI sound? Is there anything in the Bios that needs to be set, for the front panel jack to be enabled?

           

          My jack just doesn't seem to be working.....I'm beginning to think my jack may be defective........is there a way to check it out without sending it back to Vendor?

          • 2. Re: Calling Lois H NUC Bios Entry Problem
            joe_intel

            It is good to know you have access to the BIOS with your keyboard again.

            I hope my suggestion regarding the audio jack issue helps you: NUC with Creative Gigaworks T20 Speakers

            • 3. Re: Calling Lois H NUC Bios Entry Problem
              dougho

              I am not from Intel, and could be wrong, but sound operation typically depends on device drivers with the operating system (not the BIOS).  For example, on my 54250 running Windows 8.1, there is a sound icon just left of the time/date at lower right corner of the desktop.  Right clicking on that icon offers choices including Playback devices.  The Playback tab lists Intel Display Audio (which is my default - the mini HDMI) and Headphones.  When I plug in headphones to that front jack, my Playback default changes to Headphones.  When I unplug, default changes back to Intel Display Audio.  If it matters, for the headphone jack I probably did NOT download/install Intel's Realtek audio driver - I just use whatever happened during Windows installation.

              • 4. Re: Calling Lois H NUC Bios Entry Problem
                billbruen

                Thing is dougho, my 'Sound' window only shows one device registered....... my monitor, which is my HDMI output.

                 

                When I plug a headset into the front jack, Windows should see and register another device......but it doesn't. Why? Because I believe my front jack is faulty.

                • 5. Re: Calling Lois H NUC Bios Entry Problem
                  dougho

                  Again I could be wrong, but another possibility seems like you may not have the non-HDMI sound driver installed - such driver is necessary for the headphone jack.  If you are familiar with Windows, I'm talking about something like a yellow exclamation mark in Device Manager.  I don't recall having to do anything to get my driver (for High Definition Audio Device), but there is that Realtek audio driver in Intel's download files for the NUC.  My Windows 8.1 is installed in UEFI mode and I may have started with 8.0 then updated, I don't know if that matters.

                  • 6. Re: Calling Lois H NUC Bios Entry Problem
                    billbruen

                    No yellow stuff in my Device Manager my friend.......don't believe in it!! ......   :-)

                     

                    As part of my work to try and find a fix for this problem, I used Intel's online analysis tool to scan my NUC for missing/out of date drivers.

                     

                    I also updated my Bios to the latest.....0026

                     

                    So, I'm pretty confident that my NUC is internally splendiferous.......

                     

                    But do I have healthy front panel jack? Not so sure.

                    • 7. Re: Calling Lois H NUC Bios Entry Problem
                      billbruen

                      Have spoken to my Vendor about sending my NUC back for checking.

                       

                      Here's what he said.....

                       

                      "Sorry to hear about the problem. As far as we know the audio jack should work with any standard earphone or speaker jack. My colleague Ellen uses a NUC for her systems and she has her monitor speakers connected to the NUC using a standard 3 pole jack and it works perfectly. So I suspect that you may have a faulty audio jack."

                       

                      I'm returning it tomorrow......will keep you in touch with developments.

                      • 8. Re: Calling Lois H NUC Bios Entry Problem
                        dougho

                        I still believe your problem is needing to solve an audio driver issue (the audio jack won't work until a driver is working).  I have two D54250, one Windows 8.1 definitely UEFI as described earlier, the other Windows 7 which may also be UEFI (I don't know if results would vary for Legacy mode).  Both have in the Device Manager under Sound controllers two entries - one for Intel Display Audio (which is the mini HDMI), and my other says High Definition Audio Device.  That second name may be due to me sticking with a Windows default generic rather than adding a Realtek driver from Intel.  I have no idea whether Intel's online analysis tool does the right thing with respect to that necessary audio driver, nor do I know which Windows version and which mode (UEFI or Legacy) you are operating and whether you tried installing that Realtek driver.

                        • 9. Re: Calling Lois H NUC Bios Entry Problem
                          joe_intel

                          It should work with Microsoft*'s inbox driver (if enabled in BIOS as suggested before); so, I believe it is hardware related.

                          • 10. Re: Calling Lois H NUC Bios Entry Problem
                            billbruen

                            I think the problem is that Windows does not recognise the front jack (because it's faulty, I think)......so, trying to install a driver for a device that isn't there?.....you see the problem?

                             

                            The sequence of events is that Windows spots your devices and lists them in Device Manager, then will try to load a suitable Microsoft driver, if it has one, or prompt you to load a driver of your own. Until a suitable driver is installed, the device will be highlighted in yellow in Device Manager. I have no yellow in my Device Manager. Also, I only have one device recognised, my HDMI audio.

                             

                            I'm really not sure why you're still still hanging your hat on an audio driver issue, when all the evidence is pointing to a hardware issue? Anyway, we'll find out in a few days.

                             

                            Meanwhile, Mr NUC is all packed up for its journey tomorrow, so I'm not thinking about it anymore, till it returns to me.

                             

                            FYI my NUC is a D54250WYKH homebuild, with WiFi and Bluetooth, 180GB mSATA SSD, 16GB memory and Western digital 1TB hard drive......running Windows 8.1 update

                            • 11. Re: Calling Lois H NUC Bios Entry Problem
                              billbruen

                              My last post was actually directed at dougho....

                              • 12. Re: Calling Lois H NUC Bios Entry Problem
                                dougho

                                Sorry if I was unclear.  I'm trying to say that there is no reason to bother plugging anything into the jack if the audio device isn't listed in the Device Manager (and Playback devices).  The jack is merely an extension of some "chip" (ALC283?) on the NUC motherboard, and the headphones or amplified speakers are merely a further extension.

                                • 13. Re: Calling Lois H NUC Bios Entry Problem
                                  billbruen

                                  OK, I understand and agree.........

                                  • 14. Re: Calling Lois H NUC Bios Entry Problem
                                    lhill

                                    Hi Bill,

                                     

                                    Sorry I did not see this until today. Not sure if you still have the NUC at hand or not, but there are only two things you need to check about the front panel audio device.

                                     

                                    1. It's enabled in BIOS. Go to Advanced > Devices & Peripherals > Onboard Device Config and make sure Audio is turned on.

                                    2. The Windows driver is installed - Download Center

                                     

                                    If both of those are already done, then you're right - it's likely a faulty audio jack.

                                    Lois H.

                                    Intel

                                    1 2 Previous Next