2 Replies Latest reply on Jun 2, 2014 1:48 PM by sylvia_intel

    Disabling Integrated Graphics Card?

    Courageous999

      Hi,

      I have a Dell XPS 15 L502X. So I recently installed a game called Wolfenstein: The New Order. And every time I run the game I get an error known on the web as "wglCreateContextAttribsARB failed".

      I know the cause of the error is that the game keeps identifying my integrated graphics card (Intel HD 3000) as the main graphics card whereas I have a dedicated graphics card onboard (Nvidia GeForce GT 540M, 2GB dedicated memory).

       

      The issue is that my integrated graphics card only supports OpenGL 3.1 and below, although my GPU supports until OpenGL 4.0. I know for a fact this GPU is able to run the game, and YES I have already selected my GPU as the primary graphics card under Manage 3D settings, global settings AND the specific program settings, AND even tried setting PhysX Configuration as the GPU itself all to no avail.

       

      I have also attempted to disable my Intel HD 3000 through device manager (couldn't disable it through bios), but whenever I do so that turns off my laptop's display. However I have a TV to which my laptop is connected to via HDMI. So my laptop's screen is transferred to my TV and I cannot change/turn my laptop's display ON unless I were to re-enable the integrated graphics card. Strange in my opinion!


      On the other side, I ran the game without the integrated graphics card (while using my TV as the display), and the game runs just fine !!!!! So CLEARLY the GPU (GT 540M) is able to run this game, but the game doesn't identify it. Instead only identifying the integrated Intel HD 3000 Graphics card or identifies the integrated graphics card as the primary for some reason!


      Help please, I want to play the game on my laptop's screen not on my TV... Also on a side question, is it possible to completely disable my integrated graphics card (Intlel HD 3000) without losing my display? If so, how?

      Thank you for your time.