5 Replies Latest reply on Jun 4, 2014 10:07 PM by m@V8

    Bug in Intel Solid State Drive Toolbox v3.2.1.exe

    m@V8

      Below are the relevant details:

       

      Hardware

       

      Intel 530 series 240GB SSD (firmware upgraded to latest version)

      Intel i5-4570 CPU with Intel HD 4600 integrated

      Asus H87-PRO motherboard a/k/a mainboard a/k/a desktop board

      Dell monitor U2312HM

       

      Software

       

      Dell monitor driver for U2312HM

      Intel® Iris and HD Graphics Driver for Windows* 7/8/8.1 64-bit ( File name: win64_153318.exe  Version: 15.33.18.64.3496 )

      Microsoft Windows 8.1 with SP1, 64-bit, US English

      Microsoft Windows 7 with SP1, 64-bit US English

       

      After installing Intel SSD Toolbox v3.2.1 and rebooting my computer,my monitor is unable to display anything. All I got is a black screen.

       

      I have no choice but to reinstall Microsoft Windows OS, the Dell monitor driver and Intel's driver for the Intel HD 4600 integrated graphics. This time I did not install Intel SSD Toolbox v3.2.1.exe (the moment I install the said Toolbox software and reboot my computer, all I get is a black screen.)

       

      I believe there is a serious bug in the Toolbox software.

       

      Could someone software/hardware engineer from Intel look into this issue please?


      Thanks in advance.

        • 1. Re: Bug in Intel Solid State Drive Toolbox v3.2.1.exe
          joe_intel

          m@V8, we have not seen this issue with the Intel® SSD Toolbox before.

          Does the black screen appear when the operating system tries to load the desktop environment or even before that while the operating system boots?

          Did you test booting your system in safe mode by any chance or installing Intel® SSD Toolbox but not Intel® HD Graphics?

          • 2. Re: Re: Bug in Intel Solid State Drive Toolbox v3.2.1.exe
            m@V8

            Hello Joe

             

            m@V8, we have not seen this issue with the Intel® SSD Toolbox before.


            Well, now you have. Isn't that interesting?


            Does the black screen appear when the operating system tries to load the desktop environment or even before that while the operating system boots?

             

            Let me take you through again how I installed my software.

             

            1. After installing Microsoft Windows OS (either 7 or 8.1, 64-bit, US English), I installed Intel chipset driver and rebooted the computer.

            2. I installed Intel Management Engine and rebooted the computer.

            3. If I had installed Microsoft Windows 7, I would install Intel USB 3.0 driver and reboot the computer. I would skip this step if I had installed Microsoft Windows 8.1

            4. I installed Dell monitor driver that I had downloaded from Dell's official website. I rebooted the computer.

            5. I installed the latest version of Intel HD 4600 graphics driver and rebooted the computer.

            6. I installed the latest version of Intel Toolbox software and rebooted the computer.

             

            The black screen appeared while the operating system was booting up. I could not even see the Windows boot menu.(I have a dual boot setup: Microsoft Windows 7 and 8.1.)

             

            Did you test booting your system in safe mode by any chance or installing Intel® SSD Toolbox but not Intel® HD Graphics?

             

            Here's what I had experimented.

             

            1. After installing Microsoft Windows OS (either 7 or 8.1, 64-bit, US English), I installed Intel chipset driver and rebooted the computer.

            2. I installed Intel Management Engine and rebooted the computer.

            3. If I had installed Microsoft Windows 7, I would install Intel USB 3.0 driver and reboot the computer. I would skip this step if I had installed Microsoft Windows 8.1

            4. I installed the latest version of Intel Toolbox software and rebooted the computer.

             

            I did not install the Dell monitor driver from Dell. Under "Device Manager", my display driver is listed as "Microsoft standard display driver".

            I did not install the latest version of Intel HD 4600 graphics driver.

             

            Result: There is no problem of black screen.

            • 3. Re: Bug in Intel Solid State Drive Toolbox v3.2.1.exe
              joe_intel

              I have some suggestions; you may want to try the following:

              I also wanted to ask: what is the video port you are using (DVI, DP, VGA)? Please make sure it is a straight cable (not an adapter/converter).

              • 4. Re: Bug in Intel Solid State Drive Toolbox v3.2.1.exe
                m@V8

                Hello Joe,

                 

                Thanks for your reply.

                 

                Please allow me to answer your suggestions point by point.

                 

                Intel HD Graphics 15.33.14.64.3412

                 

                The URL that you provided led me to a "Page Not Found". What happened?

                 

                But no matter for I discovered that the suggested driver happened to also be available on Asus' support website: Motherboards - H87-PRO - ASUS

                Specifically the download link for the version 3412 is http://dlcdnet.asus.com/pub/ASUS/misc/vga/Intel_Graphics_Win7-8-8-1_VER1018103412.zip  Note that the size of the download is about 231.93 MB.

                Is this the same driver that you suggested that I download?

                 

                If it is the same driver, then I am sorry to tell you that installing it gave me the same issue as described in my original post.

                 

                Intel HD Graphics 15.33.0.3574 (beta)

                 

                Thanks for the suggestion, Joe. I hesitate in trying it out for the simple reason that if the same issue occurs, I will have to re-install Microsoft Windows OS and all the third party software that I need.

                 

                Version 3574 is still in beta.

                 

                Latest Asus H87-Pro Bios

                 

                The issue as described in my original post happened after I flashed the BIOS to the latest version, which is 1105. (The issue also happened with BIOS version 1103.)

                 

                In answer to your question, yes, I am using the DVI port. When I bought the Dell monitor U2312HM, Dell supplied me a DVI cable and a VGA cable.

                 

                Request to Joe

                 

                I have just learned that your colleague, Sylvia, recommended to me use another driver. Please surf to the following URL to read her reply: What are the differences between Intel HD 4600 graphics driver and Microsoft's standard display driver?

                • 5. Re: Bug in Intel Solid State Drive Toolbox v3.2.1.exe
                  m@V8

                  Hello Joe,

                   

                  Here's my latest feedback.

                   

                  I happened to read a post by your colleague, Robert, about the availability of the latest version of Intel HD 4600 graphics driver (Latest driver supporting 3rd and 4th Generation Intel® Core™ Processors with Intel® HD/Iris™ Graphics for Microsoft* Windows 7, 8, & 8.1 version  3621). I also noticed that it is the same one recommended by Sylvia, another colleague of yours.

                   

                  I downloaded and installed it.

                   

                  To my surprise, the issue with Intel SSD Toolbox v3.2.1 disappeared. I don't know whether the resolution is temporary or permanent. I will test my computer for another month or two and will feedback here if the same issue crops up again.

                   

                  In any case, I wish to thank you for taking the time to look into my issue.