4 Replies Latest reply on Apr 16, 2015 1:57 AM by White-Eagle

    Ethernet connection issues

    rflmota

      Hey all !

       

      I've start playing with my Intel Arduino Galileo, and after installing Arduino IDE 1.5.3, updating to firmware 1.0 and successfully run Blink example, I've tried to connect my board to Internet through Ethernet.

      Uploading the DhcpAddressPrinter from Ethernet Arduino library examples folder, I can't get a connection to my router, getting the following output from serial monitor:

       

       

      My IP address: 255.255.255.255.

       

      I've also tried connecting with a static IP address with Ethernet.begin(mac, ip) but I got the same result.

       

      I'd like to note also that I'm running my Galileo board without micro-SD card with the stock linux kernel.

       

      Can please somebody give me an hint on this?

       

      Thank you.

        • 1. Re: Ethernet connection issues
          Intel_Jesus

          Hi rflmota,

           

          Can you check your network settings and see if Galileo is listed in the devices connected. When i run the sketch i get My IP address printed.

           

          Regards,

          Intel_Jesus

          • 2. Re: Ethernet connection issues
            mechalas

            Make sure your ethernet cable is plugged in before you power on Galileo. The current DHCP configuration for the Linux build is to try and get a lease at boot time, and exit if it fails. This means that if you don't get a lease at boot time, you never will, and wired networking will never work in sketches until you reboot because the Galileo implementation of the Ethernet class depends on DHCP running.


            Alternatively, as a workaround, you can force a restart of networking on Galileo by executing this in your sketch:

             

            system("/etc/init.d/networking restart");
            
            

             

            This will restart DHCP without having to reboot.

             

            I consider the current DHCP configuration in Galileo to be a bug.

            1 of 1 people found this helpful
            • 3. Re: Ethernet connection issues
              rflmota

              Hi Intel_Jesus and mechalas,

               

              Thank you for your help.

               

              I tried with the ethernet cable connected before plugging in power to my Galileo, but with the same result... In the meantime I tried with mechalas suggestion:

              1. system("/etc/init.d/networking restart"); 

              Before the instruction Ethernet.begin(mac) and i finally got it to work

               

              Thanks for the help

              • 4. Re: Ethernet connection issues
                White-Eagle

                Thank you so so so much,
                I was accessing my Galileo from local network but I want to access my Galileo outside, but I can't. I have strived with this problem more than 2 weeks  It's ok with that code now