1 Reply Latest reply on Dec 20, 2009 3:41 AM by tariely

    DX58SO BIOS 4196 is out, More Gray Hair for me.

    Romasurus

      My board came with the 2124 BIOS when I purchased it. I read all of the horror stories before I tried to flash it to the 4158 BIOS, Mainly for the (DO) stepping.

      Well, today I noticed that the new BIOS is out along with a new chipset driver. I wasn't going to do another flash until something started acting funny on my MB OR until the final version of Windows 7 arrived in Oct or Nov. Well, knowledge is terrible and just knowing that a new BIOS was out there, it was all I could think about. So I went ahead and tried it. First I tried the built in F7 update on the MB. That appeared to go fine until the final step where it asks you to confirm that you DO WANT to update the BIOS. Here, my keyboard nolonger worked. Same thing with 2 more independent downloads of that BIOS. Next I tried the ISO. OH BOY did that make my heart sink. The ISO CD started and then my screen filled with errors. No more of that. The system did reboot though so I was OK. Anyone else would have stopped and waited for the next iteration of the BIOS to come out but I would not be beat by this thing. Now I tried the BIOS Recovery Option. I sat there staring at a blank Black screen for 10 minutes, as my life flashed before my eyes. I shut down the system and again prayed for the system to boot and it did. NEXT came the Windows installation. Here I was informed that the file is corrupt and I should D/L it again. And again I get the file is corrupt. Well, there was only 1 option left that I had not tried so I loaded the IFlash files onto my bootable thumbdrive and away I went. That worked. I guess I have to reevaluate my life here. BUT as long as I have a 3 year warranty on this board, I will be the boss and not the Intel MB.