0 Replies Latest reply on Aug 14, 2014 2:10 PM by Krampus

    Linux hanging at Initrd (BSP 1.0)

    Krampus

      I built a new image-full from the new (well, now old) BSP.  When I try to boot, it gets stuck right after it finds Initrd.  The serial output ends with:

       

      [Linux-EFI, setup=0x10cd, size=0x1de2d0]                                       

      [Initrd, addr=0xd895000, size=0x2a91b5]

       

      Unfortunately, that doesn't give me a lot to go on as far as debugging.  Is there a common "oops, you forgot this" that I'm missing?  According to the BSP documentation, I should just need to copy over the grub.efi, bzImage, image-full-clanton.ext3, core-image-minimal-initramfs-clanton.cpio.gz, and boot/grub/grub.conf over to the SD card.  The prebuilt image worked fine, but I'm missing something when I do my own build.

       

      Here's the relevant part of grub.conf.  I didn't mess with the boot lines it came up with (although I turned up the timeout on the grub menu):

       

      title Clanton SVP kernel-MassStorage initrd-MassStorage image-full IMR-On IO-APIC/HPET NoEMU debug

          root (hd0,0)

          kernel /bzImage root=/dev/ram0 console=ttyS1,115200n8 earlycon=uart8250,mmio32,$EARLY_CON_ADDR_REPLACE,115200n8 vmalloc=384M reboot=efi,warm apic=debug rw LABEL=boot debugshell=5 rootimage=image-full-clanton.ext3

          initrd /core-image-minimal-initramfs-clanton.cpio.gz

       

      As far as the image goes, I changed local.conf to use "clanton-full" as the DISTRO.  I also had to grab a patch from upstream for building guile with GCC 4.8 and add texinfo to the build recipe to satisfy guile's dependency on it.  The rest ought to be standard.

       

      I haven't tried cleaning and rebuilding nor have I grabbed the newest BSP released yesterday to see if that fares better.  I'll do that eventually, but I didn't want to wait for it to rebuild.   Anyone have any other suggestions as to what I'm doing wrong?