1 2 Previous Next 18 Replies Latest reply on Jun 18, 2014 12:35 PM by Intel_Jesus Branched to a new discussion.

    New release of Galileo software

    Intel_Raad

      New release of Galileo software is available for download, include firmware based on BSP 1.0.0 and new release of Arduino IDE.

        • 1. Re: New release of Galileo software
          intel_jorge

          From the release notes:

          ---------

          Features in Release 1.0.0

          1. Firmware update (*.cap file) now installs v1.0.0 capsule image, and includes support for installing firmware on boards with firmware released after 0.7.5.
          2. Improved compatibility of Arduino libraries with standard C++ math and string classes.
          3. Added min() and max() to Arduino.h
          4. Null definitions for interrupts() and noInterrupts() macros in OSAbstract.h
          5. Fixed issues with pin 0 and pin 1.
          6. Added support to the library for interacting with the ADC logic on the board.
          7. Added UtilTime module to library.
          8. Added library support for OneWire and the Dallas Temperature ICs.
          9. Added examples for the Ethernet and WiFi modules to the library.
          • 2. Re: New release of Galileo software
            Clayton Hofrock

            I would recommend that ANY ONE who is doing ANY THING with the Arduino IDE should move to this release. And update your firmware.

             

            Anyone struggling to build the BSP 1.0.0 should use this release to update their firmware.

             

            Here is the link to the new software (Note: it still has the same version number 1.5.3, but it is an update from the previously released version)

            Galileo Software Downloads

             

            It seems like the release notes are missing some information?

            • SD card file creation now works (no need for work arounds)
            • LiquidCrystal library works (no need for work arounds)
            • Servo - still some weirdness that can be easily worked around.
              • At least it compiles without needing to download anything else.
            • PGMSPACE - many of the pgmspace functions now have be ported.
            • String - most of the string additions functions work
            • Timer1 - has no been ported.

             

            I still have not gotten a DHT11 to work with Galileo. So even though the OneWire library has been included, I am not sure the hardware can work with all devices.

             

             

            If you have any issues with this release please let us know so we can get them fixed before the next release. (I don't know when the next release will be, but likely there will have to be a new release if/when any new hardware is released).


            • 3. Re: New release of Galileo software
              bjkellett

              FYI and just for reference---pay attention to where you place the arduino IDE. 

               

              This download and firmware update works with Vista OS.  Previously I've had problems with firmware updates,  although I was able to update with a Linux OS.

               

              Again I've had problems with the directory path being too long.  When I dumped the the Arduino IDE in the Programs File (renamed Galileo) I got this error (verbose):

               

              C:\Program Files\galileo/hardware/tools/x86/i686-pokysdk-mingw32/usr/bin/i586-poky-linux-uclibc/i586-poky-linux-uclibc-g++ -m32 -march=i586 --sysroot=C:\Program Files\galileo/hardware/tools/x86/i586-poky-linux-uclibc -c -g -Os -w -fno-exceptions -ffunction-sections -fdata-sections -MMD -D__ARDUINO_X86__ -march=i586 -m32 -DARDUINO=153 -IC:\Program Files\galileo\hardware\arduino\x86\cores\arduino -IC:\Program Files\galileo\hardware\arduino\x86\variants\galileo_fab_d C:\Users\Bruce\AppData\Local\Temp\build4916055110207594199.tmp\galileoblinker.cpp -o C:\Users\Bruce\AppData\Local\Temp\build4916055110207594199.tmp\galileoblinker.cpp.o

              i586-poky-linux-uclibc-g++: error: Files\galileo/hardware/tools/x86/i586-poky-linux-uclibc: No such file or directory

               

              By moving the galileo folder up  to C:\ galileo corrected the problem. 

               

              • 4. Re: New release of Galileo software
                gowrisomanath

                I updated all of the IDE, firmware and the linux image provided - now i can seem to be able even upload my sketch. I'm on Mac OS.

                Already tried multiple restarts to the laptop and board. no help.

                 

                Is there a link to the old IDE and linux image ? Also how can the firmware be reverted (if thats the problem)

                 

                thanks

                • 5. Re: New release of Galileo software
                  AlexT_Intel

                  What error do you get or how exactly the situation looks like for you now? Providing this information would help the troubleshooting.

                  • 6. Re: New release of Galileo software
                    gowrisomanath

                    Hi Alex

                     

                    Here was the initial problem - It would compile in the IDE, but when I tried to upload it would say 'cannot upload to board'.

                    Then I saw a hint the release notes saying if the usb is connected it may not boot from the SD (?). I used to disconnect the laptop side of USB while powering up the board.

                    But then i tried to disconnect all cables (ethernet, usb, etc) from the board. Power it on. wait for usb light to turn on, and then connect board end of cables. It can now upload to the board.

                     

                    But It also has new issues.

                     

                    (1) My code that includes SPI.h AND Ethernet.h now gives the errors pasted below. But strangely, if i compile another sketch whcih only has SPI, it compiles fine. Once i load the only-SPI sketch, then even the first sketch compiles. But on every restart, the first sketch has compilation errors.

                     

                    (2) If i manage to compile, there still seems to be some issue with UDP calls (EthernetUdp), which i am trying to debug. Udp.begin() seems fine, but actually packet send/rcv just hangs my code. I will try to make a simpler example and share the code if i cant debug.

                     

                     

                    ----- compile errors with SPI.h included

                    In file included from /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/sys/stat.h:106:0,

                                     from /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/arduino/x86/libraries/SPI/SPI.cpp:13:

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:71:21: error: field 'st_atim' has incomplete type

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:72:21: error: field 'st_mtim' has incomplete type

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:73:21: error: field 'st_ctim' has incomplete type

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:117:21: error: field 'st_atim' has incomplete type

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:118:21: error: field 'st_mtim' has incomplete type

                    /Users/gowrisomanath/Downloads/Arduino.app/Contents/Resources/Java/hardware/tools/x86/i586-poky-linux-uclibc/usr/include/bits/stat.h:119:21: error: field 'st_ctim' has incomplete type

                    ------

                    • 7. Re: New release of Galileo software
                      dev.null

                      Hello,

                       

                      Just like the previous version, this custom Arduino editor does NOT start on OS X (10.7.5) if the main system language is Portuguese.

                      Here's the error message: java.util.MissingResourceException: Can't find bundle for base name processing.app.i18n.Resources, locale pt_PT

                      If go to System Settings and change the language to english, then the editor will start.

                      (Regular Arduino editor works without problems)


                      When I try to upgrade the board firmware, I get this error message:  "Target firmware version query failed"

                      If I open the "blink" example, and press Upload, the editor compiles and uploads without errors, but the led never blinks.


                      Your help is welcome.


                      thank you.


                      • 8. Re: New release of Galileo software
                        Intel_Jesus

                        Hi dev.null,

                         

                        Can you confirm you are updating the firmware without the SD card? I will also try to update the firmware on OS X.

                         

                        Regards,

                        Intel_Jesus

                        • 9. Re: New release of Galileo software
                          dev.null

                          There was no card on the slot.

                          I removed power and usb, then plugged power, waited a bit, plugged usb... confirmed that I got some new serial ports, then started your Arduino App.

                           

                          thank you,

                          • 10. Re: New release of Galileo software
                            Intel_Jesus

                            Hi dev.null,

                             

                            I was able to successfully update my firmware on OS 10.8.5.

                            Are you selecting the port /dev/cu/usbmodem*?

                             

                            Also make sure your Mac is listing the USB as Gadget Serial v2.4

                            To Verify:

                            1. press and hold "option" and click on the apple menu.
                            2. select"System Information"
                            3. expand USB drop down.

                             

                            Regards,

                            Intel_Jesus

                            • 11. Re: New release of Galileo software
                              AlexT_Intel

                              gowrisomanath I see. I would suggest you to start two new threads for these two problems you see, that would make it easier for folks to help you. And yeah, the shortest possibler reproducer for the issue #2 would help a lot.

                               

                              Actually, the sketch for #1 would help too, I think they have tested it good enough before releasing, including on MacOS, to be able to catch it if it happens all the time, so I guess it may be something specific to your sketch. Unfortunately i don't have Mac myself, but I'm sure someone else should be able to look into that as soon as you post a little more details. I would definitely try to help too, as much as I can without an actual Mac :-)

                              • 12. Re: New release of Galileo software
                                gowrisomanath

                                Thanks in advance AlexT_Intel

                                I started the SPI discussion at SPI.h compilation error with May 23/14 update

                                Ive attached the barebones of a sample sketch which reproduces the error.

                                • 13. Re: New release of Galileo software
                                  dev.null

                                  Hello Intel_Jesus,

                                   

                                  Thank you for your reply.

                                  I did confirm the board's serial port and that it is detected as gadget serial 2.4 .

                                  With "Intel_Galileo_Arduino_SW_1.5.3_on_MacOSX _v1.0.0" I always get the "Target firmware version query failed".

                                   

                                  With "Intel_Galileo_Arduino_SW_1.5.3_on_MacOSX _v0.7.5", I can upgrade the firmware on the board.

                                  In this case, I get a popup with: "Target firmware(782) is same as the downloaded image. Do you wish to upgrade ? yes/no"

                                  If I press "yes", then after some time I get: "Target Firmware Upgraded Successfully".

                                   

                                  Is it possible to upgrade the system manually (from the command line, either on OSX or "inside" galileo's linux) ?

                                   

                                  best regards

                                   

                                  UPDATE:

                                  I managed to update to v1.0.0 on OSX 10.7.5, by copying "lrz" and "lsz" from Arduino v0.7.5 into Arduino v1.0.0 ( Arduino.app/Contents/Resources/Java/hardware/tools/x86/bin )

                                  The Blink v1.0.0 example now works if I use "my" custom v1.0.0… However, if I try "Blink" with your Arduino v1.0.0, it compiles and uploads without errors, but nothing happens on the board...

                                  • 14. Re: New release of Galileo software
                                    Intel_Jesus

                                    Hi dev.null,

                                     

                                    It looks like you have the old IDE with firmware version 782. Copying the lrz and lsz, can cause unexpected behavior. Please redownload and install the new IDE. You can find it here:Galileo Software Downloads. Without any modifications it will include the latest firmware 1.0.0.

                                     

                                    Regards,

                                    Intel_Jesus

                                    1 2 Previous Next