4 Replies Latest reply on May 26, 2014 8:30 AM by kevin_intel

    My unboxed NUC  DN2820FYKH is a dead brick

    JacobBogers

      My NUC  DN2820FYKH is dead, no screen, no network light blinking anymore,..,this after CHANGING the boot ORDER (disabling network boot) and enabling boot from usb.

      When it was still working, it didnt report the 8GIG on the main setup screen (although on a subscreen for temperature monitoring it did see my 8gig ram) wot?

      It NEVR recognized (FAT32) any of my USB sticks, I could not boot from them at all. (other computer and computer at work sees it just fine)

       

      I tried flashing bios (removing jumper) put bios file on usb (oh wait it doesnt see usb right?) anyway....nothing, the power light didnt blink indicating a bios update

       

      Hence i have now  A DEAD BRICK!

       

      So after changing the bios settings disabling network boot, disabling optical drive boot,.., the nuc tried to boot from harddisk (new and not formatted) of course this would have failed so after resetting...., to get back into bios setup...., DEAD brick.

       

      This is ABNORMAL to have a product not recognizing most basic hardware.

       

      What do i do know? I have a dead brick!!