1 2 Previous Next 18 Replies Latest reply on May 26, 2014 1:41 AM by Cordo

    DN2820FYKH boot

    Cordo

      Hi,

       

      I have a NUC DN2820FYKH with bios 0032. I have installed Windows 8.1 on a internal SSD - boots fine! Have unmounted the SSD and installed Open Elec on an USB flash drive - can also boot fine. The problem is when the SSD is mounted and the USB flash drive is in the USB-port I can't setup the NUC to boot to USB flash drive as default - I have to press F10 to select USB flash drive to boot Open Elec?! I have tried to disable UEFI-boot in bios and this gives me the opportunity to boot from USB, but then I have to change this setting in bios again to be able to boot Windows from my SSD.

      I seems like the bios has two boot orders one for UEFI and one for legacy devices, and it is not possible to select a legacy device as first boot device without disabling the UEFI-boot option?!

       

      Can anyone help me make my NUC boot from USB (Open Elec legacy boot) as default, and boot from internal SSD (UEFI Windows) when I select this OS with F10 at boot? Removing USB flash drive from NUC to boot from internal SSD would also be an option for me.

        • 1. Re: DN2820FYKH boot
          Akthar.Hussain

          The biggest mistake is we purchased NUC DN2820FYKH , its not stable at all ... and you have to google to fix issues one by one .... i never expect a product from Intel like this  sorry ... 

          • 2. Re: DN2820FYKH boot
            Cordo

            I find it very stable, and the only problem I have is that I can't get it to boot from USB as default when there is a UEFI-OS on the intern disk!

            • 3. Re: DN2820FYKH boot
              sylvia_intel

              Cordo, would you please try the following and let me know if there is any difference when booting?


              • Select system from the Control panel.
              • Choose advanced system settings

               

              select OS .JPG

               

              • Select Startup and recovery

              select OS 1.JPG

               

               

              • settings
              • check if OpenElec is in the list with Windows 8.1

              select OS 2.JPG

              • 4. Re: DN2820FYKH boot
                Cordo

                Hi Sylvia

                 

                There is only one entry in the list and that is "Windows 8.1" (windows don't know that I installed OpenElec - as i wrote I unmounted SSD before I installed OE on the USB flash drive). There is of course no difference in boot after i looked in the settings for startup and recovery?!

                • 5. Re: DN2820FYKH boot
                  sylvia_intel

                  Cordo, I would recommend you to contact or to post your issue to the OpenElec community so they can provided you a script that can overwrite INI from Windows 8.1  http://openelec.tv/forum/



                  • 6. Re: DN2820FYKH boot
                    Cordo

                    Hi Sylvia

                     

                    I want to setup the NUC to boot from USB flash drive as first option. I am not interested in using Windows 8.1 boot manager to boot OpenElec. The problem with Windows 8.1 boot manager is that it first loads a lot of Windows stuff and afterwards restarts to boot other OS - this is in my opinion waste of time. I don't know much about UEFI-bios but I thought the boot order could be set in the same order as in a non UEFI-bios?! In my 5 year old mother board (with Intel chipset) I can easily choose to boot from USB as first option! 

                    • 7. Re: DN2820FYKH boot
                      JacobBogers

                      My NUC is dead, no screen, no network light blinking anymore,..,this after CHANGING the boot ORDER (disabling network boot) and enabling boot from usb.

                      When it was still working, it didnt report the 8GIG on the main setup screen (although on a subscreen for temperature monitoring it did see my 8gig ram) wot?

                      It NEVR recognized (FAT32) any of my USB sticks, I could not boot from them at all. (other computer and computer at work sees it just fine)

                       

                      I tried flashing bios (removing jumper) put bios file on usb (oh wait it doesnt see usb right?) anyway....nothing, the power light didnt blink indicating a bios update

                       

                      Hence i have now  A DEAD BRICK!

                       

                      So after changing the bios settings disabling network boot, disabling optical drive boot,.., the nuc tried to boot from harddisk (new and not formatted) of course this would have failed so after resetting...., to get back into bios setup...., DEAD brick.

                       

                      This is ABNORMAL to have a product not recognizing most basic hardware.

                       

                      What do i do know? I have a dead brick!!

                      • 8. Re: DN2820FYKH boot
                        JacobBogers

                        Hi Cordo, i wanted to do the same thing changing boot order, .. since dispite checking 'boot from usb" it never went to my usb disk, and always went to network boot (supposed to as a last resort) so after disabling network boot in the bios. the nuc brick is now dead. No video output whatsover, even the LAN indicator lights are dead,...,

                        I cant believe intel is selling a product like this.

                        • 9. Re: DN2820FYKH boot
                          JacobBogers

                          Totally agree Akthar,..., I want my money back!  This product was not well tested before they sold it!!!

                          • 10. Re: DN2820FYKH boot
                            JasonHoffman

                            Hi Cordo,

                             

                            Do you know if you had fast boot enabled in the BIOS?  If you remove the cover there's a jumper for BIOS recovery.  I believe it's on 1-2 by default. Moving it to 2-3 should take you into the BIOS immediately on boot.

                             

                            Let me know if that helps.

                             

                            Jason

                            • 11. Re: DN2820FYKH boot
                              Cordo

                              Hi JasonHoffman

                               

                              I have no problem accessing the bios - my problem is that my NUC as default boots my UEFI-Windows partition on my internal SSD - that's not what I want! I want to boot my USB 3.0 flash pen with OpenElec as default! I can only boot to USB devices when I press F10 and select USB boot device or simply disable UEFI-boot devices in bios (but then I can't boot Windows before I revert that setting in bios)


                              To Akthar.Hussain and JacobBogers If you can't contribute with help to my problem, then stay away and please create your own threads with your problems? This is my thread with my problem!

                              • 12. Re: DN2820FYKH boot
                                Cordo

                                I have just upgraded bios to version 0034 - no difference, still the same problem!

                                • 13. Re: DN2820FYKH boot
                                  JasonHoffman

                                  Strange.  I just tested mine with a similar configuration and it works.  In the bios do you have "boot USB devices" enabled? What does the boot order look like?

                                   

                                  Thanks.

                                  • 14. Re: DN2820FYKH boot
                                    dougho

                                    The original post said "seems like the bios has two boot orders one for UEFI and one for legacy devices, and it is not possible to select a legacy device as first boot device without disabling the UEFI-boot option?!"

                                     

                                    I am not from Intel and I don't have my DN2820FYKH until next week, but the above description seems likely to me.  Then you encounter it since Intel's "Operating system installation" note has you installing Windows 8.1 in UEFI mode and OpenELEC in Legacy mode.  I have no familiarity with OpenELEC so don't know if it could be installed to boot in UEFI mode (then hopefully you'd get to prioritize boot order).  Alternatively I don't know if Intel supports booting Windows 8.1 in Legacy mode.

                                    1 2 Previous Next