1 Reply Latest reply on May 19, 2014 10:35 AM by allan_intel

    [DC3217BY] Linux and Uefi Problems still existing in BIOS v49

    DigitalFlow

      Hello everyone,

      I'm having problems while using Debian with my Intel NUC DC3217BY. I try to install Debian onto my Crucial M500 mSata 120GB.

      When installing Debian in UEFI mode, after finishing the install and rebooting, I get the message "No bootable device found."

      Ars Technica also had this problem (Linux on the NUC: Using Ubuntu, Mint, Fedora, and the SteamOS beta | Ars Technica), which made Intel release new BIOS revisions.

      I'm using the currently latest BIOS version 0049 for my NUC, which should fix the uefi issue according to the changelog.

      Unfortunately it doesn't and the only possibility to get it booting is creating a EFI/BOOT directory, copying the grubx64.efi file from /EFI/debian to EFI/BOOT and renaming it to bootx64.efi, as Ars also suggested.

      So the problem is still persistent, although it should be solved in the latest bios version. Can anyone else confirm, that this issue is still existing?

      I ran efibootmgr and it shows that there is an uefi entry for debian:

       

      # efibootmgr

      BootCurrent: 0000

      Timeout: 1 seconds

      BootOrder: 0000,0001

      Boot0000* debian

      Boot0001* UEFI : SATA : PORT 6G 0 : Crucial_CT120M500SSD3 : PART 0 : OS Bootloader