3 Replies Latest reply on May 15, 2014 10:54 AM by kevin_intel

    Intel DH55TC 1st gen mobo doesn't power on

    ramsalam

      lately I've been trying to install a core i5 quad 1st gen cpu to my mobo which didn't make it because of compatibility issues. So I decided to update my h55 intel mobo to latest bios thru thumbdrive update and it was successful tried to install again i5 quad but wont (machine check error), I've install back my core i3 and then all things work. But I also have another 1st gen mobo, a Foxconn h55, I transfered my core i3 there because I want to test it and used it for a long time and then my h55 intel was given a rest. Things changed my friends want to buy my Foxconn Mobo because his one was dead so I said yes to him. But things happen unexpectedly, after I install my components back to my Intel H55, checked before powering it. The mobo's led is lighting but I couldn't get it to work I've tried touching the pwr_btn front panel with a metal but no to avail, it was properly placed on a cool dry place with a static bag on it, removed all installable components. I've experience regret this time as it was my very first mobo and bought it a little pricey here in our local market like 130$ back in 2010, my mobo didn't go through mods or anything it just a plain workstation and a little gaming, didn't abused it at all. So will you give me any idea why it won't work after stocking it for awhile?

       

      Specs:

      Core i3-530 2.93ghz w/ aftermarket cooler

      4gb ram

      gtx 1gb

      sata hdd

      500w tru rated

       

      Problem:

      Mobo power indicator; OK but doesn't turn on