2 Replies Latest reply on May 7, 2014 9:14 AM by cdmurph32

    DN2820FYK PXE Booting

    cdmurph32

      I just wanted to quickly relate my experiences with PXE booting in case they can help anyone.

       

      I use SYSLINUX (pxelinux) to point to the system images.  Most of my PXE images place the root file system on NFS, preventing the need for local hard drives. This works right out of the box on my other systems, most recently a DH77DF, H77 Express Chipset board.

       

      The DN2820FYK defaults to UEFI PXE, which obviously did not work.  When I chose the legacy boot option in the BIOS, the inlaid boot window showed "no boot devices", which was a little disconcerting.

      Pressing ahead, I exited the BIOS interface and attempted to legacy PXE boot.  I was shown the familiar PXE start screen which identified the gateway and TFTP server.  However, instead of displaying my server's pxelinux boot menu, the DN2820FYK suddenly rebooted.  This cycle repeated itself a couple of times before I called it quits.

      My next action was to update the BIOS.  The automated download failed, with "Unable to locate Product ID", however, the USB stick method worked successfully.

      After the BIOS update, PXE booting worked as expected, which is nice since I really didn't want to buy SSD for this system.