1 2 Previous Next 21 Replies Latest reply on Oct 14, 2014 9:08 AM by firehaw

    Firmware update failed-Vista OS problem?  Help......

    bjkellett

      Maybe this is a Vista OS problem.  I've tried moving the arduino folder up the tree.  Blink also doesn't work.  Same cygwin warning.  Time to upgrade to 7?

       

      Return

      1

      Output

      cygwin warning:

        MS-DOS style path detected: C:/arduino-1.5.3-Galileo/hardware/tools/x86/bin/upgrade.sh

        Preferred POSIX equivalent is: /usr/bin/upgrade.sh

        CYGWIN environment variable option "nodosfilewarning" turns off this warning.

        Consult the user's guide for more details about POSIX paths:

          http://cygwin.com/cygwin-ug-net/using.html#using-pathnames

      starting download script

      Args to shell: C:/arduino-1.5.3-Galileo/hardware/tools/x86/bin sysimage_00782_capsulefull_noreset.cap COM1 cat /sys/firmware/board_data/flash_version

      /dev/ttyS0

      NO OF ARGS = 5

      execute remote command

      C:/arduino-1.5.3-Galileo/hardware/tools/x86/bin/upgrade.sh: line 34: /dev/ttyS0: No such device or address

        • 1. Re: Firmware update failed-Vista OS problem?  Help......
          JPMontero_Intel

          Hi bjkellett

          One thing you can try is to change the name of the folder from arduino-1.5.3-Galileo to just Galileo. Other thing you can try is to follow this post https://communities.intel.com/thread/51071 , it looks like a similar error is not identical, but might help. Let me know if it worked
          Regards
          JPMontero_Intel

          • 2. Re: Firmware update failed-Vista OS problem?  Help......
            AlexT_Intel

            If that didn't work, try uncommenting lines 15 and 17 in that upgrade.sh, that would provide a little more information.

             

            Right now it looks like it doesn;t really see the COM port Galileo is connected to. What's the COM port name and number you see in the Device Manager for Galileo connection?

            • 3. Re: Firmware update failed-Vista OS problem?  Help......
              bjkellett

              Ok, tried it and here's the error message.   Note I've moved the Galileo to the C drive;

              $'\r' command not found.  What's that end of line carriage return?

               

              Return

              2

              Output

              cygwin warning:

                MS-DOS style path detected: C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh

                Preferred POSIX equivalent is: /usr/bin/upgrade.sh

                CYGWIN environment variable option "nodosfilewarning" turns off this warning.

                Consult the user's guide for more details about POSIX paths:

                  http://cygwin.com/cygwin-ug-net/using.html#using-pathnames

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 1: $'\r': command not found

              starting download script

              Args to shell: C:/arduino-1.5.3/hardware/tools/x86/bin sysimage_00782_capsulefull_noreset.cap COM1 cat /sys/firmware/board_data/flash_version

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 4: $'\r': command not found

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 8: $'\r': command not found

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 12: $'\r': command not found

              COM PORT 1

               

               

               

               

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 16: 1

               

               

              : syntax error: invalid arithmetic operator (error token is "

               

               

              ")

              Converted COM Port COM1

              to tty port

               

               

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 19: $'\r': command not found

              NO OF ARGS = 5

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 21: $'\r': command not found

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 27: syntax error near unexpected token `elif'

              C:/arduino-1.5.3/hardware/tools/x86/bin/upgrade.sh: line 27: `elif [ "$#" -gt "3" ]

              '

              • 4. Re: Firmware update failed-Vista OS problem?  Help......
                Intel_Jesus

                Hi bjkellett,

                 

                It looks like you have not selected the right COM port or the driver has not been installed properly. From the message you provided, it shows that you are using COM 1. Usually all computer have COM 1 already being used.

                 

                When i do a firmware update this is part of the message:

                COM PORT 5

                Converted COM Port COM5 to tty port /dev/ttyS4

                 

                Notice the "COM PORT 5" that what i have selected in the IDE and confirmed from the Device Manager. Can you provide a screenshot of your Device Manager with the "Ports" list expanded. and a screenshot of the Tools -> "Serial Port" expanded?

                 

                Regards,

                Intel_Jesus

                • 5. Re: Firmware update failed-Vista OS problem?  Help......
                  bjkellett

                  For the Arduino IDE the  bottom right says Intel Galileo on COM4.  Under the Tools->Serial Port COM4 is checked.  Same error message as above. post

                   

                  Device Manager under  General   Location:  Port_#0001.Hub_#0008 

                  Under Port Settings, Advanced button, its COM Port Number COM4.Arduino_IDE.PNG

                   

                   

                  Device_Manager.PNG

                  • 6. Re: Firmware update failed-Vista OS problem?  Help......
                    Intel_Jesus

                    Hi bjkellett,

                     

                    Try the following steps:

                    1. Disconnect cables from Galileo (power supply, micro USB, etc.)
                    2. Remove SD card, Wi-Fi Card, and any shields connected to Galileo.
                    3. Restart your computer
                    4. Open Arduino IDE 1.5.3
                    5. Connect the power supply to Galileo
                    6. Connect micro USB to Galileo and plug the USB on a different port on the computer
                    7. Give Galileo a minutes to boot completely.
                    8. Select COM port according to you device manager
                    9. Try to update the firmware

                     

                    Let me know if you get the same message.

                     

                    Regards,

                    Intel_Jesus

                    • 7. Re: Firmware update failed-Vista OS problem?  Help......
                      dafoink

                      there needs to be another solution besides "restart your computer."  this is really crazy.  some of us have large machines that are not meant to reboot.

                       

                      Is there any chance that this will get to a point where we don't have to reboot everything, do the hokey pokey and turn everything around?

                       

                      If others don't see this as an issue, then I will be quiet.  but it is crazy that I have to reboot my computer every time I bounce the Galileo.

                      • 8. Re: Firmware update failed-Vista OS problem?  Help......
                        Intel_Jesus

                        Hi bjkellett,

                         

                        You are selecting COM 4 in the IDE which is correct. We verified this with the Device manager. There is a process running on your windows machine that is locking your COM 4. If you can find the process and terminate it, then there is no need to restart. I suggest you use process explorer to help you find it. you can also check if the following processes are running "bash.exe" and "lsz.exe" when doing a firmware update these two are running. 

                         

                        Regards,

                        Intel_Jesus

                        • 9. Re: Firmware update failed-Vista OS problem?  Help......
                          dafoink

                          Killing bash.exe and lsz.exe will now allow me to upload my sketch to the galileo.  but, still doesn't allow me to do the firmware update.  I am getting the same error as bjkellett.

                           

                          but, this is a big improvement. I should be up to date on my firmware.  but, being able to reboot my galileo without rebooting my computer, by killing bash.exe and lsz.exe, saves me a lot of time.

                           

                          thanks!

                           

                          brian

                          • 10. Re: Firmware update failed-Vista OS problem?  Help......
                            Intel_Jesus

                            Hi dafoink,

                             

                            It looks similar but may be different, could you turn on the Verbose output on the Arduino IDE and send the log.

                             

                            Regards,

                            Intel_Jesus

                            • 11. Re: Firmware update failed-Vista OS problem?  Help......
                              dafoink

                              I now don't have a problem uploading a sketch (as long as bash.exe and lsz.exe are killed first).


                              when I run update firmware

                               

                               

                              firmware.png

                               

                               

                               

                               

                              this is the verbose output:

                               

                              Return
                              128
                              Output
                              cygwin warning:
                                MS-DOS style path detected: E:/Arduino/GalileoArduino/hardware/tools/x86/bin/upgrade.sh
                                Preferred POSIX equivalent is: /usr/bin/upgrade.sh
                                CYGWIN environment variable option "nodosfilewarning" turns off this warning.
                                Consult the user's guide for more details about POSIX paths:
                                  http://cygwin.com/cygwin-ug-net/using.html#using-pathnames
                              starting download script
                              Args to shell: E:/Arduino/GalileoArduino/hardware/tools/x86/bin sysimage_00782_capsulefull_noreset.cap COM3 cat /sys/firmware/board_data/flash_version
                              /dev/ttyS2
                              NO OF ARGS = 5
                              execute remote command
                              ^XB00000000123273Retry 0: Got TIMEOUT
                              ^XB00000000000000Retry 0: Got TIMEOUT

                              Transfer incomplete

                              • 12. Re: Firmware update failed-Vista OS problem?  Help......
                                Intel_Jesus

                                Hi dafoink,

                                 

                                There must be another process that is locking the COM port. The easiest way is to restart your computer to clear the processes or use a similar tool like process exploror to find whats locking your COM port.

                                 

                                Regards,

                                Intel_Jesus

                                • 13. Re: Firmware update failed-Vista OS problem?  Help......
                                  dafoink

                                  well, uploading a sketch works fine.  but just not updating the firmware.  Rebooting my computer just isn't practical since that could take quite awhile to have it shut down all my hyper-v sessions, sql server, and everything else.  so, I will just have to live with this for now.  I updated firmware a few weeks ago (used to work). 

                                  and like I said, uploading a sketch now works if I kill bash.exe and lsz.exe.  That was the biggest part of my battle.

                                   

                                  thanks,

                                   

                                  brian

                                  • 14. Re: Firmware update failed-Vista OS problem?  Help......
                                    dafoink

                                    ok.  I am giving it one more try (still without a reboot of my computer.  It hasn't been rebooted since February, so I am trying to keep it that way )

                                     

                                    but, I did a shutdown of the Galileo, pulled the power, then brought it back up.  and now getting this when I try to upgrade firmware (which is different than the timeouts that I was getting earlier.  NOTE:  I can still upload a sketch, though I was getting some errors copying the sketch.elf to sketch.elf.old, so I deleted the sketch files from /sketch on the galileo.  which is why I rebooted the Galileo and decided to try the update firmware again)

                                     

                                    anyway, this is what I am getting now.  where I am getting permission denied on /dev/ttyS2

                                     

                                    Return

                                    1

                                    Output

                                    cygwin warning:

                                      MS-DOS style path detected: E:/Arduino/GalileoArduino/hardware/tools/x86/bin/upgrade.sh

                                      Preferred POSIX equivalent is: /usr/bin/upgrade.sh

                                      CYGWIN environment variable option "nodosfilewarning" turns off this warning.

                                      Consult the user's guide for more details about POSIX paths:

                                        http://cygwin.com/cygwin-ug-net/using.html#using-pathnames

                                    starting download script

                                    Args to shell: E:/Arduino/GalileoArduino/hardware/tools/x86/bin sysimage_00782_capsulefull_noreset.cap COM3 cat /sys/firmware/board_data/flash_version

                                    /dev/ttyS2

                                    NO OF ARGS = 5

                                    execute remote command

                                    E:/Arduino/GalileoArduino/hardware/tools/x86/bin/upgrade.sh: line 34: /dev/ttyS2: Permission denied


                                    1 2 Previous Next