4 Replies Latest reply on May 5, 2014 10:02 AM by pcnimbley

    DN2820FYKH Memory

    pcnimbley

      Finally received my DN2820FYKH that I ordered 2.5 months ago.  Threw in the memory and SSD I had for it and of course after 2.5 months of waiting it won't post, no video display at all and this is on a standard monitor via a HDMI to DVI cable so its not the display resolution issue.  Figuring its the memory.  Anyone see why this Crucial part wouldn't work?  Crucial CT51264BF1339.  Its 1.35V, but only DDR3-1333, all of the parts listed on the compatibility page are DDR3-1600. When I ordered (way back when I thought I'd have the NUC in a few days) it wasn't listed as compatible, nor-incompatible on Crucial's site.  Now of course 2.5 months later its listed as incompatible if I put the DN2820FYKH into the compatibility checker on Crucial's site.  Guess I just can't figure out why, and rather annoyed now because due to the wait on the NUC of course I can't return the memory.  Figured I'd just see if anyone had any insight before ordering up a module listed in the compatibility chart.

        • 1. Re: DN2820FYKH Memory
          ItsHappeningAgain

          Having just put together 2 DN2820FYKH, I get the no video signal when using a HDMI to DVI adaptor on a HP monitor that one of the computers is built for. The other is going with a new LG IPS235P using straight HDMI also gives no signal. Though plugging straight into a HDMI Samsung TV and my EIZO monitor I can see the Intel logo etc.

          I am using Kingston 4GB KVR16LS11/4 memory in mine, also not listed on the very small Intel compatible list, but listed as compatible on the Kingston website.

           

          I now have the additional problem that I can not get into the BIOS, it will just not accept F2 or any other F commands. And am also wondering if these issues are caused by incompatible memory as the OP is asking?

          • 2. Re: DN2820FYKH Memory
            pcnimbley

            Well thanks for the reply.  Based on your experience I decided to give it a whirl hooked it up to my Panasonic 60vt60 and lo and behold it worked.  A little bit of wrestling with the bios settings to get the bios updated and Windows 7 installed, but its now up and running with 64bit Windows 7.  Can't for the life of me imagine why I would get no video on a PC monitor but have it work just fine on my plasma.  Go figure.....

            • 3. Re: DN2820FYKH Memory
              ItsHappeningAgain

              No problem, glad you solved your problem.

               

              I have managed to solve my problem as well, by borrowing a no name brand USB keyboard from a friend, that let me into the BIOS. I have also updated the BIOS to 0032 (FYI: Intel recommends installing previous bios versions first in order) and it now works with my MS keyboards and with the HP monitor using the HDMI to DVI adaptor.

               

              Would seem the shipping BIOS 0015 was the culprit here, they are both running fine now.

               

              Hope this info helps other who are having problems, these boxes seem to be a source of a headache for many.

              • 4. Re: DN2820FYKH Memory
                pcnimbley

                Yeah they really need to stop shipping these with the 0015 bios, its complete junk.  Even after I got video it took me about 20 minutes to get a combination of bios settings and usb hookups that worked so I could just update the bios.  By that I mean which of the the 3 USB ports I had my mouse, keyboard, and usb stick with the bios hooked up to.  Once I got the 0032 bios on there it behaved much better, though it did take some more bios tweaking to get the Windows 7 install going.  On my first attempt it blue screened with some error telling me the bios wasn't ACHI compatible or something along those lines.  Oh and I went right from 0015->0032, didn't seem to cause any issues.  I'll have to try my monitor again with the new bios to see if it gets video.