6 Replies Latest reply on Jun 10, 2015 10:59 AM by Hasc

    Debian on DN2820FYKH

    anktarius

      Hello everyone !

       

      Did you succeed to install debian on intel dn2820 ?

       

      I tried to install wheezy or jessie but no succeed.

      I tried with UEFI or without, on the usb 3 port or not.

      Sometime keyboard stop respond after the first menu of debian installation or the nuc just freeze in black screen and need a reboot.

       

      No problem to install windows 8.1 or Ubuntu 14.

      Bios : 028

       

       

      Somebody success ? How do you do ?

      Thank you for reading !

        • 1. Re: Debian on DN2820FYKH
          sylvia_intel

          Hello Anktarius, I’m sorry to hear you are having issues with your NUC.

          Regarding the operating system you are trying to install I would need to inform you that this specific NUC support Windows 8 and Windows 8.1 64-bit only.  There is partial support for Windows 7.  We have received comments from customers reporting compatibility with Linux flavor OS, however Intel has not validated them.

           

          If a BIOS update is necessary, the best thing would be to install the next BIOS version, in this case BIOS version 0021.  

          When there are a few BIOS versions between the original and the latest, it is better if we install each of them. Sometimes, the latest BIOS do not include the fixes of the previous ones.

           

          Concerning the problem with your keyboard, please try installing the new USB 3.0driver. You would be able to find it on this link http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=23734


          You can also try updating your BIOS to the latest version 0032 that just got posted: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23813

          • 2. Re: Debian on DN2820FYKH
            boldstripe

            I have recently received my DN2820FYKH (version: H22962-101) and I successfully installed Debian Jessie.

            • I could not do anything until I plugged in a different monitor, an LCD TV rated at 720P with an HDMI input –– before that, on my fancy NEC 2690WUXi which is supposed to support everything, I got a blank screen on boot.
            • When I had a working monitor, I updated to BIOS FY.0032 before attempting the Debian installation, by pressing F7 on startup with the updated firmware file on a USB flash drive
            • After the firmware update, my NEC monitor worked fine.
            • I installed Wheezy first from a Netinstall CD (v7.3), accepting the Installer's defaults such as a single partition. I did not stay there for long because I only got limited screen resolutions like 1600x1200 (if I remember), so I updated to Jessie (testing) by editing my sources.list file, a common technique you can find on the web
              • Before the Wheezy to Jessie upgrade would work in Synaptic, I had to manually install python-glade2 using Synaptic

            Now it works OK, it certainly seems faster than my old Samsung Netbook running Jessie.

             

            I did not even discover the fancy Intel BIOS boot panel until I had a working Jessie computer, and I was not aware of making any choices to do with UEFI, just the standard installer did its stuff. When I discovered the BIOS panel, I raised the video memory to 256 MB.

             

            Plus, a bonus: despite the specs of the DN2820FYKH which state maximum display resolution of 1920x1080, and despite warnings on this board by Intel staff that this could not be upgraded by a firmware update by them, I am successfully running my NEC monitor at its full 1920x1200 pixels, its native resolution. Can't explain why, it may not work for you, but perhaps I should thank the Firmware update?

            1 of 1 people found this helpful
            • 3. Re: Debian on DN2820FYKH
              jreusch

              hi anktarius

              i recently encountered the same problem.

              when did you download the debian jessie installation image?

              it is regenegrated every wheek.

              i had an image from march and showed the problem you described.

              just downloaded the newest debian-testing-amd64-netinst.iso and everything works just fine

              hope that helps.

              Jan

              • 4. Re: Debian on DN2820FYKH
                TJButler

                I was able to get Debian Wheezy installed and running without issue.

                 

                I've noticed that my monitor sometimes has a hard time syncing with the signal.  I'm using a VGA to HDMI adapter.  If I unplug and replug the video connections it usually restores the connection.  Sometimes it requires a reboot to sync up again.

                • 5. Re: Debian on DN2820FYKH
                  bh-whd

                  Hi all debian fans!

                   

                  I want to buy a NUC DN2820FYK and setup a little private cloud: Debian with samba server, apache server, mysql server and so on.

                  Because I do not know, if the DN2820 has enough power, I thouhgt, you perhaps can help me?!

                   

                  Perhaps some debian fans can do some benchmarks for me and post them here?

                   

                  Benchmark1:

                  7z b -mmt2 -md24
                  

                   

                  Benchmark2:

                  sysbench --test=cpu --num-threads=2 --cpu-max-prime=20000 run
                  

                   

                  Benchmark3:

                  Step1:

                  sysbench --test=oltp --oltp-table-size=1000000 --mysql-db=test --mysql-user=root --mysql-password=xxxx prepare
                  

                  Step2:

                  sysbench --test=oltp --oltp-table-size=1000000 --mysql-db=test --mysql-user=root --mysql-password=xxxx --max-time=60 --oltp-read-only=on --max-requests=0 --num-threads=8 run
                  

                   

                  Thank you very very much!

                   

                  bh-whd

                  • 6. Re: Debian on DN2820FYKH
                    Hasc

                    Hello;

                     

                    Just wanted to share my experiences installing Debian Jessie on NUC DN2820FYKH.

                     

                    First of all, the usb installer did not work. It always got locked up at mid install, I had to reboot the thing. Tried 3 times and gave up, then I tried the "Install from a GNU/Linux system" method (D.3. Installing Debian GNU/Linux from a Unix/Linux System). As "Unix/Linux System" I used System Rescue CD, booting from a LiveUSB. I installed the standard apps (base system, printing server, desktop environment, etc.).

                     

                    The installation worked fine, and my Debian system booted right, *the first time*. The next day, when I was about to put my credentials to login, the NUC locked up again. Hard-rebooted the thing and tried again, it locked up again. Tried two or three times more, it always locked up. No matter whether I was on console or graphic login.

                     

                    I found this very post, and I decided to upgrade the BIOS (at the time, the NUC had BIOS version 34). The newest version at the time of this writing is 50.

                     

                    The first booting after BIOS upgrade didn't work, my Debian still stopped responding. But then I decided to load default values at BIOS, and then my Debian system worked.

                     

                    I can use the HDMI, Ethernet and the USB ports, didn't try the sound output, nor Wifi.

                     

                    So, to conclude: You can install Debian Jessie on this device, but you should first upgrade to the latest BIOS, then "Load Default Values", just in case.