5 Replies Latest reply on Apr 29, 2014 1:44 PM by AlexT_Intel

    Yocto on Galileo Compiling problem

    LeiZhou

      Hi Sir/Ma'am,


      I am following the instruction of 
      http://www.malinov.com/Home/sergey-s-blog/intelgalileo-buildinglinuximage
      and Intel® Quark SoC X1000 Board Support Package (BSP) Build Guide
      to build the system.
      When I run: bitbake core-image-minimal
      the result is good.
      When I run: bitbake image-full
      the result is:
      | ERROR: Function failed: do_compile (see /home/leizhou/Workspace/Galileo/meta-clanton_v0.7.5/yocto_build/tmp/work/x86_64-linux/guile-native/2.0.7-r1/temp/log.do_compile.16399 for further information)
      ERROR: Task 2016 (virtual:native:/home/leizhou/Workspace/Galileo/meta-clanton_v0.7.5/poky/meta/recipes-devtools/guile/guile_2.0.7.bb, do_compile) failed with exit code '1'
      NOTE: Tasks Summary: Attempted 2727 tasks of which 2701 didn't need to be rerun and 1 failed.

      I am using Fedora 19.
      Could you give me some suggestions for this?

      Thanks.


      Lei

        • 1. Re: Yocto on Galileo Compiling problem
          AlexT_Intel

          Out of the error message it looks like you're trying to build these two images in the same Yocto working dir. Minimal and full images are different enough to be incompatible.

           

          Either delete all but "conf" directory inside the "yocto_build" one (simpler and more robust method) or run "bitbake -c cleansstate core-image-minimal" before building the full one to cleanup properly.

           

          If neither of the above works, post the contents of the log file mentioned in the error message.

          • 2. Re: Yocto on Galileo Compiling problem
            LeiZhou

            Hi ALex,

             

            Thanks for the quick response.

            I run as you mentioned, the result is the same. I appended the log file. Could you please help check it?

            I really appreciate your help.

             

            Lei

            • 3. Re: Yocto on Galileo Compiling problem
              AlexT_Intel

              Thanks. ok, it's still enigmatic enough in the log as well. But after re-reading your initial post, I see you're using fedora 19. It's old enough, probably, but I haven't tried it personally and I've seen things breaking during the Yocto builds due to specific make or gcc or other tool or lib versions.

               

              Is trying ubuntu 12.04 or openSUSE 12.3 (two versions I personally verified to work + there were reports from others) is an option for you? That may be the fastest way to a resolution. You can e.g. try my VM image based on openSUSE I've announced in this community earlier.

              • 4. Re: Yocto on Galileo Compiling problem
                LeiZhou

                Hi Alex,

                Thanks for your response.

                I found a link for guile recipe: fix the depends for target recipes

                poky - Poky Build Tool and Metadata

                And I made change base on it. At least, the building finished without error. Is it the right way?

                Thanks again.

                 

                Lei

                • 5. Re: Yocto on Galileo Compiling problem
                  AlexT_Intel

                  If it fixes it for you - it definitely is :-) That's pretty much the way I used a couple of times already to fix glitches with dmidecode and elfutils compilations, which are incorporated into my Yocto layer at github.com.

                   

                  Thanks for reporting back - now we have a problem revealed and a fix found for building Galileo BSP on Fedora 19, which is very nice - good job.