4 Replies Latest reply on Apr 25, 2014 1:16 PM by kevin_intel

    Weird Intel RAID problem

    Lantorax

      Here's the specs:

      Processor: Intel i7 875k

      Motherboard: MSI P55-GD80

      Memory: Corsair Dominator 4x2GB (forget exact model, 1600mhz I believe, though)

      Graphics: Diamond AMD HD5870 1GB

      PSU: Antec TruePower Blue 750watt

      HDD: 4xWD black 500GB (WDC WD5001AALS-0) drives in raid 10(0+1 so says bios) mode

      Sound: On-board Realtek

      NIC: On-board Marvell

      DVD: Cheap Lite-On thingy, connected via sata

       

      I've spent a couple days trying to figure out what part went bad. At the bottom I'll list my entire debug procedure, but I'll get to the meat of the problem here. Rebooted this machine on sunday to find it took over an hour to boot up, no warnings in the logs about anything failing before hand, no updates, software, or drivers installed anytime recently. My testing actually shows that it seems to be the raid chip that’s gone slightly bad as well as windows drivers are failing on this hardware piece. I've run this machine from MiniXP, WinPE, Win7 Recovery Disc, ESET Recovery Disc. All have the same problem regardless of the raid driver I use- extremely slow access times and slow read speed. I decided to try a Linux distro, Knoppix, and, lo and behold, the drives run just like they're supposed to. Have a look-

       

       

      Windows MiniXP and HD Tune 2.55

      http://s29.postimg.org/3xrbepvfb/hdtune.png

      On this one I’m not sure why it’s reading both volumes as 1, but it's neither here nor there, as all windows kernel boots were the same speed, and the drives were accessible from windows explorer as separate, so the speed’s the important bit in that pic.

       

      And Knoppix palimpsest

      http://s9.postimg.org/ezoqocr1r/linux_hdd_test.png

       

      Now I can only figure the raid chip did die, at least a little, but somehow the Linux drivers are bypassing whatever function did fail. I may have missed something, but I'm unsure what, and I'd love some feedback to figuring this one out.

       

      The motherboard is literally 6 months out of warranty so RMA is out of the question. I don't know much about compiling my own drivers, so this kind of problem is quite beyond me. I'd love to save the board since I wasn't quite ready for an upgrade yet.

       

      And the boring part, my testing:

      First reboot, ran SpyBot, nothing wrong, antivirus timed out and would not load because drive access was too slow

      Made an ESET antivirus rescue disk, which runs from WinPE, set it to scan, cancelled after 19 hours and only about 20% of the drive scanned, no errors.

      Swapped sata cables, no change, swapped ports, no change, SMART scan, no problems.

      Fiddled bios settings a bunch, no difference

      Did a BIOS update from 1.0a to 1.0c, no change

      Made a Knoppix USB flash drive, found that a 51.5gb transfer was taking near the normal amount of time. Installed bit defender, scanned full drive, nothing suspicious.

      Made a MiniXP flash, retested the drive, still snail slow on a windows kernel. Ran HD Tune 2.55, recorded results, then loaded back up Knoppix for palimpsest, and recorded those.

      Additional info:

      I have also tried with and without the DVD drive in when I was swapping ports

      Drivers I’ve tried: MSI: 8.9.0.1023; 12.0.0.49974

                               Intel: 12.9.0.1001; 8.9.0.1023; 12.0.0.49974; 10.1.0.1008


      Thanks for reading

        • 1. Re: Weird Intel RAID problem

          Hi Lantorax,

           

          I am sorry you are having problems but let me help you.

           

          Here are some steps I would like you to do:

          1. Update the BIOS in your computer.

          2. Update the Management Engine driver provided by the Computer Manufacture.

          3. Uninstall the current driver and download the latest one here:

          https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=23496&keyword=12.9&lang=eng

          4. Test a different HDD in case that drive structure is not working properly.

          5. Worst case for troubleshooting purposes would be doing a clean installation of the Operating System and raid volume.

          • 2. Re: Weird Intel RAID problem
            Lantorax

            Thanks for your reply, I guess I wasn't as clear on top as I had intended to be.

             

            1. I did update the bios

            2. I'm not sure what 'Management engine driver' is, honestly, unless you're talking about the motherboard drivers, in which case I have done this(Edit: Oh, just noticed you said 'Computer manufacturer', this is a self built computer, there is no manufacturer other then myself)

            3. I have done this.. with 5 different drivers, including the newest one

            4. This is the one I wish I could do, being this is a home computer we do not have an extra drive to test, all I could do is try different ports, and, to be fair, since the drives are in Intel's RAID 10(0+1), I think I'd need 4 drives to accurately test this

            5. I have booted from multiple Windows OS's from the flash drive. All have the same slow access times. I have run several hard drive tools to see if there was a problem, and they did not find any problems. Also, since the Linux version I used does access them properly, and at the proper speed, really sounds like it should be a raid controller that has gone bad in such a way that it trips Windows drivers up, but not the Linux ones

             

            Thanks again, and if you have any more information I would be happy to hear it.

            • 3. Re: Weird Intel RAID problem
              Lantorax

              All right, went more into the SMART testing, turns out it was a hard drive. First SMART test passed, but went back and ran it again, and Data Lifeguard froze 5 times in a row trying to test it. Unplugged that drive and Windows boots and everything works great. I wonder if Windows and Linux might be using different of the mirrored drives for reading? Interesting, but at least it's solved, thanks again for all the help.

              • 4. Re: Weird Intel RAID problem

                Well it is good to hear it is working and thanks for sharing the information with us.