1 2 Previous Next 22 Replies Latest reply on Sep 15, 2014 6:22 PM by AndyWilson

    D54250WYK Not powering on by MCE remote

    Luckyknight

      I was having an issue powering on the NUC using the power button on top so following information on XBMC forum I removed the CMOS battery for 10 minutes to let the BIOS completely reset to defaults. This actually worked and now I can power on the NUC using the button on the top.

       

      However, what has happened now is that the NUC will no long power on by using my MCE remote. The NUC would power on by my MCE remote just fine before I reset the CMOS. I cannot state clearly enough that is the only change I made.. resetting the CMOS. The MCE remote and OS are configured exactly as they were before.

       

      I've loaded BIOS defaults and rebooted the system. I am using Linux.

       

      The solution to this problem has been that I install Windows along with the MCE remote driver so that the MCE port get's reinitialized. This is quite frankly a really painful solution. I do not have a CD drive for a start.

       

      I believe this is an issue with the BIOS 0025. CIR is enabled. My remote works just fine (Harmony One Plus).

       

      Please have your engineers look into the issue. The issue can be very easily replicated, just clear the CMOS by removing the battery then try turning on the system using a MCE remote. Do not let Windows boot as that might fix the issue.

       

      Here is the thread referencing the issue:

       

      OpenELEC Mediacenter - OpenELEC Forum - Topic: Fixing Intel NUC's! Please help... (2/2)

        • 1. Re: D54250WYK Not powering on by MCE remote
          sylvia_intel

          Hello Luckyknight, we have seen this issue before and we duplicate in our labs. We were able to use this feature without problems on a Windows 8 and 8.1 environments.  Please be aware that Intel only provides support and drivers to Windows Operating system.


          We used an RC6 remote control. What we did was installed the driver, restarted the system and then CIR was working perfectly.

          I would recommend you to check if you are using the correct driver.

          https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23086&lang=eng

          • 2. Re: D54250WYK Not powering on by MCE remote
            ASadani

            Mine nuc powers on but goes to sleep with the power button. However I could fix that by replacing the sleep setting in the bios to the S3 shutdown state. I'm using windows 7 pro.

            1 of 1 people found this helpful
            • 3. Re: D54250WYK Not powering on by MCE remote
              MattyMatt

              I thought powering on is related to the BIOS and not hardware drivers? My knowledge is very basic but I can tell you that the IR works fine once you get into Linux or OPENELEC and XBMC, or whatever non-Windows based OS you use (if you know what you are doing). The problem is being able to power on this box. And to be honest, this is the MOST important feature for most people.

               

              WORK AROUND

              Many have said that you can fix the power on issue by: clearing the CMOS by disassembling the unit and pulling out the battery, installing windows, installing the Intel CIR driver and THEN installing OPENELEC or whatever other LINUS/UBUNTU software over the windows install can fix the "power on" issue on a non-windows based OS... but only for a time. Any tinkering in the BIOS causes the machine to forget to accept data from an IR blast to power on and you have to repeat the asinine process above. I'm not even going to try this. I already had Windows 7 installed on my device. The power on worked after some tinkering in Windows and the BIOS but that is not what I want on my machine. I'm sticking with OPENELEC.

               

              BIOS

              First of all version 0023, 0024 and 0025 are complete F-up's. The BIOS freezes ALL-THE-TIME. I've since updated to the 4025 beta BIOS and it didn't fix anything for me besides the fact the the screen resolution is back to what it was in 0024 (on my TV monitor 0025 BIOS had the screen like 100 pixels by 200 pixels, fun to work in, anyway...). I'm sure the beta BIOS probably fixed some of the HDMI, USB, AUDIO/VIDEO issues that others were having but I haven't had any of those problems. I just want it to power on from an off state, actually any state would be great. Also, on both this machine and the NUC that I returned, the time does not save. Each time I boot into the BIOS my time is different so I correct it often... to no avail. You can take your visual BIOS and shove it where ever you want but I am done dealing with it.

               

              I am on my second NUC D54250WYKH1 model and I think it's about time that you hire someone who can actually fix these issues. I'm about to return my second one. Unbelievable.

              • 4. Re: D54250WYK Not powering on by MCE remote
                bogchop

                Hi Sylvia,

                 

                This is NOT a fix, but a very silly workaround. The unit does not boot fresh out of the box with an MCE remote (RC6 compatible), which this IR is supposedly meant to.

                 

                I'm having the *EXACT* same issue with my i3 NUC (D34010WYK), whereby everything is fine until you play with something in the BIOS, then bam, it's gone. I'm not reinstalling windows to get a piece of hardware working that should be available for use directly out of the box. I've used the EXACT workaround that MattyMatt has described, and I refuse to accept this as a viable solution.

                 

                This absolutely needs to be fixed. It doesn't matter what Operating System you're running - if you've shipped a product that is meant to work out-of-the-box, it should be doing just that. But, it doesn't.

                • 5. Re: D54250WYK Not powering on by MCE remote
                  Stu.in.the.UK

                  Just for reference, my experience has been all good.

                   

                  D54250WYK Bios 025 Legacy Mode. Windows 8.1

                   

                  Aim Remote Control http://tinyurl.com/l7js7rl

                   

                  "I thought powering on is related to the BIOS and not hardware drivers?"   I'm sure it is, mine worked out of the box.

                  My memory's not what it used to be but isn't the IR port disabled by default so clearing the CMOS will revert it to this and so it has to be re-enabled?

                  Maybe the box is very picky as far as remotes are concerned.

                  • 6. Re: D54250WYK Not powering on by MCE remote
                    MattyMatt

                    Thanks for the thoughts Stu. But are you sure your IR worked "out of the box"? Could you turn it on before you installed windows and the drivers? I couldn't on either of my i5's.

                     

                    I don't remember if the IR is "enabled" by default on the two units I received but I believe that it was. The remote I use will turn on the box if you go through the windows install method, enable IR in the BIOS, and I had to change some settings in windows 7, so I don't believe its the remote. It will also work in the OPENELEC or linux OS's on the NUC as it is. It just won't turn the box on. It's not a remote issue.

                     

                    It probably has something to do with how the NUC handles powering down. Like I said in my previous post, my BIOS clock doesn't save time so maybe the battery on the board is bad (not likely on two different units) or something is not saying awake to accept the IR signal. This seems like such an easy thing for anyone with any sort of formal computer training to figure out. I just don't know why it's taking so long.

                    • 7. Re: D54250WYK Not powering on by MCE remote
                      Stu.in.the.UK

                      Sorry for the delay. Methinks the culprit may be the Bios not keeping its settings. Very odd. As an experiment I've just uninstalled the CIR drivers completely , I have a lovely " Unknown device" showing in device manager. It still behaves itself after I power it off, turning on via the remote. I've even unplugged the power cable at the back and left it for ten minutes. Plugged it back in and powered it up via the remote. I'm convinced this IR function is independent of any OS installed.

                      • 8. Re: D54250WYK Not powering on by MCE remote
                        sylvia_intel

                        Internally, we have been notified that our engineers are working with people from OpenElec on the issues that are being seen with that Linux Distribution.

                        We are working together to try and resolve some or all of the issues that have been reported.

                        • 9. Re: D54250WYK Not powering on by MCE remote
                          OllieB

                          Hi Sylvia,

                           

                          that is excellent news. Thanks for sharing. Let's hope they can find the problem and fix it. I would love to be able to start my NUC with a remote!

                          • 10. Re: D54250WYK Not powering on by MCE remote
                            lhill

                            Hi all,

                             

                            I have posted a Beta BIOS to https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23882.

                             

                            This Beta BIOS fixes the issue where some consumer infrared remotes will not wake the Intel® NUC if OpenElec is installed. While internal testing confirms this fix, we want to be sure to get NUC owner feedback as well, before we roll this fix into a production BIOS version.

                             

                            Regards,

                            Lois

                            Intel

                            • 11. Re: D54250WYK Not powering on by MCE remote
                              Larryadd

                              Dear Lhill,

                               

                              1st of all, thank you for taking care of that issue, it means a lot for us.

                              Just tested the bios without success.

                              I installed it on the i5 nuc with openelec already installed and with the nuvotron activation trick (witch causes the issue for me).

                              I will try to install windows with CIR drivers on it and see when I install openelec again if I still need the activation trick in the autostart.sh and see if I can boot.

                               

                              In the mean time, can you detail the install process you did ?

                               

                              Hope it will work !

                               

                              thanks again.

                              • 12. Re: D54250WYK Not powering on by MCE remote
                                OllieB

                                Larry,

                                 

                                Please note that I have tried the new bios on a D34010 and also was NOT able to wake the NUC using my Xbox 360 Media remote. I have tried various settings without success. Installing the bios introduced a new problem on my NUC. The Visual BIOS screen is no longer shown full screen even though my TV reports a resolution of 1920 x 1080. The Visual BIOS screen has a size of about 25% of the display. Do you perhaps have the same problem?

                                • 13. Re: D54250WYK Not powering on by MCE remote
                                  Larryadd

                                  Hi OllieB

                                  I had the same screen size problem.

                                  it as been discussed in that forum, a change since 025.

                                  Have you tried to install windows with the driver and then, install openelec again ?

                                  do you use the nuvotron fix ?

                                  • 14. Re: D54250WYK Not powering on by MCE remote
                                    OllieB

                                    Larry,

                                     

                                    I got a response from Lois about the screen size issue. I had not noticed it before.

                                     

                                    I am using the nuvotron fix as that appears the only way to use the IR under openelec, unless you install Windows first. I don't have a Windows version lying around so I have not installed Windows and/or the CIR driver. I am waiting for Intel to fix this problem. I hope it is not something with the Xbox 360 Media remote though, because I really like this remote

                                    1 2 Previous Next