1 Reply Latest reply on Apr 8, 2014 9:41 AM by mjstanis

    Bitbake requires Python 2.6 on CentOS 5.7

    mjstanis

      Hi everyone,

       

      I'm testing out the BSP build process on a CentOS 5.7 system and I'm running into issues with Python.  From what I've read, it sounds like CentOS requires Python 2.4 to run the package manager and other parts of the system.  I used EPEL to install Python 2.6.8 into /usr/bin/python26, but unfortunately bitbake still doesn't like it:

       

      BitBake requires Python 2.6 or later

       

      I don't want to change the link to /usr/bin/python (2.4) as I'm afraid that will break the system.  I tried using an alias in my terminal, but bitbake still complains.

       

      Any suggestions?

       

      Thanks!

      Matt

        • 1. Re: Bitbake requires Python 2.6 on CentOS 5.7
          mjstanis

          Looks like I got it figured out after playing around a bit.

           

          I started with using the EPEL version of Python 2.6 and adding a new path to a python softlink in my homedir to Python 2.6 like the following in my .bashrc:

           

          export="/path/to/my/python/softlink:${PATH}"

           

          That failed on the 'as' keyword in the 'except' phrases in Python code, so bitbake started and almost immediately failed.

           

          Next up, I used the CentOS 5 instructions on this page for the standalone Python tarball:

           

          https://wiki.yoctoproject.org/wiki/Poky/GettingStarted/Dependencies

           

          After untaring the archive, moving it to /opt and adding it to my PATH variable via .bashrc, bitbake seems much happier.

           

          Now, on to the bitbake and the next issue

           

          Thanks!

          Matt