1 Reply Latest reply on Apr 7, 2014 10:27 AM by kevin_intel

    RAM to VRAM reallocation issue

    kony
      It looks like Linux Mint 15 doesn't reallocate RAM to VRAM dynamically and there's no such option to set minimum amount in my BIOS. I guess, Windows would get up to over 1.5GB of RAM and allocate it to VRAM when needed (but I don't have Windows to check it out), whereas in LM15 it always stays at 256MB. My iGPU is Intel HD 4000.  Lack of VRAM results in constant crashes in a game Kerbal Space Program. Moreover, sometimes the game freezes the entire OS. The crashes/freezes are much rarer if I set textures to the minimum. The same thing happens in a game Euro Truck Simulator 2 - if I set textures and anisotropic filtering to maximum, it only takes a few seconds until the game freezes my OS, while I can play just fine on low textures. Linux never allocates more than 256 MB of RAM for video card in both KSP and ETS2.

       

       

      sudo lspci -v -s 00:02.0

      00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09) (prog-if 00 [VGA controller])

         Subsystem: Lenovo Device 21f3

         Flags: bus master, fast devsel, latency 0, IRQ 43

         Memory at f0000000 (64-bit, non-prefetchable) [size=4M]

         Memory at e0000000 (64-bit, prefetchable) [size=256M]

         I/O ports at 5000

         Expansion ROM at <unassigned> [disabled]

         Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-

         Capabilities: [d0] Power Management version 2

         Capabilities: [a4] PCI Advanced Features

         Kernel driver in use: i915




      sudo dmesg | grep drm

      [  0.751141] [drm] Initialized drm 1.1.0 20060810

      [  0.984183] [drm] Memory usable by graphics device = 2048M

      [  1.005554] [drm] Supports vblank timestamp caching Rev 1 (10.10.2010).

      [  1.005556] [drm] Driver supports precise vblank timestamp query.

      [  1.268552] [drm] GMBUS [i915 gmbus dpb] timed out, falling back to bit banging on pin 5

      [  1.374961] fbcon: inteldrmfb (fb0) is primary device

      [  2.187772] i915 0000:00:02.0: fb0: inteldrmfb frame buffer device

      [  2.197836] [drm] Initialized i915 1.6.0 20080730 for 0000:00:02.0 on minor 0

      [  2.813851] [drm] Enabling RC6 states: RC6 on, RC6p on, RC6pp off



      As you can see, IN THEORY the OS should use 2 GB of VRAM, or at least it looks so to me. However, even if running KSP or ETS2, the amount of VRAM never changes and this results in a game crash/OS freeze.


      Here's a screenshot when I have KSP running in another workspace (it's basically the same with ETS2):

        • 1. Re: RAM to VRAM reallocation issue

          Hi sonarctica,

           

          I am sorry you are having problems but let me help you.

           

          Note that the Intel® graphics controllers uses shared memory that is taken from the RAM memory installed on your computer.

           

          The feature that sets the amount of memory that is used for video is called Intel® Dynamic Video Memory Technology and this will make the graphics controller only to use the amount of RAM memory that it requires to run the different applications or software’s.

           

          I am afraid to say that there is no way to preset this to an specific value; however, you can limit the maximum memory that it can take only. You will see this option usually in BIOS and you will have 3 options, 128MB, 256MB and maximum DVMT. Other values can be found as 512MB, etc but this depends on the motherboard manufacturer and the amount of RAM memory installed on your computer.

           

          In case you are having problems with the Operating System pulling the vram my best recommendation is to check on Linux communities so that other user can help you with a special configuration for Linux Mint.