4 Replies Latest reply on May 13, 2014 12:48 PM by Roy_B

    Can't configure proxy correctly for opkg

    Jartal

      Hello.

       

      I´m starting to use the intel Galileo board and I stuck when trying to use opkg. I need to go throught the company proxy but I cant`t get it work.

       

      This is what I put in my opkg.conf for the proxy settings

       

      # Proxy Support

      option http_proxy http://usuario:contraseña@proxy.company.es:8080/

       

      I also tried with this:

       

      option http_proxy http://proxy.company.es:8080/

      option proxy_username xxxx

      option proxy_password xxxx

       

      When I try to do a "opkg update" I get the following:

       

      root@clanton:~# opkg update

      Downloading http://downloads.openwrt.org/backfire/10.03/ar71xx/packages/Packages.gz.

      wget: server returned error: HTTP/1.1 407 Proxy Authentication Required

      Collected errors:

      * opkg_download: Failed to download http://downloads.openwrt.org/backfire/10.03/ar71xx/packages/Packages.gz, wget returned 1.

       

       

      I know that the username and password are correct so thats why I don't know what to do next.

       

      ¿Did someone had the same problem?

       

      Regards.