14 Replies Latest reply on Apr 18, 2014 3:09 PM by Intel_Jesus

    Intel Galileo is not detected.

    mike_one

      I connected the power cable to the card, I've also connected the usb cable to the computer, but I absolutely did not detect anything. I installed the driver, restart the computer with the hope of positive results but the computer did not detect my arduino Galilean.

      This is the image of the card connected.

       

      Galileo.jpg

      Galileo2.jpg

      leds on, usb connector and Ethernet are active.

      consult with various usb cables and multiple power sources to 5V . I have not had positive results and I am desperate.


      He conectado el cable de alimentación a la tarjeta, también he conectado el cable USB al ordenador, pero absolutamente no detectó nada. He instalado el controlador, reinicie el ordenador con la esperanza de resultados positivos, pero la computadora no detecta mi arduino galileo.

      Ya consulte con varios cables usb y fuentes de alimentación a 5V, pero sigo sin obtener resultados positivos. Los leds de "on" y "usb" están encendidos, asi como el led de conector ethernet. Estoy desesperado.

        • 1. Re: Intel Galileo is not detected.
          SpiderKenny

          The yellow bang "!" on the COM port in device manager suggests that there is no valid driver installed for the serial port which connects your Galileo.

           

          This happens on my Windows Laptop too, yet on my Apple Mac it just works without any driver.

           

          On windows it evaluates as "Gadget Serial v2.4" so we need to download and install this driver.

          On my system, I downloaded the Arduino Zip from here and extracted it to a folder.

           

          Then, double click on the port in device manager, and select 'update driver' then "Browse my computer..." so that we can specify where to look for the driver. Then browse to the folder you unzipped the Arduino zip into and make sure 'include subfolders' is ticked. It then found and installed the correct driver and the serial port worked and Galileo was detected.

          1 of 1 people found this helpful
          • 2. Re: Intel Galileo is not detected.
            LarsR

            The fact that you can see the yellow bang "!" on that COM port at all tells you that Windows IS seeing something, it just doesn't know what to do with it, as SpiderKenny correctly points out.

            It goes away when you pull the USB cable, right?

             

            You wouldn't be so lucky as to have another serial cable, this one for the round serial jack, so you could see what the Galileo spits out on the console when the USB connection is made?

             

            You could also try to open up the yellow bang COM port and show us what the status on the "General" tab is.

            It should show you a status code, like every other device in device manager does.

             

            Lets start with that, I'm sure we can figure this one out for you.

            1 of 1 people found this helpful
            • 3. Intel Galileo is not detected.
              AlphaCHarly

              Install the drivers manually and the problem will go away.

              A couple of times I found that even when the drivers are installed and normally working well, you need to unplug the USB and plug it again in order to make it work, in a couple of instances, I had to reboot windows to make it to work.

              I thinks that is part of the issue dealing with the communication between the board and the PC and the continuos loading new sketches on a development life cycle.

              Buena suerte.

              AC/.

              • 4. Re: Intel Galileo is not detected.
                mike_one

                Hello SpiderKenny.

                Thanks for the reply.

                In fact I installed manually as you describe.

                Download the driver, I decompress folder, I clicked on the device manager, and select "update driver". After updating, the port continues to indicate the same.

                • 5. Re: Intel Galileo is not detected.
                  mike_one

                  Hello LarsR.

                  Not disappears. if not manually installed the driver would not appear the "Galileo" port.

                  Visual description. Without connecting and after connecting

                  Galileo3.jpg

                  Device Type: Ports ( COM & LPT).

                  Manufacturer: Intel Corporation

                  Location: Unknown .

                  Device Status: This device can not start. ( Code 10)

                  • 6. Re: Intel Galileo is not detected.
                    mike_one

                    Hello AlphaCHarly.

                    Thanks for the reply.

                    Now restart your computer many times , connect and disconnect the USB cable, I tried with 3 different computers. windows 7 , windows xp and anything.

                    • 7. Re: Intel Galileo is not detected.
                      mike_one

                      The first time I tried. Connect the USB cable, but do not connect the power supply of 5V.

                      Is it damaged?

                      • 8. Re: Intel Galileo is not detected.
                        rmm200

                        Vanishingly low probability of damage. Only reported case was using a high current shield at the time.

                        • 9. Re: Intel Galileo is not detected.
                          mike_one

                          Hello rmm200.

                          Thanks for the reply.

                           

                          The first time I tried. Connect the USB cable, but do not connect the power supply of 5V. FOR 20 MINUTES. Is it damaged?

                          • 10. Re: Intel Galileo is not detected.
                            LarsR

                            Can you try to unplug the USB and then remove the device with the uninstall button?

                            Windows will ask you if you want to keep the driver or not. Choose keep.

                            Then reboot your machine.

                            Turn off the Galileo by pulling it's power plug.

                            Turn the Galileo back on and allow it to boot w/o any SD card (you didn't say if you had upgraded it, assuming not).

                            You need to give it a few moments, even after the USB led lights; there's not yet a linux driver at the other end.

                            Make sure you have no COM ports on device manger after it comes back up.

                            Give the Galileo another minute (this is alot easier to see if you have a serial console...) to get ready.

                            Then, and only then, should you try to make the USB connection.

                            Let us know how it goes then.

                             

                            If anyone at Intel reads this; please consider putting a serial cable in the box, we need one!

                            • 11. Re: Intel Galileo is not detected.
                              mike_one

                              Hello LarsR.

                              Thanks for the reply.

                              I followed your instructions step by step. Even wait 2 minutes to connect the usb cable and wait 2 more minutes to see if the port was detected. But still does not detect the port. Not have any SD memory connected. Get a USB-serial cable, where do I connect it?.

                               

                              I ask for an apology because I do not speak English, but I still my best to write in English.

                              • 12. Re: Intel Galileo is not detected.
                                LarsR

                                Don't apologize for language. I'm sure we understand you just fine.

                                 

                                The serial console is the black "audio"-like connector right next to the USB headers.

                                 

                                I just had some parts that I threw together. I just cut the cord on an old pair of computer headphones and soldered them to pins 2,3 and 5. If you don't get anything on a serial console (I prefer PuTTY), try swaping pins 2 & 3.

                                Just make sure you get pin 5 right or damage might ensue.

                                You can always try a search here or google "serial db9". I think we really need to see the console output, especially if the Galileo barfs when you make the USB connection.

                                 

                                If any of the gurus want to pitch in, I'm running out of ideas .. ..

                                 

                                I'm not saying your Galileo is damaged, but they do have the text "no usb before powering up" in big red letters on the getting started manual, so...

                                • 13. Re: Intel Galileo is not detected.
                                  SpiderKenny

                                  Uninstall the existing driver - to do that:

                                  1. disconnect all usb cables, except galileo

                                  2. right-click on the yellow triangles and select 'unistall'

                                  3. pull out the usb cable while it is un-installing

                                  Then try manual installation again.

                                  • 14. Re: Intel Galileo is not detected.
                                    Intel_Jesus

                                    Hi mike_one,

                                     

                                    Your computer is detecting Galileo. It appears as the driver is not correctly installed. Are you still experiencing this, after the steps that SpiderKenny suggested?

                                     

                                    Regards,

                                    Intel_Jesus