1 2 Previous Next 27 Replies Latest reply on Jun 26, 2014 6:54 AM by OllieB

    Remote boots one NUC, and not another

    bogchop

      Hi there

       

      I'm having a really strange issue with my xbox 360 media remote. It can boot my dn2820 nuc, but NOT my d34010 i3 nuc. The remote DOES work when the OS has loaded, openelec in this case, for both units.

       

      I've tried a different rc6 compatible remote, a Microsoft MCE knockoff and it works fine for both when booting/operating.

       

      Both NUCs running their latest bioses. I've tried resetting bios to default, no change. Tried disabling s4/s5, no difference.

       

      Why is it that one nuc can boot using this x360 remote, yet the other cannot?

       

      Please help!!

        • 1. Re: Remote boots one NUC, and not another
          allan_intel

          Thanks for coming back to the community.

          I understand you are using OpenELEC and booting the computer remotely.

          Please bear in mind, the operating system you are currently using has not been validated for your NUC model.

          You can try any of the Linux support groups to see if there are any drivers available that will provide you with the functions you require.

          http://www.linux.com/community

          Allan.

          • 2. Re: Remote boots one NUC, and not another
            bogchop

            Hi Allan,

             

            Why does OpenELEC have *anything* to do with booting up the unit remotely from a COLD/off state? The keypress on the remote is between the IR receiver, and the remote itself, which has nothing to do with OpenELEC at that point (it's not even on!)

             

            Why is there a difference between booting 2 NUCs that supposedly have the same IR reciever?

             

            Drivers wont help in this situation, because they're are Operating System level. This obviously is NOT something I can resolve on my own by installing drivers.

             

            Thanks,

            bc.


            • 3. Re: Remote boots one NUC, and not another
              bogchop

              Update:

               

              I tried installing Windows 7 and the IR driver as another post here suggested, and the unit began to boot from cold! I deleted Windows, installed OpenELEC and it continued to work without issue.

               

              However, once I changed a bios setting (I disabled S4/S5 Wake on LAN), the unit NO LONGER boots with the remote. NOR will it now boot from the generic MCE remote.

               

              This is RUBBISH! Surely this is a BIOS issue and must be fixed. It is ruining the experience, and I cannot recommend friends buy this unit if the CIR is so volatile (or BIOS issues, whatever it may be).

              • 4. Re: Remote boots one NUC, and not another
                allan_intel

                Thanks for coming back to our community.

                Yesterday, I tested NUC model D54250WYK and the remote actually worked. I installed Windows 7 and Windows 8.1 and loaded IR drivers, went into the BIOS and disabled S4/S5, the remote worked properly.

                Did your remote work when you enabled S4/S5 back?

                If this is a BIOS issue, then our engineering department may be working to get this fix.

                 

                Allan.

                • 5. Re: Remote boots one NUC, and not another
                  bogchop

                  Hi Allan, the answer is no: neither remote worked from that point onward. The only fix was to actually reinstall Windows, and then reinstall openelec linux XBMC distribution.


                  Problem with this is, there is a linux shutdown/hibernate bug. The fix for this bug is to disable Wake on LAN, and this kills the IR functionality for booting from cold, so I'm stuck.


                  Here is my analysis:


                  Hardware Setup:

                  on i3 NUC (D34010WYK)

                  30GB intel mSATA drive

                  Generic MCE RC6 remote as per previous posts.

                  Xbox 360 Media Remote, as per previous posts.

                  Latest BIOS, BIOS defaults loaded.

                   

                  Existing scenario:

                  I am able to boot a DN2820 NUC from cold using either the MCE RC6 remote or Xbox 360 Media Remote without issue (either windows or linux, no matter). No shut down, no hibernate, no boot problems or issues whatsoever. Unit works completely fine.

                   

                  Current Scenario:

                  a) Both MCE RC6 + xbox 360 media remotes work under windows, can start up and shut down, but only once drivers have been installed and unit has been suspended/awoken by each remote. Under linux installation, units cannot power on the unit.

                   

                  b) Under linux, there seems to be a wake-on-lan bug that causes the unit to reboot spontaneously when the shutdown command (from either linux OS or remote key press) is used. Disabling the Wake-on-lan feature in the BIOS fixes this. It doesn’t matter if you have a LAN cable connected or not.

                   

                  Pre-conditions

                  BIOS was set to DEFAULT, with only change being video RAM set to 1GB.

                   

                  Steps

                  01. Installed Windows 7 Ultimate 64 bit.

                  02. Installed INF/CIR drivers, rebooted as per usual.

                  03. Tested MCE RC6 Remote in system - worked as expected.

                  04. Tested Xbox 360 Media Remote in system (required registry tweak, but fine otherwise) - worked as expected

                  05. Was able to send NUC into hibernation with MCE RC6 remote. I woke up the NUC with the keyboard/mouse shortly after.

                  06. I shutdown the system using shutdown option in start menu.

                  07. I was then able to boot the NUC from cold state using the MCE RC6 remote, worked great.

                  08. I then shutdown the NUC from the start menu, but was not able to boot with Xbox 360 MCE remote.

                  09. I then booted the NUC using the keyboard, and sent the NUC into hibernation using the Xbox 360 Media Remote

                  10. I woke the unit from hibernation using the Xbox 360 Media Remote.

                  11. I then shutdown the unit from the start menu.

                  12. I was then able to boot the NUC from cold state using the Xbox 360 Media Remote. Strangely the remote now works?

                  ---

                  13. Install OpenELEC XBMC distribution (most current beta version).

                  14. Configure IR module for usage, both remotes work in OpenELEC system fine.

                  15. Both remotes can power down the NUC no issue, but it reboots the NUC using both remotes

                  16. Now both remotes will NOT power the NUC from a cold state (once turned off manually by power button). REMOTES DO NOT WORK AT THIS POINT FOR POWER-ON FUNCTION.

                  ----

                  17. Powering down the NUC with the keyboard also automatically reboots the unit at this point.

                  18. I’ve searched the forums, and it has been suggested that this is a linux shutdown/suspend problem due to the reboots, so recommendation is to turn off the “Wake on LAN” feature. (http://forum.xbmc.org/showthread.php?tid=176718 first post, last bit of advice).

                  19. Changed the “WAKE ON LAN FROM S4/S5” Option from “POWER ON-NORMAL BOOT” to “STAY OFF”.

                  20. Tested power down using remotes/keyboard - unit no longer reboots on shutdown from either remote or keyboard.

                  21. NUC still doesn’t boot from cold using MCE RC6/Xbox 360 Media Remote.

                  22. Tried a combination of enable DEEP S4/S5 + disable WOL; disable DEEP S4/S5 + enable WOL; disable DEEP S4/S5 + disable WOL. Unit still not booting, or automatically rebooting upon system shutdown/hibernate. This is a common issue, as described in the above forum link for this unit).

                  23. Reset the NUC bios to defaults, reinstalled Windows 7 + drivers and remotes work again.

                  24. Reinstalled linux, issue of remotes has returned.

                   

                  Outcome:

                  Remotes work under Windows using CIR drivers (after installation), and can boot NUC from cold state using both remotes.

                   

                  Remotes do not work under linux / OpenELEC once installed/rebooted, and linux suffers from suspend/shutdown/hibernation issue, causing unit to reboot.

                  • 6. Re: Remote boots one NUC, and not another
                    allan_intel

                    Thanks for sharing your results.

                    In this case, if the remote is working under Windows environment, this is a driver or compatibility problem for Linux.

                    Also you can try any of the Linux support groups to see if there are any drivers available that will provide you with the functions you require

                     

                    http://www.linux.com/community

                    • 7. Re: Remote boots one NUC, and not another
                      bogchop

                      ALAN if don't think you understand the issue. This is NOT  an operating system issue.

                       

                      I Have 2 nucs. One of them boots FROM A COLD STATE fine with two different remotes, regardless of operating system. Window and Linux. That is my dn2820 Nuc.

                       

                      The other nuc, d34010wyk nuc doesn't always boot with both of my remotes.

                       

                      wwhy is that possible? We're booing from an OFF state, nothing to do with an operating system here.

                      • 8. Re: Remote boots one NUC, and not another
                        Larryadd

                        Hi there,

                         

                        I'm posting here because I have the exact same experience as bogchop.

                        I only have Xbox 360 remotes, but anyway, the result is the same.

                        I have a d34010wyk.

                        I tried with bios 0.24 and 0.25. same issue, does not work after openelec install and loaded drivers.

                        The strange thing is on the openelec forum, some nucs seems to work. This is very strange.

                        I'm dealing with it for days now and I cannot find a clue but it's the CIR witch is not responding after an openelec shutdown.

                        If someone at Intel can manage this by a bios update, it will be realy appreciated.

                        • 9. Re: Remote boots one NUC, and not another
                          Larryadd

                          A little update,

                           

                          The wake up from cold state stop working after I enable the driver (after running modprobe -r nuvoton-cir && echo "auto" | tee /sys/bus/acpi/devices/NTN0530\:00/physical_node/resources && modprobe nuvoton-cir).

                          If I do not run these command lines, well, the remote does not work in xbmc but I still can power on the nuc after a shutdown of xbmc with the keyboard.

                          It seems that when I apply this change in the config, it sends something to the device that do not allow it to wake up with remote from cold state (or from suspend by the way...)

                          • 10. Re: Remote boots one NUC, and not another
                            tp

                            Allen, are you trying to fool us? This issue is not OS related!!! How often we need to explain...? Even with al lot of testing and workarounds, there is only a lucky hit...

                            • 11. Re: Remote boots one NUC, and not another
                              allan_intel

                              @tp, Not at all, I just mentioned operating system compatibility. Let's hope new BIOS releases will provide with all functions you require on this NUC model.

                              I do not have an estimate time for new BIOS for your NUC model. If there are new releases, I am sure they are going to be posted at downloadcenter.intel.com

                               

                              Allan.

                              • 12. Re: Remote boots one NUC, and not another
                                OllieB

                                @bogchop,

                                 

                                Did you perhaps already test the new draft firmware version (Re: NUC Haswell reboots after shutdown, post 119) to see whether that (installing + disabling S4/S5) also fixes the Xbox 360 Media remote problem?

                                • 13. Re: Remote boots one NUC, and not another
                                  bogchop

                                  OllieB

                                   

                                  Hey - thanks for the heads up. I've definitely not tried this, did not know it existed. Might give it a go within the next few days once I get a bit of free time.

                                   

                                  Thanks again!

                                   

                                  cheers,

                                  bc.

                                  • 14. Re: Remote boots one NUC, and not another
                                    bogchop

                                    I found this, in regards to OpenELEC issues:

                                     

                                    https://patchwork.linuxtv.org/patch/22339/

                                     

                                    Essentially the CIR does not seem to be enabled at boot time, which might explain why this isn't working once you install OpenELEC. Upon installing Windows and using the drivers to 'enable' the CIR, it works - albeit temporarily. Once you touch the BIOS in any particular fashion after installing a non-windows system, the CIR seemingly becomes 'disabled' on boot time, and thus doesn't work.

                                     

                                    Just a though.

                                    1 2 Previous Next