2 Replies Latest reply on Apr 9, 2014 2:26 PM by Intel_Jesus

    Serial settings

    gbaman

      So I have just finished putting together a serial cable for my Galileo (using an RS232 to usb and a soldered 3.5mm cable).

      I have hooked it all up to my windows laptop and run putty.

      I have set it up as can be seen in the pictures below, but it seems to ignore keyboard input except sometimes observing enter key presses.

      Am I doing something wrong here?

      1.png2.png3.png

      I am getting some weird stuff on the terminal as it seems to write over itself?

       

      Suggestions?

        • 1. Re: Serial settings
          grapaZ

          I've had the same experience:

          1. I spent a day or so unable to understand why I was seeing good output from Galileo but none of my attempts at input having any effect. Things worked as I expected when I used a hard-wired cable with an old Wyse 50 terminal. When I hooked up a serial-to-USB cable (almost as old), output came through but input failed to show. Eventually I tried connecting to the Wyse terminal with putty via USB and discovered that the USB was working only on output... no input. So try talking to something other than the Galileo to test your cable and driver. The driver turned out to be my problem.

           

          2. <I am getting some weird stuff on the terminal as it seems to write over itself?>

          You are looking at console output, which will overwrite the terminal dialog ("Logon:", etc) with information generated by the kernel.


          • 2. Re: Serial settings
            Intel_Jesus

            Hi gbaman,

             

            The only difference in my settings from yours is my Flow control under Serial. “XON/XOFF” is selected. This value must be the default because I don’t recall changing it. If your still experiencing issues with your cable. I would suggest purchasing a USB to RS232 and RS232 to 3.5mm jack or try building a second cable. Take a look at this post for additional information: https://communities.intel.com/message/208514#208514

             

            Regards,

            Intel_Jesus