3 Replies Latest reply on Apr 2, 2014 7:30 AM by allan_intel

    SM Bus controller, drivers not installed or SM Bus controller not connected?

    TomdeBoer

      Hey everybody

       

      I would like to hear your opinion about this if anyone could help me.

      I already tried installing drivers, please read my entire post.

       

      -SM Bus controller. The drivers for this device are not installed. (Code 28)

      -Unable to turnOff touchpad (touchpad itself works but cannot turn it of)

       

      Operating system+Hardware+ Drivers

      -Windows 7 Professional, Service Pack 1

      -64 Bit

      -DELL Latitude 3540

      -Chip Type: Intel® HD Graphics family

       

       

      Problem

      Problem with Laptop from my job:

      Unable to turn touchpad off.

      -press Fn + F3 doesnt work

      -Cannot find the touchpad in my controlPanel->hardware and devices, so manually turning of does also not work.

      -Rest appears to be working Fine!

       

      Problem Since

      Problem occured since:

      Laptop was upgraded by my boss with following actions

      -Harddisk was replaced by flashMemory (laptop has been opened up thus..)

      -Disk was encrypted with DiskCryptor and operating system + all drivers reinstalled.

       

      Actions I took

      Upgrading chipset drivers from Intell

      -Tried it automaticly over Windows 7 controlPanel-> devices->update drivers.

      Result: cannot find driver.

      -Than tried it manually http://www.dell.com/support/home/us/en/19/product-support/servicetag/8C82RZ1/drivers?s=BSD

      ->Change operating system to windows 7 64 BIT

      ->Under chipset.

      -> Manually updated driver: Chipset_Driver_Intel_USB3_A01_W732W764-SETUP_ZPE

      Of course restarted the computer.

      After this nothing really changed.

       

      Control Panel is Still saying:

      The drivers for this device are not installed. (Code 28)

      There is no driver selected for the device information set or element.

      To find a driver for this device, click Update Driver.

      Also:

      SM BUS controller:

      Device type: Other devices

      Manufactere: Unknown

      Location: PCI bus 0, device 31, function 3

       

      What do you think is the Problem?

      I am no computer genius, but is it possible that the problem is not the BUS driver?

      Maybe a cable to the BUS controller is not connected or something?

      Isnt it weird that all the other Fn+F1,2,4,5,8,9 things like turning on/off wifi, volume are all working?

      Should I rather try installing all drivers from start? Or ask my boss to open up the laptop.

      Please let me hear your opinion or redirect me to another Forum

       

      Kind regards

      Tom de Boer