1 2 Previous Next 22 Replies Latest reply on Jan 3, 2015 6:10 AM by archn

    D54250WYK, bios, and F2, again

    archn


      The bios in my D54250WYK is version 0025.  I am using the ASUS MB168B+ monitor.

      The only connection to this monitor is USB 3.0 which makes it ideal for the NUC.

      The monitor works correctly; however, I cannot enter the BIOS with F2.

       

      I realize that F2 is an old problem, but I thought it might be helpful to report

      a non-HDMI case.

        • 1. Re: D54250WYK, bios, and F2, again
          sylvia_intel

          Hello Archn, thanks for sharing the information with us. We have seen this behavior and usually it comes down to the type of HDMI monitor you're connected to.

          Are you using dual display?

           

          Could you please test the NUC using only the monitor?  Do not connect any adapter or any other video device please.

           

          Are you able to access the BIOS on maintenance mode, moving the BIOS jumper to position 2 and 3?

           

          We have seen this on monitors that do not support a resolution of 1024x768. If the monitor does not have that resolution you won’t be able to access the BIOS or have video.

           

          Please check this article  

          http://www.intel.com/support/motherboards/desktop/sb/CS-034637.htm    

          • 2. Re: D54250WYK, bios, and F2, again
            archn

            The monitor is an Asus MB168B+. It does not connect through HDMI.  It has just one connection: USB 3.0.  It gets both power and video through this connection. HDMI plays no role.

             

            As long as I do not attempt to open the bios with F2 things work correctly.  When I press F2 during post everything blocks. Then I shutdown with the power button.

             

            My reason for my original post was to give Intel's BIOS engineers an additional data point, a non-HDMI one.

            I do not expect F2 to work with the current (0025) BIOS firmware; I am waiting for an upgrade.  Or, maybe, Intel could give us access to a old fashioned BIOS .

             

            Finally, the MB168B+ can be set manually to 1024x768, but F2 still does not work.  I have access to a different monitor, and F2 works with it so my NUC is ok.

            • 3. Re: D54250WYK, bios, and F2, again
              sylvia_intel

              Archn, thanks for the information. You said that you have tested a different monitor with this product and it worked fine.  What kind of output did you used? DVI or HDMI?

              Can you try rolling back to a previous BIOS version such as v022?

              • 4. Re: D54250WYK, bios, and F2, again
                archn

                The other monitor is an IIyama ProLite E2273HDS, and it is connected through HDMI.

                 

                Until a week or so ago I was running version 0023 BIOS firmware, and I had exactly the same behavior for each monitor.

                • 5. Re: D54250WYK, bios, and F2, again
                  archn

                  When I say "exactly the same behavior for each monitor" in the previous post  I mean that the MB168B+ did not work with F2 and the IIyama ProLite E2273HDS did work with F2.

                  • 6. Re: D54250WYK, bios, and F2, again
                    sylvia_intel

                    Archn, would you please try the following graphic driver? I think it is the same version you have, but this file comes directly from the graphic page.

                     

                    https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=3721&DwnldID=23714&ProductFamily=Graphics&ProductLine=Laptop+graphics+drivers&ProductProduct=4th+Generation+Intel%C2%AE+Core%E2%84%A2+Processors+with+Intel%C2%AE+HD+Graphics+5000&DownloadType=Drivers&lang=eng

                     

                    I would recommend you to uninstall your current graphics driver, restart the system and then install this version.

                    Please let me know the results.

                    • 7. Re: D54250WYK, bios, and F2, again
                      archn

                      I did half of what you suggested.  I wasn't sure what I should uninstall. In the Device Manager I looked at the driver for the monitor, but it did not have a similar id.  So I just executed the above download.  It installed without complaining that there was already the same driver installed.

                       

                      Nothing has changed.  If I do not push F2, the NUC starts correctly.  If I push F2, the NUC blocks, and I have to stop it with the power button.

                       

                      If you tell me exactly how and what to uninstall, I will try again.  However, I doubt that I have a corrupted driver, but who knows.

                      • 8. Re: D54250WYK, bios, and F2, again
                        archn

                        Here is a bit more data.

                         

                        When I boot with the HDMI (see above) monitor without pressing F2 I see the "Intel Nuc" logo and a notice that Windows is starting, and then it starts.  This is presumably "normal" behavior.

                         

                        When I boot with the USB 3.0 monitor (see above) without pressing F2 I see neither the "Intel Nuc" logo nor a notice that Windows is starting.  Windows just suddenly starts after a bit of a delay.

                        • 9. Re: D54250WYK, bios, and F2, again
                          AlexanderR

                          I had sort of the same problem in a different way.

                           

                          When using minihdmi cable to my surround reciver i get the nuc logo and the startup windows 8.1 swirl.

                          When using minidp adapter to hdmi the screen is black until windows starts.No logo and no boot options.

                           

                          The only way i was able to get into the bios with the miniDP adapter was to hold the power button for 3 or 5 seconds when powering on. Then i got the boot screen with options.

                          • 10. Re: D54250WYK, bios, and F2, again
                            archn

                            Thank you for the feedback AlexanderR.

                             

                            I tried it and here are the results.

                             

                            Case 1: with MB168Bplus monitor. The problem.

                                          a: with NUC off (in S5)

                                          b: I press and hold down the power button and hear 3 beeps.

                                          c: A second or two after the 3 beeps I release the power button.

                                          d: Asus logo appears on the screen.

                                          e: An Asus z Z picture appears briefly.

                                          f. Power button light goes out.

                                          g: As far as I can tell the NUC is back in S5.

                             

                            Case2: with HDMI monitor.

                                          a: I repeat the above.

                                          b: It is a bit touchy, but I am eventually asked if I want to go in the BIOS.

                                          c: I enter the BIOS and all is normal.

                             

                            The bottom line, I think, is that the BIOS firmware 0025 cannot handle a purely USB 3.0 monitor, and we will just have to wait for an upgrade.  Soon, I hope.

                            • 11. Re: D54250WYK, bios, and F2, again
                              byrdchem

                              I was having this exact problem, and it was driving me nuts.  It was clearly not a connection issue (I tried all possible cable to monitor connections.)  I was not able to boot into maintenance mode by changing the BIOS jumper to pins 2 and 3  (According to March, 2014 Technical Specs, pins 2 and 3 puts it into "Lockdown Mode" with all POST hotkeys like F2 disabled.)  The solution for me was to press down and hold the power button until the third beep, then release, then press F2 repeatedly until the BIOS screen finally appears.  I discovered that when I previously had updated the BIOS to 0024, I had checked the "Fast Boot" option, which bypasses everything, disables USB until after boot to the OS.  I am going to leave Fast Boot unchecked.  All is well now.

                               

                              L. Byrd

                              1 of 1 people found this helpful
                              • 12. Re: D54250WYK, bios, and F2, again
                                archn


                                Thank you byrdchem.

                                 

                                It did not work for me, but I did get a different behavior.

                                 

                                After the 3 beeps I pressed F2 repeatedly. I did not get into the BIOS, but the blue power light stayed on. I could not wake it up, and eventually, just to be doing something, I pressed Ctrl Alt Del, and after a delay Windows booted.

                                 

                                Intel is just going to have to fix the firmware.

                                • 13. Re: D54250WYK, bios, and F2, again
                                  lhill

                                  Hi archn,

                                   

                                  I just got word back from engineering about the issue where you cannot access BIOS if the NUC is connected only to a USB display: "During BIOS POST, vBIOS/GOP will only output to onboard HDMI or DisplayPort output. The USB monitor requires its specific OS driver to function properly in an OS environment as primary or secondary monitor." So, it appears this this behavior is by design.

                                   

                                  Regards,

                                  Lois H.

                                  Intel

                                  • 14. Re: D54250WYK, bios, and F2, again
                                    archn

                                    Hello Lois,

                                    Are you saying that it is impossible, because of hardware limitations of NUCs, to write BIOS firmware that will work correctly with a USB 3.0 display?

                                    Regards,

                                    Archn

                                    1 2 Previous Next