1 2 Previous Next 21 Replies Latest reply on May 30, 2014 1:06 PM by sylvia_intel

    DN2820FYKH doesn't like SSDs

    dennisdn2820fykh

      Hi,

       

      My Intel NUC DN2820FYKH doesn't seem to like SSD's. First the background:

       

      Memory Used: 4GB DDR3L-1600 Kingston p/n KVR16LS11/4

      SSD 1: Crucial M500 120GB (CT120M500SSD1) doesn't work (see below)

      SSD 2: Samsung 840 EVO doesn't work either, same symptoms

      SSD 3: Samsung 830 - same symptoms

      Firmware tested on Intel NUC: 0015, 0021, 0025 and 0028.

      Firmware SSDs have been updated to latest versions from supplier

       

      The symptoms:

      - Crucial M500 120GB (CT120M500SSD1) doesn't work (see below)

      - Samsung 840 EVO doesn't work either, same symptoms

      - Samsung 830 doesn't work, same symptoms

      - Seagate Momentus XT 500GB HDD 2,5" SATA (hybrid) does work.

       

      What doesn't work:

      Windows 8.1 doesn't want to install (UEFI, GPT disk, Intel's recommended BIOS-settings applied), but is giving errors in installation destination screen (0x80300002). Diskpart is giving strange errors (unable to perform 'clean' and 'convert gpt' for instance, throwing an I/O error). Both SSDs also sometimes suddenly disappear from the disklist (diskpart | list disk). A powercycle brings them back. BIOS mode doesn't work either.

       

      Diskpart does work though with the same disks in my other (desktop) Windows 8.1 machine. Those disks work fully on that Machine (install Windows 8.1 from same USB-stick used in NUC), cloning, cleaning etc...

       

      After creating the partitions manually (following these instructions: Sample: Configure UEFI/GPT-Based Hard Drive Partitions by Using Windows PE and DiskPart, recommended configuration) other strange things start to happen: Windows installer won't load properly anymore and hangs in the screen telling me setup is being started.

       

      Strange thing is that the 'old' Seagate Momentus (normal HDD) doesn't give the same problems: Windows can be installed (in UEFI/GPT mode) and seems to work.... Installed from the same USB-stick (other sticks tested as well) so the USB-stick isn't to blame..

      I've spent now over 4 nights trying to get this to work, including two long drives to a store to replace the SSDs. Unfortunately without any satisfying results. Since this problem doesn't occur on my other PC, my guess is that this is a Intel NUC firmware related problem (UEFI/GPT related)

       

      My question is: What can I do to solve this problem, or do I need to wait for a firmware update from Intel? Any ideas are welcome!

       

      Kind regards,

       

      Dennis.

       

      Message was edited by author

      April, 7: updated with newly tested hardware (Samsung 830 SSD)

        • 1. Re: DN2820FYKH doesn't like SSDs
          KevinI

          I have the same issue with my DN2820FYKH with an Intel 530 SSD. The SSD disappears after a few writes, once it gets into this state and only a power cycle will bring it back.

           

          Going back to FY0021 BIOS works fine for now as a workaround.

           

          I've opened a case with Intel support and they sent me FY0030 which still has the same issue. They have escalated it to the development team and are working it. It does not seem like a HW issue since others are having it too.

          1 of 1 people found this helpful
          • 2. Re: DN2820FYKH doesn't like SSDs
            dennisdn2820fykh

            Thanks Kevinl for this feedback. I've tried 0021 a few minutes ago, but it gives me the same errors as 0025 and 0028, both during installing and using diskpart. Very frustrating... :-(

            • 3. Re: DN2820FYKH doesn't like SSDs
              dennisdn2820fykh

              I've updated the original post with new test information (using another SSD and new test results)

              • 4. Re: DN2820FYKH doesn't like SSDs
                LesMoss

                Have you tried installing 8.1 on the old Seagate HDD and then cloning that to the SSD?

                • 5. Re: DN2820FYKH doesn't like SSDs
                  visiter555

                  I have the same Kingston ram and a Samsung 840 EVO SSD as well as an Intel 530 120 GB SSD.  Both SSDs work perfectly and I did a clean install of Windows 7 then Windows 8 then upgraded to Windows 8.1 on both drives (I have two 2820's).

                   

                  No problems at all.  Did you follow the original config instructions online on how to set the Bios to get things setup for the original install?  I Started by (at the time) upgrading the Bios to 025 on the first NUC and did the second one at Bios rev 028, then changings the BIOS settings as per Intel's directions.

                   

                  I have also tried a Kingston V300 120 GB with no problems.  I am thinking it is either the BIOS settings or a defective unit?  I did one via a USB Windows install and the other via a DVD install booting from the DVD.

                   

                  I could certainly use another of the 2820s....or I will wait till the 2830s are released later this month.

                  1 of 1 people found this helpful
                  • 6. Re: DN2820FYKH doesn't like SSDs
                    KevinI

                    For me I could not even install Windows 8.1 as a clean install with FY0025 & FY0028. As soon as I tried to create the partition using the installer UI or Diskpart the 530 SSD it would disappear. It would not return until I power cycled.

                     

                    I've tried every BIOS setting I can think of with no effect, of course I could be missing something. The weird thing is FY0021 works perfectly.

                     

                    After installing Windows using FY0021 when I try and go back up to FY0028 windows works for about 5 minutes and then freezes and blue screens.

                     

                    The only last piece I have not tried is the BIOS recovery using the jumper, I'll try that tonight.

                     

                    That is interesting that yours works fine, If my unit is faulty that's fine, I just need it replaced, Intel support are working it, until then I stay on FY0021. It might be a stepping issue.

                    • 7. Re: DN2820FYKH doesn't like SSDs
                      Bill.A

                      I had similar - but not exactly the same - issues with my DN2820FYKH when I tried installing Win7 64bit. Drives disappearing, Windows install freezing 1/2 way through, etc. I even purchased a new HDD & RAM from the compatibility list and had the same result.

                       

                      The solution to my problems was a replacement NUC - the new unit installed Win7 fine using all the exact same components.

                       

                      You may have a defective unit...

                      • 8. Re: DN2820FYKH doesn't like SSDs
                        dennisdn2820fykh

                        @LesMoss (regarding cloning from HDD to SSD): Nope, that might be a good idea. Any ideas on what tool I can use best to clone a 500GB GPT HDD to a 111GB SDD?

                         

                        @visiter555 (regarding BIOS settings): yes I've set everything according to instructions that can be found when downloading the BIOS firmware..

                         

                        @KevinI (regarding 0021 working and BIOS recovery option): 0021 doesn't work for me, gives the same errors. Same goes for 0015, 0025 and 0028. I'll try the BIOS recovery option too and let you know what the results are..

                        • 9. Re: DN2820FYKH doesn't like SSDs
                          visiter555

                          Sounds more & more like a defective unit and I would be on the vendor & Intel's case about a replacement.

                           

                          I actually took a 2.5" laptop drive (Samsung 60 GB) out of an old (circa 2005) laptop that died and used it and did a clean Windows 8 Pro 64 bit install on the DN2820 last night with 028 BIOS and it went absolutely fine.  Installed XBMC on it and it was still running this morning.

                           

                          Possibly there is more to the discontinuance of the 2820?

                          • 10. Re: DN2820FYKH doesn't like SSDs
                            sylvia_intel

                            Dennis, I’m sorry to hear that you are having issues with the installation of the HDD and your NUC.

                             

                            It seems like you already tried the suggestions given by other users and you are still having issues, I recommend you to get in touch with our Warranty Department so they can help you: 

                            http://www.intel.com/p/en_US/support/contactsupport

                            • 11. Re: DN2820FYKH doesn't like SSDs
                              dennisdn2820fykh

                              Thanks visiter555 & Sylvia_intel, This afternoon (after unsuccesfully trying to install Windows 8.0 64-bit to an SSD, in which the installer didnt want to start at all (black screen)), I've decided to return this unit to the shop where I've bought it. They are sending it in for repair / replacement.

                               

                              I hope to receive a good working device in the next couple of weeks. When I have an update, I'll let you know via this thread.

                               

                              Thanks for all the advice here, this is a very valuable forum!

                              • 12. Re: DN2820FYKH doesn't like SSDs
                                ASadani

                                For the NUC I would prefer to buy from fry's or a retailer where you can switch out the unit when you are confused. I had the NUC with Network dropouts and nothing seemed to fix it except replacing the unit. After few months I upgraded my NUC to the new i5 with IR. This time the IR was choppy. It would work but not fluidly. Key strokes would get stuck etc. I tried different driver combinations but that didn't fix the problem as well. I got a new one in Fry's and returned the defective one to NewEgg. It gets me to believe the QA process on the NUC's is choppy. You may very well land up with a unit that is a little questionable. Lots of others had the network issue with the earlier i3 version of the nuc when hard wired and when the nearest HDMI is in use.

                                • 13. Re: DN2820FYKH doesn't like SSDs
                                  KenColey

                                  Has anyone resolved this?  I have two units out of the same batch.  One works just fine, the other has the symptoms described above.

                                  • 14. Re: DN2820FYKH doesn't like SSDs
                                    alain31

                                    Same problem with my NUC 2820 and two SSD's Intel 530 120Go, SSD disappear or pc freeze after a few seconds. Bios and firmware are up to date and an older Intel SSD 80Go works fine....

                                     

                                    Edit: i had not seen that there is a new bios (032), mine is 028, i'll try the new one tonight

                                     

                                    Edit 2: with bios 032, no more issues !!!!!

                                    1 2 Previous Next