2 Replies Latest reply on Mar 13, 2015 9:00 AM by neomash

    D34010WYKH Only Boots from USB when Using F10 Option

    BrentKe

      Just purchased my first NUC and so far, quite impressed.  Nicely executed, Intel!

       

      The only issue I have found is that to boot off of a USB thumb drive, I can only do it by using the F10 boot menu - selecting the USB drive and then works like a charm.  I have tried so many combinations in the BIOS, changing boot order, turning legacy support on/off, boot usb first, turn off network boot, etc etc.  I have also tried USB ports on the front and rear of the unit


      When the power is turned on, I get the NUC splash screen and the function key menu (F2, F7, F10, etc).  However, unless I use the F10 option, the screen will display a "no bootable device found..." error message.  If I select F10, it shows the two drives installed (Samsung SSD and the Sandisk thumb drive).  I select the thumb drive and life is good.  Boots perfectly.

       

      My Intent is to make this a headless server booting from the USB thumb drive.  So I really cannot have a monitor/keyborad plugged in every time it reboots.  Here is the current config:

       

      NUC Model: D34010WYKH

      BIOS Version: 0025 (this is the latest as of 03/23/2014)

      Memory: 16Gb - Kingston HyperX KHX16LS9P1K2/16

      SATA Disk: Samsung SSD 840 EVO-Series 500GB (data drive only - no operating system)

      USB Thumb Drive: SanDisk Cruzer Fit 16 GB USB Flash Drive SDCZ33-016G-B35 (boot drive) (USB 2.0)


      Note that all devices show up as expected in the BIOS - even the Sandisk thumb drive.  The BIOS accepts all my changes and saves them as I would expect.  So the BIOS user interface seems to work as expected.


      Again, using F10 and manually selecting the thumb drive - the system boots perfectly.  All devices (including the SSD) show up just fine even from the OS I boot into.


      Any help would be appreciated.


       


        • 1. Re: D34010WYKH Only Boots from USB when Using F10 Option
          BrentKe

          Just so happens I did some more research this evening and this is not a NUC defect at all.

           

          The OS I am running is vSphere 5.5 and I found a couple of people that make reference to the partition type ESXi 5.x creates by default.  Apparently, it defaults to GUID Partition Table (GPT) partitions which doesn't seem to be very friendly to USB thumb drives and "legacy" mode in the BIOS when attempting to boot.  I learned we can force vSphere to use the traditional master boot record (MBR) at the time of installation.  If you enter the boot option prompt, enter a parm called "formatwithmbr" which tells the ESXi installer to use MBR instead of GPT.

           

          Tested several times and works great - problem solved!

           

          I won't go into a lot of detail as you can search for existing articles that spell it out step by step.  Use a query similar to "vsphere usb formatwithmbr".  That should get you down the right path.

           

          The NUC is well on its way as a low power server for a small test env.  As originally stated, I am very pleased thus far.

           

          Hope this helps someone else.

          • 2. Re: D34010WYKH Only Boots from USB when Using F10 Option
            neomash

            Brent,

            You're awesome, thx for posting this. Been searching in the wrong direction, until I found you're post.