2 Replies Latest reply on Mar 20, 2014 7:18 PM by spinlock

    i7-4960x rdrand instruction fails

    spinlock


      I found documentation that states rdrand is supported on this processor, but the following routine fails continuously with RAX  and CF being zeroed.

       

      top:

           rdrand rax

           jnc top

           ret

       

      If it wasn't supported I would think I would get an Invalid Instruction exception and/or it wouldn't zap RAX.

       

      I went all through the BIOS, only function that could be disabled was Virtualizatoin(which is enabled).

       

      Is something needed to enable rdrand?

       

      thanks,

        • 1. Re: i7-4960x rdrand instruction fails
          allan_intel

          Thanks for joining the community.

          If you are software developer, I would highly recommend you engage the software developer forum for issues with rdrand. There is a lot of expertise in the community for working with issues like you are experiencing.

          http://software.intel.com/en-us/tags/20757

           

          Allan.

          • 2. Re: i7-4960x rdrand instruction fails
            spinlock

            I ran the CPUID command and bit 30 was OFF, so, I guess they disabled this function on Extreme Edition processors.

             

            I tried it on a Haswell i7-4770K and it worked fine.

             

            EDIT: Oops, I was looking at wrong register, when setting EAX=1, then issuing CPUID, ECX was returned as x7FBEE3BF on the i7-4960x and bit 30 is on. This means that the i7-4960x DOES support rdrand and there is no explanation for it failing to return a hardware generated random number.

             

            I will try the software forums as suggested.