2 Replies Latest reply on Mar 17, 2014 1:37 PM by sylvia_intel

    lost 1080p after upgrading bios DN2820FYKH

    bh1

      I am running debian-7.4.0 . I first installed debian from a usb install image with full 1080p support dueing hte installation process but then I  found I had to upgrade the bios to get past the f2 bios issue so that I could enable legacy BIOS support and then upgrade again to get past the debian boot issue.

       

      I first installed GK0042.BIO to get access to the BIOS. I had to do this with no screen.

      Then I installed FY0025.BIO to get debian to boot off the HDD.

       

      Now I can only get 1280x1024 resolution and the default 3d acceleration does not kick in either. I noticed that the resolution changed after I installed GK0042.BIO. 

       

      I can see that acceleration is supported in the driver with:

       

      glxinfo | grep rende

      direct rendering: Yes

      OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 0x209)

          GL_NV_conditional_render, GL_AMD_draw_buffers_blend,

        • 1. Re: lost 1080p after upgrading bios DN2820FYKH
          bh1

          I tried downgrading to FY0015.BIO  and FY0021.BIO but that didn't fix the resolution problem.

           

          So I upgraded back to FY0025.BIO and tried running in UEFI mode which was the default configuration for the original BIOS and suddenly I can see 1080p resolution again.

           

          The thing is I don't want to run UEFI mode. I am not particularly interested in having a rootkit with reverse ssh installed directly on my computer so that the NSA can monitor me if they feel like it.

           

          Is there any way to get 1080p resolution while using the Legacy BIOS? There shouldn't be a hardware limitation for the video card just because of the choice of BIOS. I have other devices that can run 1080p perfectly well with a so called legacy BIOS. It's not a limitation of any operating system that I know of so why has intel decided to cripple 1080p in this way?

           

          I'm sure there is no ulterior motive on behalf of Microsoft /NSA to force people to use UEFI on these devices so perhaps there is a simple BIOS flag that I am missing?

          • 2. Re: lost 1080p after upgrading bios DN2820FYKH
            sylvia_intel

            Bh1, it looks like there were some changes on the BIOS settings and the VBIOS, therefore this could be a hardware issue.

             

            Since the resolution appears after enabling UEFI, this is for sure a BIOS situation. My recommendation will be to replace the NUC and if the replacement works OK using the original BIOS, please do not upgrade it.

             

            Contact our Warranty department so they can help you replacing the board.

            http://www.intel.com/p/en_US/support/contactsupport