3 Replies Latest reply on Mar 14, 2014 12:00 PM by sylvia_intel

    NUC DN2820FYKH will not display after BIOS update

    Myles9999

      Prior to attempting to install Windows 8.1 (x64) on a new DN2820FYK NUC, and as per Intel's OS installation notes, I undertook a BIOS update via a flash drive containing the latest version available, FY0025.bio.  According to the screen display, the update appeared to go ok, but after restarting, there was no longer any display at all.

       

      I have tried the BIOS Recovery procedure (removing the jumper etc)  The power led does flash for a few minutes, as if it might be loading something, but then just goes steady-on until the unit is turned off. When re-started, the power light goes on but nothing is displayed, and pressing F2 etc does nothing.  I tried the CMOS clearing procedure also, and then BIOS recovery, but still no display.  I also reseated the 4gb 1.35v memory module just in case, even though it did not cause a problem when the NUC first booted up to the BIOS it shipped with.

       

      I have subsequently tried the NUC on 3 Panasonic TVs (all of which are XGA (1024x768) capable), a Samsung monitor (also 1024x768 capable), and an LG TV which may or may not be 1024x768 capable.  All connections have been by HDMI.  I have also tried 3 different HDMI cables, 2 of which at least are 1.4a, and are already used for carrying video and 5.1/7.1 audio from a Core i5 laptop, WD media player and 3D bluray player.  I have tried various combinations of cables and TVs, and repeating attempted boot-ups, BIOS recovery, etc.  No luck.  Apart the initial boot-up and BIOS display, the unit hasn't displayed a thing since the (uninterrupted!) BIOS update.

       

      All up, I have probably wasted about 8 hours so far, not to mention the hours reading forum posts from all over the place.  I realise now from the forums that these Haswell NUCs have more than their fair share of BIOS-related problems, but can anyone suggest any other procedures I can try to bring this thing back to life??

        • 1. Re: NUC DN2820FYKH will not display after BIOS update
          sylvia_intel

          Myles999, I am sorry to hear you are having problems with your new NUC, but I will be more than happy to assist you on this issue.

           

          I was reading your comment and it looks like you already performed all the recommended troubleshooting on this type of product. However I will like to know which BIOS version you are trying to install through a BIOS recovery?

          • 2. Re: NUC DN2820FYKH will not display after BIOS update
            Myles9999

            The latest BIOS I could find was FY0025.bio.  I downloaded it a couple of
            times onto different USB sticks after the initial failure, just in case there
            was a problem with the download or with one of the sticks.  No success. After repeating the
            recovery procedure a number of times on different display/cable combinations, I
            even tried recovering the previous version (0021) just in case that might at
            least display something and let me into the BIOS.  No luck on anything.

             

            I have now contacted Intel support center and have supplied some more info to them that they asked for.  All I can hope for now is that Intel will indicate that the unit appears to be faulty so that the retailer will agree to issue an RMA.

             

             

             

            • 3. Re: NUC DN2820FYKH will not display after BIOS update
              sylvia_intel

              Ok Myless9999, once you receive the replacement NUC, please stay on BIOS 0021 until we find a solution.