8 Replies Latest reply on Apr 3, 2014 3:58 AM by Ekimus

    Intel DP45SG posting error code B2

    Ekimus

      Evening,

       

      Have an Intel DP45SG (AA E27733-402) board that now refuses to POST past code B2. I can't get into the BIOS at all and restarting has no effect either warm or cold. BIOS recovery up or down has no effect nor does clearing the CMOS (jumper or pulling battery). I do get the first beep when switching on the machine which starts the posting sequence but not any further then B2.

       

      Posting code B2 is: Detecting presence of a fixed media (IDE hard drive detection etc.). My Google-fu failed to make sense of the post code, given there are no IDE connection on the board to begin with (and I didn't hook up the SATA optical or hard drives at this stage either), and others that had experienced a same code, removed the last piece of hardware to get their system work again.

       

      After the first BIOS recover I did get posting code BC (removable media) which when I removed the USB stick solved that issue but then went to B2 again and since then, even with subsequent BIOS changes.

       

      Recently the system was functioning fine on the latest and last BIOS (0125) with a C2 E8400, 4 x 2GB of compatible RAM (DDR3 v1.5 PC3-10600 1333MHz) with crossfire ATI 5850's and a Antec True power 650w PSU.

       

      I tried upgrading the CPU to a C2 Q9400 (SLB6B) and changing the PSU to a Corsair TX750 but the system refused to display anything. I also tried changing the case as well at the same time.

       

      I bread boarded the mobo and stripped everything down to just the new CPU + fan, RAM, 1x video and new PSU with no change to the booting or posting. Plugging in the old original PSU (Antec 650w), everything worked fine (and I should have stopped there it seemed).

       

      I tried Google-fu'ing the issue without success, as mentioned, with the exception of resetting the CMOS (both via the jumper and/or removing the battery) to reset the information held by the mobo. In hindsight, this was probably a mistake as now it's not working at all.

       

      The mobo will give the 3 beeps when there is no RAM installed and I tried each stick of RAM in each of the 4 slots without any change to the posting code. I have re-rest the CMOS (jumper and removing battery (from 5 mins to 24 hours without the PSU attached)) and down/upgraded the BIOS (via USB recovery) with no change in the outcomes.

       

      Each of the components work fine in other systems which make me think the mobo is no longer viable now for some unknown reason. I have tried several other components; C2 E6750, C2 E8500, both ATI 5850's and a Nvidia EN8500GT silent, a single stick to all 4 sticks of RAM (in various slots), an Antec 430w, the original Antec 650w and the new Corsair 750w PSU's with no change in out come at all.

       

      I tried re-connecting both a SATA optical and hard drive (singularly and then together), to see if that magically did anything as it was looking 'fixed media', as well as a USB stick with no change to the posting code unfortunately. Even unplugging the USB keyboard had no effect to the posting code.

       

      Currently installed is the Q9400 plus stock fan, 1 x 2GB stick of RAM, EN 8500GT, and the Antec 650w on BIOS 0083.

       

      I'm hoping someone on here with fresh eyes can't assist me with this as its driving me nuts! It was all working until I cleared the CMOS which shouldn't have caused any issues apart from losing settings.

       

      Thanks.

        • 1. Re: Intel DP45SG posting error code B2
          Nik

          Hi, sounds not good, probably you tried everything, it may be dead south bridge, damaged bios chip, you may try to replace bios chip (bios-repair.co.uk).

          Look at the electrolytic capacitors, there are no swollen?

          • 2. Re: Intel DP45SG posting error code B2
            Ekimus

            No leaky or buldging capacitors, and changing the CMOS battery has no effect. There is also no visable damage or strange smell to the board either.

             

            I did look at the link you provided but they dont do Intel board :/

            • 3. Re: Intel DP45SG posting error code B2
              sylvia_intel

              Ekimus, at this point, since you already performed all recommended troubleshooting; I just need to ask if you tried to access the BIOS on maintenance mode, moving the BIOS jumper to position 2 and 3.

              If you are able to access the BIOS screed, please run default settings (F9) and save the changes.

               

              Let me know the results.

              • 4. Re: Intel DP45SG posting error code B2
                Ekimus

                I have indeed tried accessing the BIOS in maintenance mode but have had no success. From memory it did not get through the POST screen and sat with B2 in the bottom right corner of the Intel splash screen. The same as if it was going through normal mode.

                 

                I tried to retest this again tonight, to confirm this was the case (and to make sure I had actually done it correctly), but now I cannot get the board to give the initial beep when turning on before it runs the POST.

                 

                I get the 3 beep when no RAM is installed still but I do not get anything else now when trying to fire up the board; no starting beep, no POST screen, no video life from any card in any PCI-e slots... nothing.

                 

                For an 'extreme desktop board' it seems to be only getting 'extremely worse' all of a sudden

                • 5. Re: Intel DP45SG posting error code B2
                  Ekimus

                  I have managed to get the board to post back to the original POST error B2, after leaving the CMOS battery out for over 24 hours, and have confirmed that I cannot get into the BIOS or maintenance mode screen at all.

                   

                  I did notice again this time around that the system gives the initial posting beep, then displays a | cursor, about 3 lines down and a Tab length across if the screen is on before Turing the system on, for about a second on the screen at the top left before it goes into the Intel POST screen and finally sits a B2 with no hint of moving.

                   

                  Given all that, as I've run out of other things to try, the board is now useless?

                  • 6. Re: Intel DP45SG posting error code B2
                    sylvia_intel

                    Ekimus, do you have any other video card that you can test on this motherboard?

                    • 7. Re: Intel DP45SG posting error code B2
                      Ekimus

                      Afternoon,

                       

                      Not sure how changing the video card would make any different to the POST error of B2 (Detecting presence of a fixed media (IDE hard drive detection etc.)) but have tested a number of video card brands and makers with no change to the issue or outcome.

                       

                      I have tested the following working cards:

                       

                      AMD/ATI

                      =======

                      Asus HD5850, Sapphire HD5850, Sapphire HD5770, XFX HD5770 and a Generic ATI HD3650.

                       

                      Nvidia

                      =====

                      Nvidia Quadro FX 1800, Asus EN8500GT Silent and a XFX GeForce 7600GS.

                       

                      I even tested 2 low profile PCI-x cards (Nvidia and ATI based) from a HP and a Dell system with no change to the POST'ing code.

                       

                      I also tried 2 PCI cards (Diamond S3 Virge and Monster 3Dfx dating back to the late 90’s) but the board refused to boot with them install in any of the 3 PCI slots. The PCI-e and PCI-x slots all work fine.

                       

                      The lower end cards do display what they are on the screen longer compared to the faster cards but that’s the only noticeable difference. They have no effect or change to the POST’ing or getting past the POST code B2.

                       

                      I take it the ‘extreme board’ is nothing more than an ‘extreme paperweight’ now?

                      • 8. Re: Intel DP45SG posting error code B2
                        Ekimus

                        I acquired myself a PCI analyser card and it stops at the same POST code of B2. I am still unable to get past this issue :/