8 Replies Latest reply on Mar 9, 2014 8:33 PM by JasonHoffman

    Nuc does not start

    JulienG

      Hi-

       

      I just purchased a new NUC (DN2820FYKH), ajd it would not start.

      It is equipped with 8gb of ram and a 120gb SSD disk. I am in the process of testing these separately,  but it seems unlikely to be the cause though.

       

      When I launch the device, the white light sets on,  fixed, and I can hear the fan. But nothing comes on screen (tried with a projector and a PC screen). As a matter of fact, even the USB keyboard does not light.

       

      Could you please let me know if you can think of ways to sort this out?

       

      Thanks.

       

      Julien

        • 1. Re: Nuc does not start
          HellDiverUK

          These things are very fussy about the display they're connected to when using the factory BIOS. 

           

          Mine was the same, it wouldn't display or boot using a Dell 19" monitor and a HDMI to DVI cable.  I was able to get it to display the BIOS on my old 32" Toshiba TV.  That got me in to the BIOS, where I was able to upgrade the BIOS to 0025.  That cured all the issues.

           

          Also when you do get it working, you need to make sure to boot using UEFI when installing the OS, my 2820 kept on locking up and hanging when using Legacy boot from USB trying to install Windows 7.

          • 2. Re: Nuc does not start
            LesMoss

            That's the exact opposite of my experience installing Win 7 64 (preSP1) from USB DVD. I had to use Legacy boot to install and continue to run in Legacy.

             

            Did you use SP1? From DVD or USB Drive?

             

            Confusingly, the BIOS 0025 instructions say to use UEFI for 64 bit and  Legacy for 32 bit.

            • 3. Re: Nuc does not start
              HellDiverUK

              I created a UEFI boot USB stick.  I used a Windows program called "Rufus" which creates the boot stick using an ISO file. I used the Windows 7 Professional x64 ISO downloaded from Technet. 

               

              Creating a boot stick is easy enough, but making it UEFI is tricky, Rufus makes it simple.

              • 4. Re: Nuc does not start
                LesMoss

                That answers the question. The raw disk has a legacy bootloader, but Rufus makes it UEFI.

                 

                Once installed that way, do you continue to run UEFI or do you switch to Legacy? I would think the Windows installer would write a Legacy Boot on the hard disk, unless Rufus does some more extensive tweaking.

                 

                These alternatives should be explained in the BIOS 0025 instructions.

                • 5. Re: Nuc does not start
                  HellDiverUK

                  I left it in UEFI.  Booting off the Crucial M4 64GB mSATA drive (not the fastest SSD in the world) from off to Windows 7 login is less than 5 seconds.

                   

                  You can build the UEFI boot disk, but it's a fiddle having to change the bootloaders and such like, that app does it automagically.

                  • 6. Re: Nuc does not start
                    LesMoss

                    FYI, Legacy boot from a USB stick also requires that Legacy USB Support be turned on. That may have been your original problem.

                     

                    I consider that a BIOS bug.

                    • 7. Re: Nuc does not start
                      JulienG

                      Thanks guys, it helps.

                      I was afraid of this as I don't have any other display at hand... Guess that I will need to find one to flash the bios...

                       

                      I tried to connect to the projector directly (without going through my AV receiver) and it behaves as if it tried to switch to a different resolution but ends up not being able to display anything either. This is quite frustrating.

                       

                      I also find a bit strange that the USB keyboard does not lit. It looks like the usb ports do not get powered initially when the device is switched on. Anyone can confirm this behavior?

                       

                      Thanks

                       

                      Julien

                      • 8. Re: Nuc does not start
                        JasonHoffman

                        JulienG,

                         

                        Just starting with the basics: did you make sure to use 1.35v memory?  What you describe could be a memory incompatibility issue.

                         

                        Thanks.

                         

                        Jason