3 Replies Latest reply on Mar 15, 2014 9:00 AM by AlexT_Intel

    Galileo no longer seen by OS

    joaocandre

      I'm running Arch Linux to develop on an Intel Galileo. I just received it this week, and everything was working fine until I lost DC power while connected to USB. Now the board doesn't seem to be connected to the computer, even though both power and usb LEDs on the board are ON. The "serial port" port entry on the Galileo IDE is now disabled - before it showed the /dev entry corresponding to the device. Seeing that DC power should always be connected before USB, did I bricked the Galileo board when I lost power while on USB ?

        • 1. Re: Galileo no longer seen by OS
          AlexT_Intel

          did I bricked the Galileo board when I lost power while on USB

          Yes, that might be the case, though in this case it's not totally bricked (at least these several cases reported so far for similar circumstances were able to recover), you may be able to restore that using DediProg. The best way to diagnose that is to take a look at the serial console using the 3.5 mm to serial cable - it will show you what's happening there. I assume you've tried the usual magic of rebooting your PC and power cycling Galileo, right?

           

          An indirect way to check would be to use the SD card linux image, ensure that your home network has a DHCP server, which is setup to give out IP to the Galileo board, plug the ethernet cable into Galileo, plug in the power supply and check if the DHCP server has given out the IP, then try to SSH there. If the board boots, it will get the IP and you should be able to connect via SSH.

          • 2. Re: Galileo no longer seen by OS
            robotdad

            I'm seeing the same thing with some of mine. I can boot from an SD image and connect to the device via ssh. The device no longer shows up on USB though. I tried connecting to another machine and no dice there either. The other machine had never had one connected to it before. I also tried connecting a fresh one out of the box and it isn't seen on either the machine previously used or the machine that had not been setup with drivers yet.

             

            This is all on Windows 8.1, I've not tried from a Mac yet.

            • 3. Re: Galileo no longer seen by OS
              AlexT_Intel

              To be honest, that looks more like a problem with host-side drivers to me, more than with Galileo itself. On the Galileo side it's as simple as one kernel module, which is present and auto-loaded in all the default images and the overall setup is simple enough, so there's not much to break. I can help you to check it out step by step if you're interested.

               

              Do you have a 3.5mm to USB (or to 3.5mm-to-serial+serial-to-USB) cable to be able to connect to the serial console directly? That would make the troubleshooting noticeably easier.